Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 336077 - dev-python/numpy-1.5.0: sandbox violation when no valid icc and ifc
Summary: dev-python/numpy-1.5.0: sandbox violation when no valid icc and ifc
Status: RESOLVED DUPLICATE of bug 333423
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-05 10:32 UTC by Martin Mokrejš
Modified: 2010-10-23 12:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,153.25 KB, text/plain)
2010-09-05 10:33 UTC, Martin Mokrejš
Details
build.log (build.log,579.58 KB, text/plain)
2010-09-21 16:01 UTC, Martin Mokrejš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2010-09-05 10:32:58 UTC
This is probably a re-incarnation of bug #332657. I have expired license for icc and never had ifc. I would hope that configure is smart enough not to use the compiler if it is not actually working, due to expired license.

>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-20439.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: chmod
S: deny
P: /usr/local/share/macrovision/storage/FLEXnet/INTEL_00211300_tsf.data
A: /usr/local/share/macrovision/storage/FLEXnet/INTEL_00211300_tsf.data
R: /usr/local/share/macrovision/storage/FLEXnet/INTEL_00211300_tsf.data
C: /opt/intel/Compiler/11.1/072/bin/ia32/ifort -FI -V -c /var/tmp/portage/dev-python/numpy-1.5.0/temp/tmpUIJDLp/yOyieX.f -o /var/tmp/portage/dev-python/numpy-1.5.0/temp/tmpUIJDLp/yOyieX.o 


Reproducible: Always
Comment 1 Martin Mokrejš 2010-09-05 10:33:23 UTC
Created attachment 246112 [details]
build.log
Comment 2 Martin Mokrejš 2010-09-05 10:37:05 UTC
# emerge -pv numpy

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-python/numpy-1.5.0 [1.4.1] USE="lapack -doc -test" 0 kB


# emerge --info
Portage 2.1.9 (default/linux/x86/10.0/desktop, gcc-4.4.4, glibc-2.12.1-r1, 2.6.27.52 i686)
=================================================================
System uname: Linux-2.6.27.52-i686-Mobile_Intel-R-_Pentium-R-_4_-_M_CPU_1.80GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 04 Sep 2010 09:45:03 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 1.3.7-r1, 2.1.11
dev-lang/python:     2.5.4-r4, 2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.2
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13::<unknown repository>, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.3.6-r1, 4.2.4-r1, 4.3.5, 4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Nero-EULA-US skype-eula AdobeFlash AdobeFlash-10 AdobeFlash-10.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -pipe -fno-strict-aliasing -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind /var/lib/hsqldb /var/qmail/alias /var/qmail/control /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/portage /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -pipe -fno-strict-aliasing -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distcc distlocks fixlafiles fixpackages metadata-transfer news nostrip parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirror.web4u.cz"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en cs cz"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="32bit 7zip R X Xaw3d a52 aac aalib ace acl acpi alsa amr amrnb amrwb apache audacious audiofile bash-completion bcmath berkdb blas bluetooth boost branding bzip2 cairo caps cblas cddb cdparanoia cdr cgi clamav cli colordiff compress consolekit cpio cracklib crypt cscope css ctype cups curl curlwrappers cxx dbi dbus dga dia directfb djbfft dri dts dv dvb dvd dvdr dvdread emboss emf enblend encode enscript exif expat faad fam fame fat fbcon ffmpeg fftw firefox flac flash fortran fpx ftp gcj gd gdbm ggi gif gimp gimpprint glibc-compat20 glibc-omitfp glut gmp gnuplot gnutls gpgme gphoto2 gpm graphviz gs gsl gsm gtk gtkhtml hal hdf hdf5 hp2xx i8x0 icc iconv icu id3 ieee1394 imagemagick imlib inifile innodb ithreads jack java javascript jbig jce jikes jpeg jpeg2k kdtree kerberos lame lapack laptop lcms leim libcaca libnotify libwww live lzo lzw mad maildir matroska mhash mikmod mime ming mjpeg mmap mmx mng mod_python modperl modplug modules motif mozilla moznoirc mp2 mp3 mp4 mpeg mpi mpi_njtree mpich2 mplayer mudflap mule musepack mxdatetime mysql mysqli nat ncurses netcdf netpbm network nls nntp nptl nptlonly nsplugin ntfs numeric objc ogg opengl openmp openssl pam pango pcmcia pcntl pcre pdf perl plotutils plugin png pnm postproc postscript ppds pppd procmail pymol python qt3support qt4 quicktime rar raw readline recode reflection reiserfs romio rpm samba sasl scanner scp seamonkey server session sftp sift slp smime sndfile soap sockets spell spl sqlite srt sse sse2 ssl startup-notification subtitles subversion svg svgz sysfs sysvipc t1lib tcl tcpd theora threads tidy tiff tk transcode truetype unicode urandom usb userlocales utils uuencode v4l v4l2 vcd vhook vim-syntax vim-with-x vorbis wifi win32codecs wmf wxwindows x264 x86 xanim xcb xcf xfs xft xinerama xinetd xml xorg xpm xsl xslt xulrunner xv xvid xvmc yv12 zip zlib" ALSA_CARDS="intel-8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config mem_cache mime mime_magic rewrite setenvif speling status unique_id userdir usertrack vhost_alias negotiation" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs cz" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Dirkjan Ochtman gentoo-dev 2010-09-07 07:19:49 UTC
I'm tempted to say this is your responsibility, but if you have an easy way of detecting the expired license, maybe we can do something about it.
Comment 4 Martin Mokrejš 2010-09-07 09:15:23 UTC
Please note gcc was used for src_compile(). I just do not known why ifort comes into play at src_install().
Comment 5 François Bissey 2010-09-07 09:24:57 UTC
(In reply to comment #4)
> Please note gcc was used for src_compile(). I just do not known why ifort comes
> into play at src_install().
> 

scons.... scons is terrible at detecting compilers by itself and wanting to use them. intel compilers in particular. On the other hand I'd like to know how it detect ifort and tries to run it if you never install it. Anything at all at:
/opt/intel/Compiler/11.1/072/bin/ia32/ifort ?
Comment 6 François Bissey 2010-09-07 09:45:07 UTC
Which makes me thinks, since numpy generates a sconstruct and seems to run it,
shouldn't numpy depend on scons? And by the way Martin which scons version
do you have installed?
Comment 7 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-09-08 09:59:35 UTC

*** This bug has been marked as a duplicate of bug 335908 ***
Comment 8 Martin Mokrejš 2010-09-21 14:53:03 UTC
Hi, sorry for the delay in my answer. I just resynced my portage tree and retried, same result. I do not have the  -limf linking issue (bug #335908) so I do not think this is a dupe. Notably, I do have dev-util/scons-1.3.0_p20100501 installed while have NOT dev-python/numscons installed at all. Therefore, the dependencies on scons/numscons should be fixed somehow as well.

I have upgraded to dev-util/scons-2.0.1 now and re-tried "ebuild numpy-1.5.0-r2.ebuild install" but that did not help. Probably I have to recompile, if at all, actually, buy the ifort license. ;)
Comment 9 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-09-21 15:00:21 UTC
(In reply to comment #8)
> the dependencies on scons/numscons should be fixed somehow as well.

dev-python/numpy builds correctly for me (with gcc) without scons/numscons.
Comment 10 Martin Mokrejš 2010-09-21 15:32:58 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Please note gcc was used for src_compile(). I just do not known why ifort 
> > comes into play at src_install().
> > 
> 
> scons.... scons is terrible at detecting compilers by itself and wanting to 
> use them. intel compilers in particular. On the other hand I'd like to know
> how it detect ifort and tries to run it if you never install it. Anything at
> all at: /opt/intel/Compiler/11.1/072/bin/ia32/ifort ?

$ ls -la /opt/intel/Compiler/11.1/072/bin/ia32/
total 120440
drwxr-xr-x 4 root root     4096 Aug 23 23:05 .
drwxr-xr-x 3 root root     4096 Aug 23 23:05 ..
-rwxrwxr-x 1 root root  1566153 Apr 15 05:16 codecov
drwxr-xr-x 2 root root     4096 Aug 23 23:05 en_US
-rwxrwxr-x 1 root root 23381574 Apr 15 05:16 fortcom
-rwxrwxr-x 1 root root   150485 Apr 15 05:16 fpp
-rw-rw-r-- 1 root root   355756 Mar 31 16:45 ia32.xrd
-rwxr-xr-x 1 root root  3231033 Apr 15 05:16 icc
-rwxrwxr-x 1 root root       13 Aug 23 23:02 icc.cfg
-rwxrwxr-x 1 root root     3287 Aug 23 23:02 iccvars_ia32.csh
-rwxrwxr-x 1 root root     3609 Aug 23 23:02 iccvars_ia32.sh
-rwxr-xr-x 1 root root  3231033 Apr 15 05:16 icpc
-rwxrwxr-x 1 root root       15 Aug 23 23:02 icpc.cfg
-rwxr-xr-x 1 root root     3344 Aug 23 23:02 idb
-rwxr-xr-x 1 root root     3123 Mar 31 16:45 idb.el
-rwxr-xr-x 1 root root      866 Aug 23 23:02 idbc
-rw-rw-r-- 1 root root      315 Aug 23 23:02 idbvars.csh
-rw-rw-r-- 1 root root      335 Aug 23 23:02 idbvars.sh
-rwxr-xr-x 1 root root  3207277 Apr 15 05:16 ifort
-rw-rw-r-- 1 root root       63 May 31 19:57 ifort.cfg
-rwxrwxr-x 1 root root     3286 May 31 19:57 ifortvars_ia32.csh
-rwxrwxr-x 1 root root     3573 May 31 19:57 ifortvars_ia32.sh
-rwxr-xr-x 1 root root 13761916 Mar 31 16:45 iidb
drwxr-xr-x 2 root root     4096 Aug 23 23:05 ja_JP
-rwxrwxr-x 1 root root   323771 Apr 15 05:16 map_opts
-rwxrwxr-x 1 root root 20413721 Apr 15 05:16 mcpcom
-rwxrwxr-x 1 root root    68153 Apr 15 05:16 prelink
-rwxrwxr-x 1 root root   106411 Apr 15 05:16 profdcg
-rwxrwxr-x 1 root root   202933 Apr 15 05:16 profmerge
-rwxrwxr-x 1 root root   132250 Apr 15 05:16 proforder
-rwxrwxr-x 1 root root 22498716 Apr 15 05:16 svcpcom
-rwxrwxr-x 1 root root 25786221 Apr 15 05:16 svfortcom
-rwxrwxr-x 1 root root  1308517 Apr 15 05:16 tselect
-rwxrwxr-x 2 root root    64678 Apr 15 11:06 uninstall_cproc.sh
-rwxrwxr-x 1 root root    64678 Apr 15 12:49 uninstall_cprof.sh
-rwxrwxr-x 2 root root    64678 Apr 15 11:06 uninstall_debugger.sh
-rwxrwxr-x 1 root root  1451444 Apr 15 05:16 xiar
-rwxrwxr-x 1 root root  1651562 Apr 15 05:16 xild
$

Do not know ja_JP/ is there, btw, does not match my LINGUAS.


Comment 11 Sébastien Fabbro (RETIRED) gentoo-dev 2010-09-21 15:47:10 UTC
numpy does not use numscons in gentoo. so could you post your build log, and do you actually have a valid ifort license?

Comment 12 Martin Mokrejš 2010-09-21 15:49:49 UTC
(In reply to comment #11)
> numpy does not use numscons in gentoo. so could you post your build log, and do
> you actually have a valid ifort license?

Well, for me _builds_ fine actually without as well. But if that is optional still USE flag should exist to hint users they might want to install it?

This bugreport should be in my eyes only about the sandbox violation issue anyways. ;)
Comment 13 Martin Mokrejš 2010-09-21 16:01:14 UTC
Created attachment 248278 [details]
build.log

Attaching current build.log, do not know if it differs from the previous actually. ;-) No, I do NOT have ifort license and won't have.

A simple check for valid license:

# ifort

Error: A license for FComp is not available (-5,357).

Make sure that a license file is being used that contains a license
for the requested feature.  If your license requires a license server,
make sure that the server is using the right license file (usually,
this would be the same license file that is being used by this
application), and make sure that you have not changed the license
file since starting the server.

License file(s) used were (in this order):
    1.  Trusted Storage
**  2.  /opt/intel/Compiler/11.1/072/Licenses
**  3.  /root/intel/licenses
**  4.  /opt/intel/licenses/EVAL_L_CMP_CPP_VXM4-MP475JVT.lic
**  5.  /opt/intel/licenses/l_cpp_21985136.lic
**  6.  /Users/Shared/Library/Application Support/Intel/Licenses
**  7.  /opt/intel/Compiler/11.1/072/bin/ia32/*.lic

Please visit http://software.intel.com/sites/support/ if you require technical assistance.

ifort: error #10052: could not checkout FLEXlm license
#
Comment 14 SpanKY gentoo-dev 2010-09-25 05:51:10 UTC
is this just a dupe of bug 333423 ?
Comment 15 Martin Mokrejš 2010-09-25 08:34:07 UTC
(In reply to comment #14)
> is this just a dupe of bug 333423 ?

Here are several issues:
1. I have USE=gfortran so no ifort should be used (indeed, it is not for src_compile() but during src_install() ifort is picked up)
2. why actually sandbox violation happens .. it seems you are right that bug #333423 has an explanation what ifort is doing

Comment 16 Justin Lecher (RETIRED) gentoo-dev 2010-10-23 12:32:57 UTC

*** This bug has been marked as a duplicate of bug 333423 ***