Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 335801 - dev-lisp/ecls does not respect LDFLAGS
Summary: dev-lisp/ecls does not respect LDFLAGS
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Common Lisp Bugs
Depends on:
Blocks: ldflags
  Show dependency tree
Reported: 2010-09-03 13:07 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2015-11-08 10:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Build log (ecls-10.4.1:20100903-090913.log,499.99 KB, text/plain)
2010-09-03 13:08 UTC, Diego Elio Pettenò (RETIRED)
patch against latest ebuild (ebuild.patch,314 bytes, patch)
2013-04-01 15:06 UTC, Michael Mair-Keimberger (iamnr3)
Details | Diff
build.log (ecls-13.5.1:20130718-152323.log,934.00 KB, text/x-log)
2013-07-18 15:36 UTC, Michael Mair-Keimberger (iamnr3)

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-09-03 13:07:50 UTC
See attached build log.

(Please do not complain about the need for looking at the build log until you can provide an easy way to open bugs with the correct data picked out of a tinderbox log. Thanks.)
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-09-03 13:08:14 UTC
Created attachment 245855 [details]
Build log
Comment 2 Michael Mair-Keimberger (iamnr3) 2013-04-01 15:06:42 UTC
Created attachment 343940 [details, diff]
patch against latest ebuild

I've added an simple sed fix for the latest ebuild which should fix the ldflags issue. Please have a look at it.
Comment 3 Andrey Grozin gentoo-dev 2013-07-02 04:07:48 UTC
Seems to be fixed in 13.5.1. Could you please check?
Comment 4 Michael Mair-Keimberger (iamnr3) 2013-07-18 15:36:29 UTC
Created attachment 353596 [details]

Doesn't seems so. I still get: 

 [33;01m*[0m [31;01mQA Notice: Files built without respecting LDFLAGS have been detected[0m
 [33;01m*[0m  Please include the following list of files in your report:
 [33;01m*[0m /usr/lib64/ecl-13.5.1/dpp

I've also attached the full build.log
Comment 5 Pacho Ramos gentoo-dev 2015-11-08 10:13:24 UTC
looks solved in dev-lisp/ecls-16.0.0