Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 334871 - app-text/gtkspell-2.0.16 missing dev-perl/XML-Parser dependency
Summary: app-text/gtkspell-2.0.16 missing dev-perl/XML-Parser dependency
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-27 20:06 UTC by John (EBo) David
Modified: 2010-08-27 21:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John (EBo) David 2010-08-27 20:06:08 UTC
gtkspell requires the XML::Parser perl module to configure, but it is not included in the ebuilds dependencies. Here are a few lines of the build log for confirmation:

checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.12.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

After installing XML-Parser, gtkspell builds as expected.
Comment 1 Jeroen Roovers gentoo-dev 2010-08-27 20:20:29 UTC
You may need to run perl-cleaner first.
Comment 2 Jeroen Roovers gentoo-dev 2010-08-27 20:25:19 UTC
.
Comment 3 Jeroen Roovers gentoo-dev 2010-08-27 20:25:28 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 4 John (EBo) David 2010-08-27 21:08:46 UTC
Why not add "perl-cleaner --reallyall" or similar to perl's ebuild pkg_postins and make this automatic every time perl is updated or downgraded?  I have not programmed in perl in a decade, and have no idea of the nuances of maintaining a working perl installation on my cluster nor home machines.  

Also, the last time I updated perl the cleaner_msg was buried in the middle of output from 265 packages that were updated in the middle of the night, and I never saw the message.