Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 334105 - sys-devel/distcc: xorg-server build enters endless loop "libtool: compile: Waiting for --shave-mode=compile.o.lock to be removed"
Summary: sys-devel/distcc: xorg-server build enters endless loop "libtool: compile: Wa...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: ARM Linux
: High normal (vote)
Assignee: Gentoo Cluster Team
Depends on:
Reported: 2010-08-23 17:07 UTC by John L. Poole
Modified: 2022-05-31 07:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,397.52 KB, text/plain)
2010-08-24 14:52 UTC, John L. Poole
emerge --info x11-base/xorg-server (emerge-info_x11-base-xorg-server,3.80 KB, text/plain)
2010-08-24 14:53 UTC, John L. Poole
environment (environment,139.50 KB, text/plain)
2010-08-24 14:53 UTC, John L. Poole

Note You need to log in before you can comment on or make changes to this bug.
Description John L. Poole 2010-08-23 17:07:18 UTC
updating  x11-base/xorg-server-1.7.7-r1 causes ebuild to enter endless loop of:
libtool: compile: Waiting for --shave-mode=compile.o.lock to be removed

Reproducible: Always

Steps to Reproduce:
1. emerge  x11-base/xorg-server-1.7.7-r1

Actual Results:  
Making all in doc
Making all in include
Making all in dix
libtool: compile: Waiting for --shave-mode=compile.o.lock to be removed
libtool: compile: Waiting for --shave-mode=compile.o.lock to be removed

Expected Results:  
successful build
Comment 1 Eray Aslan gentoo-dev 2010-08-24 14:31:22 UTC
Please attach the full build log and emerge --info =x11-base/xorg-server-1.7.7-r1 output.  Thank you.
Comment 2 John L. Poole 2010-08-24 14:52:38 UTC
Created attachment 244409 [details]
Comment 3 John L. Poole 2010-08-24 14:53:08 UTC
Created attachment 244411 [details]
emerge --info x11-base/xorg-server
Comment 4 John L. Poole 2010-08-24 14:53:34 UTC
Created attachment 244413 [details]
Comment 5 John L. Poole 2010-08-24 14:54:50 UTC
I apologize for not having the information immediately available, I filed another unrelated bug around the same time and forgot to attend to this one.
Comment 6 Rémi Cardona (RETIRED) gentoo-dev 2010-09-22 06:47:04 UTC
Please try with distcc disabled.

Comment 7 John L. Poole 2010-09-22 17:38:44 UTC
I turned the distcc off and emerged and it worked.  Thank you.
What can be done to identify what caused the problem for distcc?  It seems that since the emerged worked without distcc then there is a problem with distcc that needs to be identified and addressed. Is there a team that oversees distcc and should this bug be assigned to them?  I can provide ebuild information (using preserve) on the build process that can be analyzed and compared if desired.
Comment 8 Rémi Cardona (RETIRED) gentoo-dev 2010-09-22 18:32:21 UTC
Comment 9 Rémi Cardona (RETIRED) gentoo-dev 2010-09-22 18:33:04 UTC
Reassigning. Thanks
Comment 10 cJ 2014-10-26 21:33:19 UTC

I don't think this issue is particular to xorg, I encountered it for a lot of package (but it was when doing OpenEmbedded builds, not even Gentoo).
It seems that libtool doesn't like it when gcc writes to stderr when doing configuration tests, and this can happen with distcc... this can lead to issues when running conftests (I have seen yesterday that printing to stderr (eg. DISTCC_VERBOSE=1 during -fPIC -DPIC tests would cause libraries to not use PIC...) or when compiling stuff (for some reason the "shave" macros, used by some packages has this issue).
Probably libtool developers figured out that checking for gcc return code wasn't enough... and wanted to ensure that nothing goes on stderr too. That sounds stupid, but that's what is happening.