Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 334017 - net-libs/xulrunner- fails to compile on amd64 with USE="DEBUG"
Summary: net-libs/xulrunner- fails to compile on amd64 with USE="DEBUG"
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
: 337079 348823 (view as bug list)
Depends on:
Reported: 2010-08-22 21:41 UTC by p11
Modified: 2011-10-31 21:44 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

Build.log (build.log,145.12 KB, text/plain)
2010-08-22 21:49 UTC, p11
Build.log (build.log,145.12 KB, text/plain)
2010-08-22 22:53 UTC, p11

Note You need to log in before you can comment on or make changes to this bug.
Description p11 2010-08-22 21:41:36 UTC
hello I am unable to install xulrunner or anything that depends on it i.e. VLC,firefox

x86_64-pc-linux-gnu-g++ -o NativeX64.o -c -I./../../dist/system_wrappers_js -include ./config/gcc_hidden.h -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -DEXPORT_JS_API  -DJS_USE_SAFE_ARENA  -I. -I. -I./../../dist/include -I./../../dist/include/nsprpub  -I/usr/include/nspr   -I.    -fPIC  -I/usr/include -fno-rtti -fno-handle-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Wno-long-long -pipe -fPIC -Wno-return-type -w -fno-strict-aliasing -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_root -DTRACING -ggdb  -I/usr/include -DMOZILLA_CLIENT -include ./js-confdefs.h -Wp,-MD,.deps/NativeX64.pp ./nanojit/NativeX64.cpp
./nanojit/NativeX64.cpp: In member function 'void nanojit::Assembler::underrunProtect(ptrdiff_t)':
./nanojit/NativeX64.cpp:1405: error: no matching function for call to 'nanojit::Assembler::codeAlloc(nanojit::NIns*&, nanojit::NIns*&, nanojit::NIns*&)'

"Emerge --info"
Portage (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.10.1-r1, 2.6.34-gentoo-r1 x86_64)
System uname: Linux-2.6.34-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_6000+-with-gentoo-1.12.13
Timestamp of tree: Sat, 07 Aug 2010 03:30:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aac acl aiglxkde amd64 aoss asf berkdb bzip2 cli cracklib crypt cups cxx dbus debug dri dvd external-fuse fam fortran gdbm gif gpm hal iconv ipv6 java kde mad mmx modules mp3 mp4 mudflap multilib ncurses new-login nls nptl nptlonly nsplugin opengl openmp pam pcre pdftruetype perl png pppd python qt3 qt3support qt4 rdesktopalsa readline realmmx reflection screensaver semantic-desktop session spell spl sql sqlite sse sse2 ssl suid svg symlink sysfs tcpd threadssamba tiff udev unicode webkit x x264 xcomposite xinerama xmljpeg xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

I've also rebuilt dev-libs/nss and dev-libs/nspr
Comment 1 p11 2010-08-22 21:49:35 UTC
Created attachment 244109 [details]

this is the xulrunner build.log
Comment 2 Harald van Dijk (RETIRED) gentoo-dev 2010-08-22 21:49:52 UTC
This probably only happens with USE=debug, which you really shouldn't set globally. Could you please unset that, and retry the build? It needs to get fixed either way, though.
Comment 3 p11 2010-08-22 22:53:55 UTC
Created attachment 244119 [details]

this is the xulrunner build.log
Comment 4 Harald van Dijk (RETIRED) gentoo-dev 2010-08-23 00:17:54 UTC
(In reply to comment #3)
> Created an attachment (id=244119) [details]

This is exactly the same as what you had already attached, including having USE=debug set.
Comment 5 Kobboi 2010-09-08 12:31:12 UTC
I can also not compile xulrunner- (no USE=debug)
Comment 6 Kobboi 2010-09-08 12:31:47 UTC
(In reply to comment #5)
> I can also not compile xulrunner- (no USE=debug)

Disregard, I am trying to compile
Comment 7 Jory A. Pratt gentoo-dev 2010-09-13 14:05:36 UTC
*** Bug 337079 has been marked as a duplicate of this bug. ***
Comment 8 Jory A. Pratt gentoo-dev 2010-12-28 03:16:20 UTC
*** Bug 348823 has been marked as a duplicate of this bug. ***
Comment 9 ablepharus 2011-01-13 21:24:48 UTC
Confirm with xulrunner with use="debug", no problem without debug flag.
Comment 10 Jory A. Pratt gentoo-dev 2011-01-14 16:56:39 UTC
(In reply to comment #9)
> Confirm with xulrunner with use="debug", no problem without debug
> flag.

Can anyone test the mozilla overlay and ensure we have fixed it upstream, if not I need to get a bug open so we can block final release as soon as possible.
Comment 11 Cyprien Nicolas (fulax) 2011-01-14 17:09:22 UTC
(In reply to comment #10)
> Can anyone test the mozilla overlay and ensure we have fixed it upstream, if
> not I need to get a bug open so we can block final release as soon as possible.
xulrunner-2.0 from the mozilla overlay compiled fine as long as sqlite was built with USE=debug if one want to use the system sqlite with xulrunner.

I ran it for the whole day, without any issues, except the slowness.

net-libs/xulrunner-2.0_beta9_pre-r3  USE="alsa custom-optimization dbus debug ipc libnotify startup-notification system-sqlite webm -gnome -wifi"
Comment 12 Jaak Ristioja 2011-07-07 20:45:02 UTC
Bug still present in net-libs/xulrunner-
Comment 13 Jory A. Pratt gentoo-dev 2011-10-31 21:44:47 UTC
Has been fixed in firefox-7.