Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333991 - net-misc/tigervnc-1.0.1_p20100529: aborts with error "Security type not supported"
Summary: net-misc/tigervnc-1.0.1_p20100529: aborts with error "Security type not suppo...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Raúl Porcel (RETIRED)
Depends on:
Reported: 2010-08-22 17:45 UTC by David Suarez
Modified: 2010-08-27 20:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description David Suarez 2010-08-22 17:45:17 UTC
When trying to connect to a VNC server (vnc4server, version 4.1.1+xorg1.0.2-0ubuntu7). vncviewer logs the following:

$vncviewer -log *:stdout:100

TigerVNC Viewer for X version 1.0.90 - built Aug 17 2010 17:52:57
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 TightVNC Group
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See for information on TigerVNC.

Sat Aug 21 17:07:09 2010
 Config:      set AutoSelect(Bool) to 1
 Config:      set CustomCompressLevel(Bool) to 0
 CConn:       connected to host port 5900
 CConnection: reading protocol version
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: processing security types message
 CConnection: Server offers security type None(1)
 CConnection: Choosing security type None(1)
 main:        Security type not supported

I've also tried connecting to a VNC server created with x11vnc and I got the same result.

Reproducible: Always

Steps to Reproduce:
1.emerge net-misc/tigervnc-1.0.1_p20100529
2.Try to connect to a VNC server with vncviewer

Actual Results:  
vncviewer displays the error: "Security type not supported"

Expected Results:  
Display of a remote window.
Comment 1 Johan Hovold 2010-08-23 13:13:44 UTC
I have the same problem connecting to x11vnc with tigervnc-1.0.1_p2010052.

You can add

    -SecurityTypes None

as an argument to tigervnc as a workaround.
Comment 2 pierre 2010-08-25 15:19:37 UTC
same here with tigervnc-1.0.1_p2010052-r2

Comment 3 pierre 2010-08-25 15:33:53 UTC
googling, I found out that it's not a gentoo bug : see

if I understood it well, SecurityTypes is mandatory if server offers more than one type, and can be one of VncAuth,TLSNone,None.
Comment 4 Raúl Porcel (RETIRED) gentoo-dev 2010-08-27 20:22:06 UTC
Correct. Its a problem in the software itself, not something we can fix. So blame upstream