Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333923 - dev-db/mysql-5.1.50: /usr/include/mysql/my_global.h fails php-5.3.3
Summary: dev-db/mysql-5.1.50: /usr/include/mysql/my_global.h fails php-5.3.3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux MySQL bugs team
: 334009 334013 362831 (view as bug list)
Depends on:
Blocks: CVE-2010-1621
  Show dependency tree
Reported: 2010-08-22 09:17 UTC by fkhp
Modified: 2011-07-28 18:57 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

Build log for USE="mysqli" emerge -1 dev-lang/php (build.log,410.22 KB, text/plain)
2010-08-24 10:14 UTC, Ian Abbott
Patch to include my_compiler.h (5.1.50_include_missing_my_compiler_h.patch,960 bytes, patch)
2010-08-24 11:03 UTC, Ian Abbott
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description fkhp 2010-08-22 09:17:57 UTC
/usr/include/mysql/my_global.h:626:25: error: my_compiler.h: No such file or directory

Reproducible: Always
Comment 1 fkhp 2010-08-22 09:18:53 UTC
Comment 2 Ian Abbott 2010-08-23 17:02:32 UTC
Also reported (less concisely) in bug #334013.
Comment 3 Ian Abbott 2010-08-23 17:35:47 UTC
Here is a (possibly incomplete) list of bugs regarding the broken my_global.h (it does a #include <my_compiler.h>, which doesn't exist).

Bug #334009
Bug #334013
Bug #334021 (resolved as "FIXED" but I don't know why).
Comment 4 Ian Abbott 2010-08-23 17:43:41 UTC
Please assign to
Comment 5 SpanKY gentoo-dev 2010-08-24 01:39:06 UTC
reporter needs to post `emerge --info` and full build log as an attachment first
Comment 6 Ian Abbott 2010-08-24 10:14:32 UTC
Created attachment 244379 [details]
Build log for USE="mysqli" emerge -1 dev-lang/php

I'm not the reporter, but I've attached a build log showing the failure.  Note that php needs to be built with the "mysqli" use flag to exhibit the failure.

Steps to reproduce:
1. emerge -1 =dev-db/mysql-5.1.50
2. USE="mysqli" emerge -1 =dev-lang/php-5.3.3-r1

# emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r2-ija1 x86_64)
System uname: Linux-2.6.35-gentoo-r2-ija1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3800+-with-gentoo-2.0.1
Timestamp of tree: Mon, 23 Aug 2010 10:45:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.2
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.3.6-r1, 3.4.6-r2, 4.2.4-r1, 4.3.5, 4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=k8 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage"
USE="X a52 aac acl acpi adns alsa amd64 avahi berkdb branding bzip2 cairo cdr cgi cjk cli consolekit cracklib crypt cscope cups curl cxx dbus djvu doc dri dts dv dvd dvdr eds emboss encode esd evo exif expat fam ffmpeg firefox flac flash fortran gdbm gif glut gmp gnome gnome-keyring gnutls gpm graphviz gstreamer gtk gtkhtml guile hal htmlhandbook iconv idn imagemagick imap imlib ipod ipv6 java jpeg kde kerberos lcms ldap libnotify mad mikmod mmx mng modules mono motif mozsvg mp3 mp4 mpeg mudflap multilib musicbrainz ncurses nls no-helper nptl nptlonly nsplugin offensive ogg opengl openmp pam pango pcre pdf perl plotutils png policykit ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rdesktop readline reflection ruby samba sasl sdl semantic-desktop session slang snmp spell spl sqlite sse sse2 ssl startup-notification svg sysfs tcl tcltk tcpd tetex threads tiff tk truetype unicode usb vnc vorbis x264 xcb xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon ati vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 7 Ian Abbott 2010-08-24 11:03:49 UTC
Created attachment 244387 [details, diff]
Patch to include my_compiler.h

I'm not sure about the procedure for including this in the mysql-extras patchset, but this patch should cause my_compiler.h to be installed, thus preventing the problem.
Comment 8 Ian Abbott 2010-08-24 16:08:45 UTC
Upstream patch (pending review):
Comment 9 Christian Faulhammer (RETIRED) gentoo-dev 2010-09-01 09:42:01 UTC
*** Bug 334013 has been marked as a duplicate of this bug. ***
Comment 10 Christian Faulhammer (RETIRED) gentoo-dev 2010-09-01 09:42:12 UTC
*** Bug 334009 has been marked as a duplicate of this bug. ***
Comment 11 Mathias Weigt 2010-09-01 12:57:25 UTC
dev-db/myodbc-5.1.6 fails with the same error.
Comment 12 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-09-01 19:03:56 UTC
In 5.1.50-r1.
Comment 13 Attila Tóth 2010-09-02 19:08:42 UTC
Thanks for the fix.
I just don't really see it in the tree despite of robbat2's comment...
Comment 14 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-09-02 19:50:15 UTC
(In reply to comment #13)
> Thanks for the fix.
> I just don't really see it in the tree despite of robbat2's comment...
Err, what mirror are you syncing from? Check it's timestamps and open a bug if it's >2 hours out of date.
Comment 15 Attila Tóth 2010-09-02 21:03:21 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Thanks for the fix.
> > I just don't really see it in the tree despite of robbat2's comment...
> Err, what mirror are you syncing from? Check it's timestamps and open a bug if
> it's >2 hours out of date.

You're right. What I really ment to say is that 5.1.50-r1 should go stable soon...

Thanks: Dw.
Comment 16 Michael Kuhlmann 2010-10-25 09:52:34 UTC
Alas it's still not working with MariaDB. :-(
Comment 17 Sébastien Fabbro (RETIRED) gentoo-dev 2011-07-28 18:57:48 UTC
*** Bug 362831 has been marked as a duplicate of this bug. ***