Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333813 - World update (with paludis-0.52.3) fails because amarok-2.3.1-r2 blocks amarok-utils-2.3.1
Summary: World update (with paludis-0.52.3) fails because amarok-2.3.1-r2 blocks amaro...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-21 15:35 UTC by Christoph Lange
Modified: 2010-08-21 15:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Lange 2010-08-21 15:35:01 UTC
I'm not sure whether this is an error in the media-sound/amarok-utils-2.3.1 or media-sound/amarok-2.3.1-r2 ebuilds, or if they are fine and there is a bug in paludis (0.52.3).  Anyway, I will first try it here, and I will be happy to report this as a paludis bug as well.

amarok blocks amarok-utils.  Maybe there is a good reason for that if you want to build amarok, but it also makes any attempt to update world fail, even if amarok would not be built in the course of that world update.

Reproducible: Always

Steps to Reproduce:
1. have media-sound/amarok-2.3.1 and media-sound/amarok-2.3.1-r2 installed
2. update world
3. fails because amarok blocks amarok-utils
4. Workaround: uninstall amarok-utils without removing it from world (paludis --preserve-world), then update world
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-08-21 15:41:22 UTC
amarok and amarok-utils ebuilds have been merged in amarok-2.3.1-r2. So you need USE="utils player" to have them both installed. Portage should autoresolve the block, I don't know how paludis should handle it though. Closing as invalid. Thanks
Comment 2 Christoph Lange 2010-08-21 15:47:22 UTC
I see – thanks for your help!  I wasn't aware of the merger.  I have these use flags for amarok, so I guess the problem will be solved by simply uninstalling amarok-utils.