Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333639 - NetworkManager gentoo specific e-build enhancement
Summary: NetworkManager gentoo specific e-build enhancement
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Robert Piasek (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-20 16:23 UTC by Sophie Tatch
Modified: 2012-11-15 09:10 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix Bug 333639 (warn_for_kernel_setting.patch,910 bytes, patch)
2010-08-21 02:20 UTC, Mu Qiao (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sophie Tatch 2010-08-20 16:23:08 UTC
Networkmanager

Reproducible: Always

Steps to Reproduce:
A networkmanager problem led to a chat in between me and dcbw on irc.gentoo.org #NM...

We, well actually he, figured out a problem, I proposed a solution.

<dcbw> and it's likely the "net:eth0" thing you see in your earlier fpaste
<dcbw> I've got just "net"
<MisteryTatch> Outcome to what command again?
<dcbw> it's looking like a kernel config thing
<dcbw> so, your kernel is built with CONFIG_SYSFS_DEPRECATED which udev does not work with
--
<MisteryTatch> Yes I did
--
<dcbw> older versions of udev used to work with CONFIG_SYSFS_DEPRECATED, but newer ones dropped that support
--
<MisteryTatch> Should I rebuilt the kernel?
<dcbw> if you do, NM will start working then
<MisteryTatch> Will try, thanks for your help and patience
<MisteryTatch> Will post when its done!
--
<dcbw> basically we should be fixing bugs that CONFIG_SYSFS_DEPRECATED appears to fix, instead of turning that option on
<MisteryTatch> Question though, some packages yap about the kernel missing some settings, isn't it handy to advise, in the NetworkManager's package, about this kernel setting? a grep <kernel setting> = y? Is it already there
<MisteryTatch> Maybe a warning on the echo?
<MisteryTatch> dcbw: "[*] enable deprecated sysfs features to support old userspace tools" that's it, right/
<MisteryTatch> dcbw: / = ?
<dcbw> yeah, that sounds like the one
<dcbw> I think that would more be an issue for the package / distro itself in the build scripts or whatever, so on Gentoo the scripts would check for that since they know that the kernel config will be around
<dcbw> on other distros though, the kernel may be prebuilt and we won't necessarily know
<MisteryTatch> That's right, networkmanager isn't specifically written for gentoo
<MisteryTatch> Shall check for the package maintainer
<dcbw> yeah, that would be best

Actual Results:  
In the e-build there should be checked that:

"[*] enable deprecated sysfs features to support old userspace tools" 

Isn't selected, and when is, maybe post a echo while having a "klean" build.

Expected Results:  
That somebody would take notice... ;)

Mistery
Comment 1 Sophie Tatch 2010-08-20 19:19:58 UTC
I'm sorry for the styling,

What I wanted to say is that 

"[*] enable deprecated sysfs features to support old userspace tools" 

Is bugging with Networkmanager. When it is compiled in the kernel (what I did because of the gnome power manager bug), nm-applet isn't showing the wired and the wireless networks anymore, which has something to do with networkmanager itself isn't managing those anymore.

The enhancement / improvement I figured was that the kernel config should be checked so that when this option is selected a warning about the features of networkmanager could be influenced.

Maybe this describes better what I wanted to say.

Greetings

Mistery
Comment 2 Mu Qiao (RETIRED) gentoo-dev 2010-08-21 02:20:39 UTC
Created attachment 243797 [details, diff]
fix Bug 333639

I created this patch fixing this problem
Comment 3 Robert Piasek (RETIRED) gentoo-dev 2010-08-23 11:54:11 UTC
That should be now fixed in 0.8.1-r4. We will check for CONFIG_SYSFS_DEPRECATED_V2 before configuring NM.

Comment 4 Pavel Šimerda (pavlix) 2012-11-15 09:10:07 UTC
Sorry for commenting on an old bug report... but it occurs to me that what dcbw said is that it's udev struggling with the setting, not NetworkManager.