Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333501 - =app-misc/gpsdrive-2.09-r1[garmin] fails to build (gcc-4.4/glibc-2.11 problem?)
Summary: =app-misc/gpsdrive-2.09-r1[garmin] fails to build (gcc-4.4/glibc-2.11 problem?)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Steve Arnold
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2010-08-19 20:03 UTC by Kobboi
Modified: 2011-06-17 09:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2010-08-19 20:03:55 UTC
In file included from garmin_data.cpp:19:
garmin_data.h: In member function 'char* garmin::D108::Wpt_comment() const':
garmin_data.h:60: error: 'strlen' was not declared in this scope
garmin_data.cpp: In function 'garmin::track_point_type& garmin::operator<<(garmin::track_point_type&, const garmin::D301&)':
garmin_data.cpp:54: error: 'memset' was not declared in this scope
make[2]: *** [garmin_data.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-misc/gpsdrive-2.09-r1/work/gpsdrive-2.09/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-misc/gpsdrive-2.09-r1/work/gpsdrive-2.09'
make: *** [all] Error 2


Reproducible: Always
Comment 1 Kobboi 2010-08-19 20:29:08 UTC
"solved" in the sense that 2.10_pre7 appears to compile without problems :/
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-19 21:49:01 UTC
Please provide emerge --info and reopen if it's still a problem in Portage.

I'm ready to bet the problem is glibc-2.12 anyway.
Comment 3 Kobboi 2010-08-20 17:22:45 UTC
(In reply to comment #2)
> Please provide emerge --info and reopen if it's still a problem in Portage.
> 
> I'm ready to bet the problem is glibc-2.12 anyway.
> 

*buzzer* glibc-2.11.2

$ emerge --info
Portage 2.2_rc67 (default/linux/amd64/10.0/desktop, gcc-4.4.4, glibc-2.11.2-r0, 2.6.35.2 x86_64)
=================================================================
System uname: Linux-2.6.35.2-x86_64-Intel-R-_Core-TM-_i7_CPU_930_@_2.80GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 20 Aug 2010 13:05:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.4.6, 2.6.5-r2, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe -g"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe -g"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildpkg distlocks fixpackages installsources news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/gnome /var/lib/layman/gamerlay /home/christophe/kobboi"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus doc dri dts dvd dvdr emboss encode examples exif fam firefox flac fortran fuse gdbm gif gnome gpm gtk iconv ipv6 jpeg kde lcms ldap libnotify lm_sensors mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-20 19:31:37 UTC
Fun, so either there is something else that changed, or this is one of those failures that we've _still_ not fixed. SIGH.
Comment 5 Steve Arnold gentoo-dev 2010-08-21 04:15:41 UTC
Well, gpsdrive 2.09 is fairly old (from prior to the major upgrades anyway).  I'll be working on more updates to gpsdrive once I update a few other things...
Comment 6 Steve Arnold gentoo-dev 2010-10-19 02:28:33 UTC
gpsdrive-2.11 is now in the tree, and is much more compliant with current tools and libraries.  I'd try that version for now.
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2011-06-17 09:24:48 UTC
Only 2.11 in main tree, that works with the gcc/glibc combo.