Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 333391 - Qt 4.6.3 is built without STL support
Summary: Qt 4.6.3 is built without STL support
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-19 08:22 UTC by Keith Rusler
Modified: 2010-09-03 00:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Qt's configuration file (qconfig.pri,725 bytes, text/plain)
2010-08-21 12:35 UTC, Keith Rusler
Details
Qt-4.7.0rc1 build log (qt470rc1.build,258.78 KB, text/plain)
2010-09-02 23:55 UTC, Keith Rusler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Rusler 2010-08-19 08:22:50 UTC
Qt 4.6.3 doesn't build with STL which I need for my project.

Reproducible: Always
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2010-08-19 22:16:50 UTC
I assume we can add a use flag for it. Objections? Patches are always welcome
Comment 2 Davide Pesavento gentoo-dev 2010-08-19 22:39:55 UTC
WTF? We already pass -stl to the configure script...
Comment 3 Keith Rusler 2010-08-20 00:46:04 UTC
Well when I try use QString::fromStdString() etc like STL features in C++ it says they are not defined.
Comment 4 Davide Pesavento gentoo-dev 2010-08-20 01:59:59 UTC
I can't reproduce. Try re-emerging qt-core please.
Comment 5 Keith Rusler 2010-08-20 03:35:56 UTC
I just recompiled qt-core and can reproduce it again. I don't understand what is going on.


/home/comawhite/projects/TagCorrecting/main.cxx:50:13: error: ‘fromStdString’ is not a member of ‘QString’
Comment 6 Keith Rusler 2010-08-20 03:36:07 UTC
I just recompiled qt-core and can reproduce it again. I don't understand what is going on.


/home/comawhite/projects/TagCorrecting/main.cxx:50:13: error: ‘fromStdString’ is not a member of ‘QString’
Comment 7 Davide Pesavento gentoo-dev 2010-08-21 09:44:59 UTC
Attach /usr/share/qt4/mkspecs/gentoo/qconfig.pri please.
Comment 8 Keith Rusler 2010-08-21 12:35:49 UTC
Created attachment 243845 [details]
Qt's configuration file
Comment 9 Davide Pesavento gentoo-dev 2010-08-21 15:21:53 UTC
(In reply to comment #8)
> Created an attachment (id=243845) [details]
> Qt's configuration file
> 

This shows that stl support is enabled.
So either you're doing something wrong or it's a gcc-4.5 issue.
Comment 10 Keith Rusler 2010-08-21 15:27:15 UTC
It might be a GCC-4.5.x bug, because I don't understand how I'm doing anything wrong. I've done it like it says to use that method in the documentation.
Comment 11 Davide Pesavento gentoo-dev 2010-08-21 15:47:01 UTC
I don't use gcc-4.5 myself, so I'm unable to debug this issue further. You can help by attaching a full build.log of x11-libs/qt-core.
Comment 12 Bartosz Brachaczek 2010-09-02 19:15:25 UTC
FWIW, I have world compiled with GCC 4.5.1 and my Qt 4.6.3 installation has proper STL support. My qconfig.pri differs from Keith's only in that I have a release build, not debug, and I have x86, not x86_64.
Comment 13 Davide Pesavento gentoo-dev 2010-09-02 20:41:58 UTC
Keith, attach your build.log for qt-core please.
Comment 14 Keith Rusler 2010-09-02 23:55:54 UTC
Created attachment 245810 [details]
Qt-4.7.0rc1 build log
Comment 15 Keith Rusler 2010-09-02 23:56:26 UTC
I experienced it also in Qt-4.7.0-rc1, I posted the build log
Comment 16 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-03 00:05:43 UTC
build.log attached, reopening
Comment 17 Keith Rusler 2010-09-03 00:29:35 UTC
I fixed the issue. It seems that it was disabled in my KDE4 project using CMake. I had to use remove_definitions(-DQT_NO_STL) for it to work when building my CMake project with KDE4.