Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 33252 - 2.6beta9 ppc video problem with radeon,drm
Summary: 2.6beta9 ppc video problem with radeon,drm
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High major (vote)
Assignee: PPC Porters
Depends on:
Reported: 2003-11-11 14:02 UTC by Ævar Arnfjörð Bjarmason
Modified: 2006-02-04 06:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ævar Arnfjörð Bjarmason 2003-11-11 14:02:16 UTC
The above url says it all..

Reproducible: Always
Steps to Reproduce:

Portage 2.0.49-r15 (default-ppc-1.4, gcc-3.2.3, glibc-2.3.2-r1,
System uname: 2.4.22-ppc-sources-r0 ppc 
Gentoo Base System version
distcc 2.11.2 powerpc-unknown-linux-gnu (protocols 1 and 2) (default port 3632)
ccache version 2.3 [enabled]
CFLAGS="-mcpu=750 -O3 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.2/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=750 -O3 -pipe"
FEATURES="distcc ccache"
USE="dvd xv nls mitshm gif ppc cups foomaticdb gnome-libs gtkhtml gdbm berkdb
slang readline arts bonobo tcltk guile X sdl gpm tcpd libwww perl python esd
imlib oggvorbis gtk motif cdr -java -gnome -kde -joystick -matrox opengl jpeg
png truetype aalib encode gtk2 qt pam ssl tc pd alsa oss crypt directfb spell
tiff xmms mozilla moznoirc moznomail moznocompose -apache2 radeon ncurses
Comment 1 Luca Barbato gentoo-dev 2003-11-11 14:35:28 UTC
there is a kernel source called ppc-development-sources. please try that
Comment 2 Luca Barbato gentoo-dev 2003-11-22 10:55:50 UTC
may I close that bug?
Comment 3 Kevyn Shortell (RETIRED) gentoo-dev 2003-11-23 23:43:10 UTC
well seeing as how his site that is supposed to clarify what this is, isn't responding..... I'm bouncing back to orginator with not enough info =)

Jeedo, if your going to open a bug, all the info for the bug should be included. If the information isn't in the actual bug report itself, it doesn't exist.

Comment 4 Ævar Arnfjörð Bjarmason 2003-11-24 04:32:43 UTC
This seems to have been fixed in benh-4

The site went down, here is the text of it:

9.Nov 2003

Turns out that wasn't the issue after all, what it is i have no idea.

The only thing i know for sure it that 2.6 is _fucked_. These display errors
appear and disappear at random.

I did eliminate that display error in one configuration though, i cant seem 
to reproduce that though.

Even if the display was working perfectly there are more issues

* pbbuttonsd doesn't seem to work (changed kernel interface?)
* mouse 2+3 button emu doesn't work

Anyway, I'm tired of debugging the kernel. I'll try it again when it comes out 
of the betas.

8.Nov 2003

I forgot to disable the DRM stuff,

It seems that with both "Character devices/Radeon" & "Character devices/Direct 
Rendering Manager" in the the kernel the "psycho video error" is produced.

However with only "Character devices/Radeon" in a slight video distortion 
is produced.

After this kernel compile finishes i will find out for sure what i suspect, 
that this problem can indeed be fixed by having neither of those in but using
the "Character devices/ATI Rage 128" driver instead of the "ATI Radeon" driver.

8.Nov 2003

#gentoo-ppc irclog

<Jeedo> the one marked 8 nov works slightly better
<Jeedo> i narrowed down a problem in the kernel
<Jeedo> radeon = foo_bar
<Jeedo> but there are still some other problems
<mkfort> well like I said my stuff is sort of working, just bad scan lines. I'm typing this now in Xchat in X on the ibookg4
<Jeedo> it seems that its a combonation of many bugs making one super-bug as far as i can tell
<mkfort> well video has lots of different pieces
<Jeedo> mkfort: those scan lines you refer to are present in the 8nov config
<Jeedo> though i _cannot_ get mouse 2+3 button emu to work
<mkfort> I havn't tried that
<Jeedo> i tried a config from a guy who had the ibook 2.2 which claimed it worked
<Jeedo> i compiled it, didnt change anything and it doesnt work
<Jeedo> i have the ibook 2.3
<mkfort> I think the easiest thing at this point is to fix the X driver, because it is very close to working. I think the stuff in the kernel is 
going to be more difficult
<Jeedo> there is nothing wrong with X
<mkfort> I don't know what version I just have the one that came out last week
<Jeedo> all the stuff we've seen so far i think is just the kernel messing with the video
<mkfort> maybe the bug is in AGP
<mkfort> that is also most likely
<mkfort> X might be working just some bad AGP
<Jeedo> i think that s it
<mkfort> because this has 8x agp
<puggy> lu_zero: hey
<mkfort> I might try to hack on it later
<Jeedo> i got rid of all these bugs in one config
<Jeedo> the display was _normal_
<mkfort> I might try to take agp out my kernel like you said, because I don't think it's even supposed to use agp without dri but trying to initi
alize it is borking everything
<mkfort> but I'm tired of building kernels now ;)
<Jeedo> me too
<Jeedo> i might try it later
<Jeedo> the problem is AGP though i think
<mkfort> yeah, I'm going to try a non-agp kernel with this new X
<Jeedo> and the radeon driver adds to that problem
* mkfort nod
<mkfort> keep your eye on the xfree-cvs changelog
<mkfort> but yeah, I think it's a combination of X and buggy AGP code
<mkfort> it has 8x agp whereas everything before was 4x at most
<mkfort> I still love this machine though, once it is really optimized (which will probably take a year or two) it is going to really fly

7.Nov 2003

After some testing it seems i have isolated the "psycho video output" problem
and that is the radeon driver. I will continue to debug it until i get it to 
work probably. i don't know C so I'll use the grunt approach, get that driver
from other versions of linux-2.6betaX and insert them into my kernel tree, 
test, see if it works etc.
Comment 5 phaidros 2004-01-16 10:33:37 UTC
2.6.1_rc1-benh1 [ppc-development-sources-2.6.1_rc1-r1] has solved this problem.
radeon, radeonfb & drm works.
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2004-02-15 09:29:10 UTC
Thanks for the information.  Closing this bug.
Comment 7 Lars Weiler (RETIRED) gentoo-dev 2004-04-03 15:56:09 UTC
This should be closed.