Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 331071 - [PATCH] x11-libs/qt-gui-4.6.3: Slow font rendering in Konsole on nvidia + related off-by-one error
Summary: [PATCH] x11-libs/qt-gui-4.6.3: Slow font rendering in Konsole on nvidia + rel...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-03 16:42 UTC by wbrana
Modified: 2011-11-13 15:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch from upstream bug (konsole-nvidia-font-speed.diff,1.64 KB, patch)
2010-08-03 16:43 UTC, wbrana
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description wbrana 2010-08-03 16:42:42 UTC
When using KDE4's Konsole with a bitmap (.pcf) font with the nvidia proprietary driver, text rendering is very slow. The problem is the XRenderCompositeText32() call in QX11PaintEngine::drawFreetype(), which is very slow due to (guessing from http://www.nvnews.net/vbulletin/showthread.php?t=125111) the fact that bitmap fonts are 1bpp and the driver doesn't accelerate those.
upstream bug report:
http://bugreports.qt.nokia.com/browse/QTBUG-7255
Comment 1 wbrana 2010-08-03 16:43:40 UTC
Created attachment 241271 [details, diff]
patch from upstream bug
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2010-08-03 19:28:10 UTC
Seems like upstream didn't apply the patch
Comment 3 Davide Pesavento gentoo-dev 2011-11-13 15:21:17 UTC
(In reply to comment #2)
> Seems like upstream didn't apply the patch

Right, and we won't apply a patch that upstream rejected, sorry.