Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 330799 - net-fs/nfs-utils-1.2.2-r2 prevents exports from being mounted by clients
Summary: net-fs/nfs-utils-1.2.2-r2 prevents exports from being mounted by clients
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-02 08:38 UTC by Andreas Proteus
Modified: 2016-01-22 08:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Proteus 2010-08-02 08:38:46 UTC
Attempting to mount an exported share gives the following errors:

On the client: 
mount.nfs: Access denied by server while mounting olethros:/mnt/library

On the server (from logs):
Aug  2 10:19:41 olethros mountd[1395]: authenticated mount request from 192.168.1.6:671 for /mnt/library (/mnt/library)
Aug  2 10:19:41 olethros mountd[1395]: qword_eol: fflush failed: errno 2 (No such file or directory)

The /etc/exports of the server:

# /etc/exports: NFS file systems being exported.  See exports(5).
/mnt/library  *(rw,no_root_squash,async,no_subtree_check,insecure)

This goes away if downgrade to net-fs/nfs-utils-1.2.2-r1


my emerge info:

Portage 2.2_rc67 (default/linux/x86/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.34-gentoo-r2-ole i686)
=================================================================
System uname: Linux-2.6.34-gentoo-r2-ole-i686-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 02 Aug 2010 04:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 1.3.7-r1, 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.5, 1.6.3, 1.7.9-r2, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 googleearth AdobeFlash-10.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache collision-protect distcc distlocks fixpackages metadata-tranfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.ntua.gr/pub/linux/gentoo ftp://files.gentoo.gr/ ftp://ftp.ntua.gr/pub/linux/gentoo/ ftp://gentoo.arcticnetwork.ca/pub/gentoo/"
LANG="el_GR.ISO-8859-7"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en el"
MAKEOPTS="-j11"
PKGDIR="/usr/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/berkano /usr/portage/local/layman/perl-experimental /usr/portage/local/layman/sunrise /usr/portage/local/layman/desktop-effects /usr/portage/local/layman/jokey /usr/portage/local/layman/science /usr/portage/local/layman/vmware /usr/portage/local/layman/kde-sunset /usr/portage/local/layman/gnome /usr/portage/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl alsa arts avahi bash-completion berkdb bzip2 cli cracklib cups curl cxx dbus dri dvd fam ffmpeg flac fontconfig fortran gdbm gif gpm gtk hal iconv imagemagick java jpeg kde mad mmx modules mono mp3 mplayer mudflap mysql ncurses nls npp nptl nptlonly nsplugin ogg opengl opengli openmp oss pam pcre pdf perl png pppd python qt3support rdesktop readline reflection samba session slang spell spl sse ssl ssse3 svg sysfs tcpd tetex tiff tk truetype unicode vorbis win32codecs x86 xorg xpm xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Reproducible: Always
Comment 1 Andreas Proteus 2010-08-02 09:10:59 UTC
I have discovered that net-fs/nfs-utils-1.2.2-r2 works if I restart the daemon with:

/etc/init.d/nfs restart

Please note however that upon rebooting the server the above error appears again only to go away if I manually restart the daemon.
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-02 11:05:31 UTC
Okay, -r2 is mine so I should take the pieces...

Is this with NFSv4 enabled?
Comment 3 Andreas Proteus 2010-08-02 11:13:49 UTC
nfsv4 is enabled

equery u nfs-utils

 * Found these USE flags for net-fs/nfs-utils-1.2.2-r2:
 U I
 - - caps        : Use Linux capabilities library to control privilege
 + + elibc_glibc : ELIBC setting for systems that use the GNU C library
 - - ipv6        : Adds support for IP version 6
 - - kerberos    : Adds kerberos support
 - + nfsv3       : Enable support for NFSv3
 - + nfsv4       : Enable support for NFSv4
 + + tcpd        : Adds support for TCP wrappers
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-02 11:20:50 UTC
Okay... are you actually using it or was just the default? Because -r2 should only be fixing a couple of things for nfsv4+kerberos (which is not the case for you), while there is an actual possible trouble with the init script that was reported as bug #330795 but that shouldn't hit you since you don't have sec=sys...
Comment 5 Andreas Proteus 2010-08-02 12:05:25 UTC
(In reply to comment #4)
I tried: 

#export USE="-nfsv4"
#emerge nfs-utils

The problem is still there:

Aug  2 14:52:42 olethros mountd[1376]: authenticated mount request from 192.168.1.6:764 for /mnt/library (/mnt/library)
Aug  2 14:52:42 olethros mountd[1376]: qword_eol: fflush failed: errno 2 (No such file or directory)

#/etc/init.d/nfs restart

mounts ok, no error.



Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-02 12:08:05 UTC
And you say -r1 does not do that, after a reboot? Now that's strange because it has changed nothing between the two beside nfsv4.
Comment 7 Andreas Proteus 2010-08-02 14:27:05 UTC
(In reply to comment #6)
I had another look and it appears that -r1 suffers from the same problem.

When I filed the bug report, after downgrading -r1 I restarted nfs manually (no reboot) and it worked. 
I erroneously assumed that -r1 it was doing the right thing and -r2 had the problem. My apologies.

To sum up:

When the system starts, although the exports appear to be available (showmount -e), the clients are unable to mount them, and the server reports an error as shown above.

If nfs is restarted manualy (/etc/init.d/nfs restart) the problem goes away.

The same happens with "/etc/init.d/nfs reload" or even with "exportfs -r".

For the time being I circumvent this problem by adding the line:

/usr/sbin/exportfs -r

to /etc/conf.d/local.start
------------------------------------------------------

lastly, upon issuing: exportfs -r,  it gives the curious error msg:

exportfs: Warning: /mnt/library does not support NFS export

But the exports are there and are mountable! 

Issuing exportfs -r for a second time  there is no warning and everything is ok.





Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-02 14:41:19 UTC
Reassigning then.

/mnt/library uses which filesystem?
Comment 9 Andreas Proteus 2010-08-02 14:53:32 UTC
From mtab:
/dev/sdb1 on /mnt/library type ext3 (rw,nosuid,nodev,noatime)
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-02 14:56:43 UTC
Okay so "exportfs: Warning: /mnt/library does not support NFS export" is definitely wrong ^^;;
Comment 11 Andreas Proteus 2010-08-02 18:44:36 UTC
(In reply to comment #10)
Yes, its wrong but it appears to cause no harm and in spite of the warning the share can be mounted by the clients.

It may be an indication as to what is causing this problem.
Comment 12 Andreas Proteus 2010-08-02 18:56:46 UTC
This problem is not unknown.

http://linux.derkeiler.com/Mailing-Lists/SuSE/2009-12/msg01140.html

They do not offer any clues though. :-(
Comment 13 SpanKY gentoo-dev 2010-10-08 19:51:14 UTC
nfs-utils-1.2.3 now in the tree if you want to retest