Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 330139 - sys-apps/findutils-4.5.8 automagic dependency on selinux
Summary: sys-apps/findutils-4.5.8 automagic dependency on selinux
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-28 01:12 UTC by Johan Hattne
Modified: 2010-09-30 05:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Initial attempt at introducing --enable-selinux/--disable-selinux options to configure. (findutils-4.5.8-selinux.patch,1.35 KB, patch)
2010-07-28 01:14 UTC, Johan Hattne
Details | Diff
Upstream's patch for --with-selinux/--without-selinux options to configure. (findutils-4.5.8-selinux.patch,4.21 KB, patch)
2010-09-06 18:32 UTC, Johan Hattne
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Hattne 2010-07-28 01:12:43 UTC
The build system for sys-apps/findutils-4.5.8 automagically detects and links against libselinux.  This causes trouble for prefix if findutils are compiled on a host where selinux is present, but run on a system without.  The attached patch is a ugly workaround, because I don't understand how all the pieces of the build system fit together.

Applying it, doing eautoreconf and adding an $(use_enable selinux) to econf fixes the problem for me.

Reproducible: Always

Steps to Reproduce:
1. host_with_selinux$ emerge "=findutils-4.5.8"
2. host_without_selinux$ find /etc -name passwd
3.

Actual Results:  
find: error while loading shared libraries: libselinux.so.1: cannot open shared object file: No such file or directory


Expected Results:  
...
/etc/pam.d/passwd
...
/etc/passwd
...
Comment 1 Johan Hattne 2010-07-28 01:14:05 UTC
Created attachment 240385 [details, diff]
Initial attempt at introducing --enable-selinux/--disable-selinux options to configure.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-07-29 16:24:03 UTC
I'm no autotools wizard. Can you approach upstream with this issue and report back?
Comment 3 Johan Hattne 2010-07-30 20:29:19 UTC
(In reply to comment #2)
> I'm no autotools wizard. Can you approach upstream with this issue and report
> back?

Reported upstream.  See http://savannah.gnu.org/bugs/index.php?30608
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-08-18 21:15:27 UTC
Great thanks, now there is activity on the upstream bug.
Comment 5 Johan Hattne 2010-08-18 22:28:08 UTC
(In reply to comment #4)
> Great thanks, now there is activity on the upstream bug.

The issue has migrated to gnulib.  The thread starts here:

  http://lists.gnu.org/archive/html/bug-gnulib/2010-08/msg00127.html
Comment 6 Johan Hattne 2010-09-06 18:32:46 UTC
Created attachment 246291 [details, diff]
Upstream's patch for --with-selinux/--without-selinux options to configure.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-20 16:56:32 UTC
Just pushed to 4.5.9 the other day. You will need to remerge.
Comment 8 Johan Hattne 2010-09-30 05:02:28 UTC
(In reply to comment #7)
> Just pushed to 4.5.9 the other day. You will need to remerge.

Thanks a lot, issue solved!