Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 329563 - net-libs/xulrunner: Missing revision bump for bug 329529
Summary: net-libs/xulrunner: Missing revision bump for bug 329529
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
: 329567 329669 (view as bug list)
Depends on: 329529
Blocks:
  Show dependency tree
 
Reported: 2010-07-23 11:23 UTC by Bill Krueger
Modified: 2010-07-26 19:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
an strace /usr/bin/firefox (firefox-trace.txt,8.04 KB, text/plain)
2010-07-23 11:24 UTC, Bill Krueger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Krueger 2010-07-23 11:23:11 UTC
After emerging both net-libs/xulrunner-1.9.2.7 and www-client/mozilla-firefox-3.6.7, firefox would not start. Running the command firefox or /usr/bin/firefox results in the error msg 

"Could not find compatible GRE between version 1.9.2.7 and 1.9.2.7." 

Running /usr/bin/xulrunner-1.9.2 --version displays the msg 

"Mozilla XULRunner 1.9.2.7 - 20100723001113

Running /usr/bin/xulrunner-1.9.2 --gre-version displays the msg

1.9.2.7

Running revdep-rebuild after getting this error results in the msg: 

Dynamic linking on your system is consistent... All done.



Reproducible: Always

Steps to Reproduce:
1. emerge --sync
2. emerge mozilla-firefox
3. firefox (or /usr/bin/firefox)

Actual Results:  
No browser window.

Expected Results:  
A firefox browser window.

Here is the output of emerge --info from my system:

Portage 2.2_rc67 (default/linux/x86/10.0/desktop, gcc-4.4.2, glibc-2.11-r1, 2.6.33-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.33-gentoo-r2-i686-AMD_Sempron-tm-_Processor_2800+-with-gentoo-2.0.1
Timestamp of tree: Fri, 23 Jul 2010 10:30:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.5.4-r4, 2.6.4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc:       4.1.2, 4.3.2-r2, 4.4.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.1"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://130.208.16.26/pub/gentoo/ http://130.208.16.26/pub/gentoo/ ftp://130.208.16.31/pub/gentoo/ http://130.208.16.31/pub/gentoo/ ftp://mirrors.64hosting.com/pub/mirrors/gentoo/"
LANG="en_US.iso88591"
LC_ALL="en_US.iso88591"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/mozilla /usr/local/portage/layman/voyageur"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi aim alsa amr apache2 avi berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus dgs dri dts dvd dvdr dvdread emacs emboss encode exif fame ffmpeg flac fortran gdbm gif glitz gphoto2 gpm graphviz gs gstreamer guile hal iconv imagemagick ipv6 java javascript jbig jpeg jpeg2k kde lame lcms ldap libnotify libwww lzo mad matroska mikmod mjpeg mmx mmxext mng modules mozdevelop mozsvg mp3 mp4 mpeg mplayer mudflap musepack mysql mythtv nas ncurses network nls nptl nptlonly nsplugin oci8 ofx ogg oggvorbis opengl openmp pam pango pch pcre pdf perl png postgres povray ppds pppd python qt3support qt4 quicktime rar readline reflection rtc scanner sdl session speex spell spl sse sse2 ssl startup-notification subtitles svg svga sysfs tcltk tcpd tetex theora tiff tools truetype truetype-fonts type1-fonts unichrome unicode usb vorbis win32codecs x264 x86 xanim xcb xine xml xml2 xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Bill Krueger 2010-07-23 11:24:28 UTC
Created attachment 239905 [details]
an strace /usr/bin/firefox
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2010-07-23 11:33:04 UTC
Caused by bug 329529 and the lack of revision bump to fix the issue. For now, you can "emerge --sync" and re-emerge xulrunner to fix it...

Moving to maintainers
Comment 3 Ilya Ershov 2010-07-23 11:42:50 UTC
After syncing and rebuilding xulrunner, you may need to rebuild firefox again.
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-07-23 12:29:07 UTC
*** Bug 329567 has been marked as a duplicate of this bug. ***
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2010-07-23 12:46:32 UTC
+*xulrunner-1.9.2.7-r1 (23 Jul 2010)
+
+  23 Jul 2010; Lars Wendler <polynomial-c@gentoo.org>
+  -xulrunner-1.9.2.7.ebuild, +xulrunner-1.9.2.7-r1.ebuild:
+  Increased revision to fix GRE issues caused by bug #329529 and requested
+  in bug #329563.
+
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2010-07-24 07:55:40 UTC
*** Bug 329669 has been marked as a duplicate of this bug. ***
Comment 7 Bill Krueger 2010-07-24 16:30:07 UTC
(In reply to comment #3)
> After syncing and rebuilding xulrunner, you may need to rebuild firefox again.
> 

I followed these instructions and Firefox 3.6.7 is working. Thanks.
Comment 8 Paramonov Valeriy 2010-07-26 19:31:01 UTC
Thanks