Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 329559 - eix-remote update fails: gentooexperimental.org down
Summary: eix-remote update fails: gentooexperimental.org down
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Martin Väth
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-23 11:06 UTC by denysonique
Modified: 2010-10-01 09:14 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Script to create eix-caches.tbz (eix-make-remote-tbz2.sh,486 bytes, text/plain)
2010-07-23 16:20 UTC, Martin Väth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description denysonique 2010-07-23 11:06:30 UTC
eix-remote update fails to fetch http://dev.gentooexperimental.org/eix_cache/eix-caches.tbz2


Reproducible: Always

Steps to Reproduce:
1.eix-remote update
2.
3.

Actual Results:  
# eix-remote update
 * Fetching eix-caches.tbz2
--2010-07-23 11:57:20--  http://dev.gentooexperimental.org/eix_cache/eix-caches.tbz2
Resolving dev.gentooexperimental.org... 81.200.64.50
Connecting to dev.gentooexperimental.org|81.200.64.50|:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
2010-07-23 11:57:21 ERROR 403: Forbidden.

 * could not fetch http://dev.gentooexperimental.org/eix_cache/eix-caches.tbz2


Expected Results:  
eix cache successfully updated.
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-07-23 12:51:51 UTC
Yup, the *.gentooexperimental.org domains went away. The owner of the domain (patrick) is on vacation, I don't expect this to get fixed very soon.
Comment 2 denysonique 2010-07-23 12:56:47 UTC
(In reply to comment #1)
> Yup, the *.gentooexperimental.org domains went away. The owner of the domain
> (patrick) is on vacation, I don't expect this to get fixed very soon.
> 

Does anyone have a script that generates the cache? It would be nice if we could set up a temporary server or a second mirror. I think I could host it. Until bonsaikitten returns from his holidays.
Comment 3 Martin Väth 2010-07-23 16:20:04 UTC
Created attachment 239931 [details]
Script to create eix-caches.tbz

The attached script is essentially untested, but should create
eix-caches.tbz2 in the required format.

It needs to be started in an empty directory in which eix-caches.tbz2
(and some temporary files) will be stored. The paths need to be adjusted,
of course.

Note that the script syncs all layman overlays, so you should have a lot of
bandwidth and diskspace if you use this script...
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-07-23 16:43:49 UTC
It is important to note that we don't want this script being ran by "everyone, all the time" doing so will hurt the perfomance of overlays.gentoo.org (where most of the overlays are hosted, but not all)
Comment 5 denysonique 2010-07-23 19:10:55 UTC
Thanks Martin for the script. I am going to set up this as a daily cron job on my server. That will be on Monday.
Comment 6 Martin Väth 2010-07-23 19:58:39 UTC
(In reply to comment #4)
> It is important to note that we don't want this script being ran by
> "everyone,  all the time"

Sorry if my posting of the script gave the wrong impression that it might
be useful for somebody if he runs this script: This is not the case.
(It would be rather stupid and unnecessary to fetch all overlays only to
find the content of the overlays.)

In fact, running this script makes only sense for _one_ person, namely for
that person who serves the output file for the whole gentoo community,
i.e. under normal circumstances (if gentooexperimental.org is up)
this script does not make sense for anybody...
Also now it makes only sense for Dennis and if he publicly announces the
server (once it is set up) e.g. in the forums so that users can use his
server temporarily until gentooexperimental.org is up again.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-07-23 20:14:15 UTC
Even if Dennis runs this script and announces it to the community (with limited success). Is it a good thing?

A more long term fix would be to run it on gentoo infrastructure which is more resiliant and most important, more secure. Anyway, I'm not a big eix-remote user so I don't have a strong opinion. (I normally use http://gpo.zugaina.org/ to search overlays.)
Comment 8 denysonique 2010-07-29 08:52:13 UTC
The old eix-cache server is up and running and was never down. The only problem it has is the DNS records. This is what I have been told by Patric when chating with him on freenode. You can use the ip of the eix-cache server http://91.191.147.225/eix_cache/eix-caches.tbz2 for the -a switch value of eix-update. Or alternatively just add an appropriate entry to your /etc/hosts file. This is a temporary fix until the domain will be working again.
Comment 9 Navid Zamani 2010-08-07 09:22:26 UTC
Yes, I agree that this should be hosted on the Gentoo mirrors, including checksums.
But I disagree that it would be more secure, since we don’t have any trust network system here, and I don’t trust Gentoo admins any more than anybody else. People are just people. If you don’t personally know them, they are no better. (Usually they are even worse, as proven by politicians and Wikipedia admins all over the world.)

You may know them, and you may trust them, because you interests match up. But everyone else can’t know that. :)
Comment 10 pavel sanda 2010-09-15 00:17:09 UTC
hello, is patrick still alive? :)
Comment 11 Patrick Lauer gentoo-dev 2010-10-01 09:14:11 UTC
FIXED