Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 329529 - net-libs/xulrunner-1.9.2.7 ebuild, missing inherit prefix
Summary: net-libs/xulrunner-1.9.2.7 ebuild, missing inherit prefix
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 329563
  Show dependency tree
 
Reported: 2010-07-23 06:45 UTC by Ilya Ershov
Modified: 2010-07-23 12:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Ershov 2010-07-23 06:45:04 UTC
xulrunner-1.9.2.7.ebuild users eprefixify function but does not inherit prefix.class. Because of this, it builds (saying "eprefixify: command not found", but not stopping the process), but running xulrunner leads to error messages.

Reproducible: Always

Steps to Reproduce:
1. emerge =net-libs/xulrunner-1.9.2.7
2. Try to run xulrunner --register-globals, for example


Actual Results:  
This leads to error message 'could not create @GENTOO_PORTAGE_EPREFIX@/etc/gre.d'

Expected Results:  
It should work
Comment 1 Fabian Groffen gentoo-dev 2010-07-23 07:41:56 UTC
Our apologies.

Missing inherit prefix added, thanks.
Comment 2 Fabian Groffen gentoo-dev 2010-07-23 11:35:00 UTC
@maintainers do you want a revbump to get the fix pushed for bug #329563?
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2010-07-23 12:46:25 UTC
+*xulrunner-1.9.2.7-r1 (23 Jul 2010)
+
+  23 Jul 2010; Lars Wendler <polynomial-c@gentoo.org>
+  -xulrunner-1.9.2.7.ebuild, +xulrunner-1.9.2.7-r1.ebuild:
+  Increased revision to fix GRE issues caused by bug #329529 and requested
+  in bug #329563.
+