Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 329205 - media-gfx/povray-3.7.0_beta35 fails to compile on OSX
Summary: media-gfx/povray-3.7.0_beta35 fails to compile on OSX
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All OS X
: High normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-21 04:11 UTC by Guilherme Amadio
Modified: 2011-09-30 21:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guilherme Amadio gentoo-dev 2010-07-21 04:11:53 UTC
I get the following error when trying to compile povray on my prefix:

x86_64-apple-darwin10-g++ -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../source -I../../source -I../../source/base -I../../unix -I../../vfe -I../../vfe/unix -I/Library/Gentoo/usr/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -Iyes/../include  -pthread   -I/usr/include  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -O3 -ffast-math -O2 -pipe -march=nocona -mssse3 -DPOVLIBDIR=\"/Library/Gentoo/usr/share/povray\" -DPOVCONFDIR=\"/Library/Gentoo/etc/povray\" -D_THREAD_SAFE -MT tracetask.o -MD -MP -MF .deps/tracetask.Tpo -c -o tracetask.o `test -f 'render/tracetask.cpp' || echo './'`render/tracetask.cpp
In file included from ../../source/backend/render/rendertask.h:102,
                 from render/rendertask.cpp:100:
../../source/backend/support/task.h:187: error: thread-local storage not supported for this target
In file included from ../../source/backend/scene/threaddata.h:104,
                 from ../../source/backend/render/trace.h:104,
                 from ../../source/backend/interior/media.h:97,
                 from ../../source/backend/interior/interior.h:97,
                 from render/ray.cpp:97:
../../source/backend/support/task.h:187: error: thread-local storage not supported for this target
In file included from ../../source/backend/scene/threaddata.h:104,
                 from ../../source/backend/render/trace.h:104,
                 from render/trace.cpp:109:
../../source/backend/support/task.h:187: error: thread-local storage not supported for this target
In file included from ../../source/backend/scene/threaddata.h:104,
                 from ../../source/backend/render/trace.h:104,
                 from render/tracetask.cpp:101:
../../source/backend/support/task.h:187: error: thread-local storage not supported for this target
mv -f .deps/povray.Tpo .deps/povray.Po
x86_64-apple-darwin10-g++ -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../source -I../../source -I../../source/base -I../../unix -I../../vfe -I../../vfe/unix -I/Library/Gentoo/usr/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -Iyes/../include  -pthread   -I/usr/include  -pipe -Wno-multichar -Wno-write-strings -fno-enforce-eh-specs -O3 -ffast-math -O2 -pipe -march=nocona -mssse3 -DPOVLIBDIR=\"/Library/Gentoo/usr/share/povray\" -DPOVCONFDIR=\"/Library/Gentoo/etc/povray\" -D_THREAD_SAFE -MT radiositytask.o -MD -MP -MF .deps/radiositytask.Tpo -c -o radiositytask.o `test -f 'render/radiositytask.cpp' || echo './'`render/radiositytask.cpp
make[3]: ** [ray.o] Erro 1
make[3]: ** Esperando que outros processos terminem.
make[3]: ** [rendertask.o] Erro 1
make[3]: ** [tracetask.o] Erro 1
make[3]: ** [trace.o] Erro 1

Any ideas on what may be the cause? I am using openmpi, but boost fails to compile with mpi
support (another bug that I will file next...)

Reproducible: Always
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-08-18 21:16:48 UTC
Could you try _beta38 now?
Comment 2 Guilherme Amadio gentoo-dev 2010-08-22 04:27:45 UTC
I just tried it, it fails with the same error :(
Comment 3 Fabian Groffen gentoo-dev 2010-08-22 06:59:04 UTC
Hmmmm, if it insists on thread-local-storage, then this may be a dead end.
On a side-note, -I/usr/include isn't really nice either.
Comment 4 Fabian Groffen gentoo-dev 2010-09-13 18:36:24 UTC
pthread_getspecific — get a thread-specific data value
Comment 5 Joe Peterson (RETIRED) gentoo-dev 2011-09-30 20:57:08 UTC
3.7.0_beta35 is no longer in the tree.
Comment 6 Fabian Groffen gentoo-dev 2011-09-30 21:04:14 UTC
and prefix changes were reverted, so it won't work at all anyway