Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 327641 - app-arch/tar-1.23 enters dead loop on extracting symlinks with -k option
Summary: app-arch/tar-1.23 enters dead loop on extracting symlinks with -k option
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 329105 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-09 18:41 UTC by srunni
Modified: 2010-08-12 19:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description srunni 2010-07-09 18:41:20 UTC
When using the -k option, tar will simply pause during execution if it encounters a symlink.

A patch is available here: http://git.savannah.gnu.org/cgit/tar.git/patch/?id=b60e56fdb6fd8d82a1f92a4fa7781d9a3184dce1

Reproducible: Always

Steps to Reproduce:
1. Launch tar with -k flag to extract a tarball with symlinks
2. Watch output.
3. Observe tar freezing.
Comment 1 SpanKY gentoo-dev 2010-07-18 21:06:51 UTC
added to tar-1.23-r3 ... thanks for the upstream info
Comment 2 Rafał Mużyło 2010-07-20 13:07:18 UTC
*** Bug 329105 has been marked as a duplicate of this bug. ***
Comment 3 Wormo (RETIRED) gentoo-dev 2010-08-12 19:47:03 UTC
*** Bug 329105 has been marked as a duplicate of this bug. ***