Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 32747 - kdeadmin-3.2.0_beta1.ebuild compile error
Summary: kdeadmin-3.2.0_beta1.ebuild compile error
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
: 32840 35529 36927 (view as bug list)
Depends on:
Reported: 2003-11-04 14:44 UTC by Svein
Modified: 2005-12-25 13:42 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Svein 2003-11-04 14:44:20 UTC
What can I say, the package don't compile.. and give me the feared Exitcode 2

Reproducible: Always
Steps to Reproduce:

Expected Results:  
 * GNU info directory index is up-to-date. :)

*** Creating configure.files
cd . && /bin/sh
/var/tmp/portage/kdeadmin-3.2.0_beta1/work/kdeadmin-3.1.93/admin/missing --run
cd . && \
/var/tmp/portage/kdeadmin-3.2.0_beta1/work/kdeadmin-3.1.93/admin/missing --run
automake-1.7 --foreign  Makefile
cd . && rm -f configure && make -f ./admin/Makefile.common configure
make[1]: Entering directory
autom4te-2.57: cannot not rename autom4te.cache/traces.0t as
autom4te.cache/traces.0: No such file or directory no proper invocation of AM_INIT_AUTOMAKE was found. You should verify that invokes AM_INIT_AUTOMAKE, that aclocal.m4 is present in the top-level directory, and that aclocal.m4 was recently regenerated (using aclocal). required file `./install-sh' not found required file `./mkinstalldirs' not found required file `./missing' not found
SUBDIRS: variable `TOPSUBDIRS' is used but `TOPSUBDIRS' is undefined
make: *** [] Error 1
make: *** Waiting for unfinished jobs....
make[1]: Leaving directory

!!! ERROR: kde-base/kdeadmin-3.2.0_beta1 failed.
!!! Function kde_src_compile, Line 137, Exitcode 2
!!! died running emake, kde_src_compile:make
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2003-11-04 18:14:22 UTC
make sure you have autoconf-2.57a-r1 installed.
Comment 2 Svein 2003-11-05 00:56:55 UTC
Thats it. Had autoconf-2.57 :(
It compiled just fine, will close the bug shortly
Comment 3 Cedric Veilleux 2003-11-05 07:03:30 UTC
Encountered the same problem. I had to manually merge autoconf 2.57a-r1

Shouldn't the kdeadmin ebuild have a dependency on it?
Comment 4 Martin Holzer (RETIRED) gentoo-dev 2003-11-06 00:43:31 UTC
*** Bug 32840 has been marked as a duplicate of this bug. ***
Comment 5 Christian Herzyk 2003-11-10 00:15:55 UTC
Hi all,

I still get the same error after updating to autoconf2.57a-r1.

Comment 6 Caleb Tennis (RETIRED) gentoo-dev 2003-11-10 06:32:04 UTC
are you sure it's the same error?
Comment 7 Christian Herzyk 2003-11-11 04:35:42 UTC
Yes it was, but it was solved by now by updating automake, too.
I had 1.7.5-r2 and now updated to 1.7.8.
Comment 8 Heinrich Wendel (RETIRED) gentoo-dev 2003-12-10 10:26:32 UTC
*** Bug 35529 has been marked as a duplicate of this bug. ***
Comment 9 Ævar Arnfjörð Bjarmason 2003-12-17 14:59:16 UTC
EXACTLY the same problem here, fixed by:

ACCEPT_KEYWORDS="~x86" emerge automake m4 autoconf
Comment 10 FieldySnuts 2003-12-26 06:55:11 UTC
I am having the same problem with the beta2 ebuild. There was a bug for beta2, however, it has been marked a dupe of this.

Right now kdeadmin is compiling, after upgrading to autoconf 2.58 .

I'm commiting this early and incomplete because I don't feel like typing it again... continued.
Comment 11 FieldySnuts 2003-12-26 07:02:02 UTC

Results:  kdeadmin-3.2.0_beta2 merged.

So at least to me, the solution was to upgrade autoconf to 2.58. Perhaps this should be a dependancy.
Comment 12 Peter Triller 2003-12-31 20:05:37 UTC
it will compile with autoconf-2.57
if you do it manually using ebuild and tweak a little

first get it 
ebuild ..../.ebuild fetch unpack

now go to the surce dir in /var/tmp and do a 
make -f admin/Makefile.commom

and now a
ebuild ... /..ebuild compile install qmerge

will do just fine
Comment 13 Martin Holzer (RETIRED) gentoo-dev 2004-01-01 06:24:53 UTC
*** Bug 36927 has been marked as a duplicate of this bug. ***
Comment 14 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-25 13:42:35 UTC
Dead old bug left to close...