Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 327081 - xfce-base/exo-0.3.107 www-client/opera-10.60 launcher doesn't open the URL
Summary: xfce-base/exo-0.3.107 www-client/opera-10.60 launcher doesn't open the URL
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: XFCE Team
URL: http://bugzilla.xfce.org/show_bug.cgi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-06 06:17 UTC by Christopher Head
Modified: 2011-09-27 18:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Head 2010-07-06 06:17:55 UTC
When setting Opera as the default browser in XFCE, the exo-open command (via /usr/libexec/exo-helper-0.3) uses /usr/share/xfce4/helpers/opera-browser.desktop, which includes this line:

X-XFCE-CommandsWithParameter=%B -remote "openURL(%s,new-window)";%B "%s";

Unfortunately, as of Opera 10.60, this no longer works right if no Opera process is running yet. Rather than launching a new browser and opening the URL in it, it ends up launching a browser with no pages open and somehow the request falls through the cracks and the page never opens (it still works fine for opening new pages when a browser is already running).

I imagine there's probably an Opera bug in there somewhere (it feels like a race condition); however, the command listed in the desktop file is ridiculous overkill anyway, given that simply replacing it with this line works perfectly in all cases:

X-XFCE-CommandsWithParameter=%B "%s"

because Opera already handles launching of a second process correctly by sending a message to the original instance!

Reproducible: Always

Steps to Reproduce:
Comment 1 Samuli Suominen gentoo-dev 2010-08-11 16:33:45 UTC
+  11 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> exo-0.5.3.ebuild,
+  +files/exo-0.5.3-opera-10_60.patch:
+  Set python_set_active_version to make sure Python 2.x is used. Fix
+  opera-browser.desktop for >= 10.60 wrt #327081 by Christopher Head.