Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 326721 - [qting-edge] x11-libs/qt-webkit-4.7.0_beta1-r1: revdep-rebuild repeatedly wants to rebuild due to jscore
Summary: [qting-edge] x11-libs/qt-webkit-4.7.0_beta1-r1: revdep-rebuild repeatedly wan...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Qt Bug Alias
Whiteboard: [PATCH]qt4-build.eclass: Remove .la f...
Depends on:
Reported: 2010-07-03 09:21 UTC by Nikos Chantziaras
Modified: 2010-07-12 06:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info =x11-libs/qt-webkit-4.7.0_beta1-r1 (emerge--info,4.61 KB, text/plain)
2010-07-03 09:25 UTC, Nikos Chantziaras

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Chantziaras 2010-07-03 09:21:32 UTC
No matter how many times I let revdep-rebuild rebuild qt-webkit, it always wants to build it again:

 * Checking dynamic linking consistency
[ 87% ]  *   broken /usr/lib64/qt4/ (requires -ljscore)
[ 98% ]  *   broken /usr/lib/qt4/ (requires -ljscore)
[ 100% ]
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/lib64/qt4/ -> x11-libs/qt-webkit
 *   /usr/lib/qt4/ -> x11-libs/qt-webkit
Comment 1 Nikos Chantziaras 2010-07-03 09:24:18 UTC
emerge -pqv qt-webkit:
[ebuild   R   ] x11-libs/qt-webkit-4.7.0_beta1-r1  USE="dbus exceptions kde (-aqua) -debug -pch"
Comment 2 Nikos Chantziaras 2010-07-03 09:25:09 UTC
Created attachment 237349 [details]
emerge --info =x11-libs/qt-webkit-4.7.0_beta1-r1
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2010-07-08 15:47:08 UTC
Can you reproduce it with 4.7.0_beta2?
Comment 4 Nikos Chantziaras 2010-07-08 18:13:26 UTC
(In reply to comment #3)
> Can you reproduce it with 4.7.0_beta2?

Yes. Still happens with qt-webkit-4.7.0_beta2.

Another thing is that anything matching *jscore* doesn't exist at all on my system.  Doing a:

  find /usr -iname "*jscore*"

doesn't find anything. I think there's a "jscore" library that seems to exist during building but it doesn't get installed at all?
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2010-07-08 21:06:16 UTC
yes this library never gets installed because of a broken build system. Reported upstream

I will try to manually install this library till upstream fixed it
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2010-07-08 22:15:39 UTC
Well I fixed it for now. Closing as UPSTREAM. When I have more info from upstream I will reopen this 
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2010-07-09 00:44:35 UTC
Reopening since I reverted my commit. I am currently testing a qt4-build.eclass patch which removes .la files completely from Qt modules since we don't need them. This bug is related to .la files since it lists libjscore static lib as dependency
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2010-07-11 10:34:04 UTC
A patch was been applied to remove .la files from qt-modules

So next time you rebuild qt-webkit you should *not" suffer from this problem

Reopen if you still have problems
Comment 9 Nikos Chantziaras 2010-07-11 23:51:52 UTC
It's fixed now. Thank you for your work on this :)
Comment 10 Davide Pesavento gentoo-dev 2010-07-12 06:29:11 UTC
Reopening for proper resolution.
Comment 11 Davide Pesavento gentoo-dev 2010-07-12 06:29:32 UTC