Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 326599 - www-plugins/gnash-0.8.{5,6} fails to build with media-libs/libpng-1.4
Summary: www-plugins/gnash-0.8.{5,6} fails to build with media-libs/libpng-1.4
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Romain Perier (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.4
  Show dependency tree
 
Reported: 2010-07-02 10:27 UTC by Serhij S. Stasyuk
Modified: 2010-07-02 11:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
www-plugins/gnash/files/gnash-0.8.5-libpng14.patch (gnash-0.8.5-libpng14.patch,436 bytes, patch)
2010-07-02 10:31 UTC, Serhij S. Stasyuk
Details | Diff
www-plugins/gnash/gnash-0.8.5.ebuild.patch (gnash-0.8.5.ebuild.patch,531 bytes, patch)
2010-07-02 10:34 UTC, Serhij S. Stasyuk
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Serhij S. Stasyuk 2010-07-02 10:27:57 UTC
gnash-0.8.5 uses deprecated function from libpng12, png_set_gray_1_2_4_to_8, which was removed in libpng14.

Reproducible: Always

Steps to Reproduce:
Comment 1 Serhij S. Stasyuk 2010-07-02 10:31:51 UTC
Created attachment 237235 [details, diff]
www-plugins/gnash/files/gnash-0.8.5-libpng14.patch

Just replace png_set_gray_1_2_4_to_8 with png_set_expand_gray_1_2_4_to_8 in libbase/GnashImagePng.cpp
Comment 2 Serhij S. Stasyuk 2010-07-02 10:34:55 UTC
Created attachment 237237 [details, diff]
www-plugins/gnash/gnash-0.8.5.ebuild.patch

Add www-plugins/gnash/files/gnash-0.8.5-libpng14.patch to used patches.
Comment 3 Samuli Suominen gentoo-dev 2010-07-02 10:37:48 UTC
I don't know why you are using 0.8.5, but the problem is same for 0.8.7... fixing summary.
Comment 4 Samuli Suominen gentoo-dev 2010-07-02 10:44:16 UTC
(In reply to comment #3)
> I don't know why you are using 0.8.5, but the problem is same for 0.8.7...
> fixing summary.
> 

Or rather the faulty code is present in all of 0.8.5, 0.8.6, 0.8.7 but only 0.8.5's ebuild is passing --enable-png and thus the only ebuild hitting this bug.
Comment 5 Samuli Suominen gentoo-dev 2010-07-02 11:02:12 UTC
ah no, 0.8.7 had the fix already (unnecessarily with #ifdef's though, upstream failed).

fixed properly for 0.8.5 and 0.8.6:

+  02 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+  +files/gnash-0.8.x-libpng14.patch, gnash-0.8.5.ebuild, gnash-0.8.6.ebuild:
+  Fix building with libpng14 wrt #326599 by Serhij S. Stasyuk.
Comment 6 Serhij S. Stasyuk 2010-07-02 11:17:01 UTC
Thanks for quick response.