Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 32554 - openoffice directory not found building instsetoo
Summary: openoffice directory not found building instsetoo
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Office Team
Depends on:
Reported: 2003-11-02 09:03 UTC by David D. Huff Jr.
Modified: 2005-01-16 11:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Full Compile Log (oobuild.txt,881.06 KB, text/plain)
2003-11-02 09:06 UTC, David D. Huff Jr.
Build Envirnoment (build_env.txt,1.34 KB, text/plain)
2003-11-02 09:08 UTC, David D. Huff Jr.
OpenOffice Config Log (config.log,37.56 KB, text/plain)
2003-11-02 13:10 UTC, David D. Huff Jr.

Note You need to log in before you can comment on or make changes to this bug.
Description David D. Huff Jr. 2003-11-02 09:03:13 UTC
Building project instsetoo

WARNING! Project(s):

not found and couldn't be built. Correct build.lsts.

!!! ERROR: app-office/openoffice-1.1.0 failed.
!!! Function src_compile, Line 457, Exitcode 1
!!! Cannot find build directory!
Comment 1 David D. Huff Jr. 2003-11-02 09:06:13 UTC
Created attachment 20113 [details]
Full Compile Log

The error message produced in the compile is conflicting so I submitted the
whole log.
Comment 2 David D. Huff Jr. 2003-11-02 09:08:17 UTC
Created attachment 20114 [details]
Build Envirnoment

I'm running very conservative compile options for the Athlon 800. I'm running
full 'emerge sync && emerge -DU world' everynight and everything but openoffice
is up to date.
Comment 3 Paul de Vrieze (RETIRED) gentoo-dev 2003-11-02 11:15:08 UTC
Could you attach

Comment 4 David D. Huff Jr. 2003-11-02 13:10:21 UTC
Created attachment 20133 [details]
OpenOffice Config Log 

As requested, thanks for looking into this.
Comment 5 Paul de Vrieze (RETIRED) gentoo-dev 2003-11-04 03:26:16 UTC
It seems that ccache is not correctly setup on daphnie. If it doesn't work,
try compiling without distcc or ccache
Comment 6 David D. Huff Jr. 2003-11-05 20:25:07 UTC
I'd already tried getting rid of ccache and distcc on 4 different systems
over the last month since this last release. I've been watching the daily
bug reports of openoffice. Finally decided to file my own. The error is always
the same no matter which CPU or setting or whether distcc and ccache were
The topography is as follows 300 Mhz Cyrix, 700&800 AMD and 900 AMD; mcpu=486
-O2, 586 -O2 and 686 -O3 respectively. Not using branded optimizations at
Over the past 6 months at least 2 of them have been able to successfully
compile openoffice when the new versions came out.
The only thing that sets these systems apart is that the USE= was changed
from gtk to gtk2 and all of Gnome was recompiled. 
I just finished rebuilding a server with an XP2600 tonight and have started
the openoffice compile sans ccache and distcc, I'll report back the results.
Comment 7 Paul de Vrieze (RETIRED) gentoo-dev 2003-11-06 02:51:41 UTC
The easiest way is just to run:
FEATURES="-distcc" emerge openoffice. This should cause distcc not to be
used. ccache on the local host is safe, but if you want to disable that too
FEATURES="-distcc --cache" emerge openoffice
Comment 8 David D. Huff Jr. 2003-11-06 14:10:10 UTC
Last night 3 systems had the same error as originally reported after running
"emerge -C distcc ccache" and then /etc/init.d/distccd stop.

The 4th system had the sandbox violation, I've seen reported elsewhere. It
was done compiling and just looking to write the files.
Comment 9 Maurice van der Pot (RETIRED) gentoo-dev 2004-11-12 11:30:54 UTC
David, is this still a problem with more recent versions?
Comment 10 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-16 11:20:20 UTC
No feedback for quite some time, closing