Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 32531 - Can't emerge mono-debugger-0.4
Summary: Can't emerge mono-debugger-0.4
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-02 04:36 UTC by Sebastian Bergmann (RETIRED)
Modified: 2003-11-04 13:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Bergmann (RETIRED) gentoo-dev 2003-11-02 04:36:43 UTC
Can't emerge mono-debugger-0.4.

Reproducible: Always
Steps to Reproduce:
1. emerge mono-debugger
2.
3.

Actual Results:  
sed -e 's,\@MONO\@,/usr/libexec/mono-debugger-mini-wrapper,g' \
-e
's,\@PATH\@,/usr/lib/ccache/bin:/sbin:/usr/sbin:/usr/lib/portage/bin:/bin:/usr/bin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/usr/X11R6/bin:/opt/blackdown-jdk-1.4.1/bin:/opt/blackdown-jdk-1.4.1/jre/bin:/usr/qt/3/bin:/usr/kde/3.1/sbin:/usr/kde/3.1/bin:/usr/share/karamba/bin,g'
\
-e 's,\@LD_LIBRARY_PATH\@,/usr/lib:,g' \
< Debugger.exe.config.in > tmp-t && mv tmp-t Debugger.exe.config
sed -e 's,\@MONO\@,/usr/libexec/mono-debugger-mini-wrapper,g' \
-e
's,\@PATH\@,/usr/lib/ccache/bin:/sbin:/usr/sbin:/usr/lib/portage/bin:/bin:/usr/bin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/usr/X11R6/bin:/opt/blackdown-jdk-1.4.1/bin:/opt/blackdown-jdk-1.4.1/jre/bin:/usr/qt/3/bin:/usr/kde/3.1/sbin:/usr/kde/3.1/bin:/usr/share/karamba/bin,g'
\
-e 's,\@LD_LIBRARY_PATH\@,/usr/lib:,g' \
< Interpreter.exe.config.in > tmp-t && mv tmp-t Interpreter.exe.config
../classes/Backtrace.cs(99) error CS0103: The name `Math.Min' could not be found
in `Mono.Debugger.Backtrace'
../classes/Backtrace.cs(100) error CS0103: The name `Math.Min' could not be
found in `Mono.Debugger.Backtrace'
Compilation failed: 2 error(s), 2 warnings
make[2]: *** [Mono.Debugger.dll] Error 1
make[2]: Leaving directory
`/var/tmp/portage/mono-debugger-0.4/work/mono-debugger-0.4/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/var/tmp/portage/mono-debugger-0.4/work/mono-debugger-0.4'
make: *** [all] Error 2

!!! ERROR: dev-util/mono-debugger-0.4 failed.
!!! Function src_compile, Line 22, Exitcode 2
!!! (no error message)



wopr-mobile root # emerge info
Portage 2.0.49-r15 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r8, 2.4.20-gentoo-r7)
=================================================================
System uname: 2.4.20-gentoo-r7 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.3.11
distcc 2.8 i686-pc-linux-gnu (protocol 1) (default port 3632) [disabled]
ccache version 2.3 [enabled]
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium3 -Os -fomit-frame-pointer -mmmx -msse -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
/usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=pentium3 -Os -fomit-frame-pointer -mmmx -msse -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="sandbox ccache autoaddcvs fixpackages"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/
ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo/
ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
ftp://ftp.fhh.opensource-mirror.de/pub/gentoo.org/
ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://gentoo.oregonstate.edu
http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg libg++ libwww mad
mikmod mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms zlib gdbm
berkdb slang readline arts svga tcltk java guile mysql postgres sdl gpm tcpd pam
ssl perl python esd imlib oggvorbis gtk motif opengl mozilla ldap cdr X xv gtk2
gnome imap -mbox -kde -qt alsa acpi dga dvd apache2 innodb moznoirc moznomail
moznocompose"
Comment 1 Rainer Größlinger (RETIRED) gentoo-dev 2003-11-02 05:17:11 UTC
obviously, mono(doc|-debugger) related bugs are spreading :)

any comments? tberman ?
Comment 2 foser (RETIRED) gentoo-dev 2003-11-03 09:20:07 UTC
yeah, well .. problem is that certain versions may work with one mono and
not the next. Thats the reason i feared putting them both in in the first
place, we should just p.mask them for now until they stabilize afaic.

I have been very busy lately so i haven't kept up, but i will look at the
whole mono thing soonish.
Comment 3 Todd Berman (RETIRED) gentoo-dev 2003-11-04 13:02:35 UTC
This package is upstream unmaintained for a bit while work is being done
on generics.