Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324911 - net-misc/wicd-1.7.0: can't connect and stalls on "Disconnecting active connections" when having (dis)connection scripts set
Summary: net-misc/wicd-1.7.0: can't connect and stalls on "Disconnecting active connec...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Thomas Kahle (RETIRED)
URL: https://bugs.launchpad.net/wicd/+bug/...
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks:
 
Reported: 2010-06-21 08:10 UTC by Phillip Merensky
Modified: 2011-09-13 19:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Wicd 1.7.0-r1.ebuild which fixes bug (wicd-1.7.0-r1.ebuild,2.89 KB, text/plain)
2010-06-21 08:13 UTC, Phillip Merensky
Details
Jonathan's patch for fixing the issue (1.7.0-fix_stall_on_disconnecting_active_connections_all_.patch,1.14 KB, text/plain)
2010-06-21 08:14 UTC, Phillip Merensky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phillip Merensky 2010-06-21 08:10:58 UTC
When using wicd-gtk and having scripts set for execution on connection or disconnection wicd-gtk stalls with "Disconnecting active connections" in the status bar.
When using wicd-curses the bug did not occur to me. The bug is already filed upstream at https://bugs.launchpad.net/wicd/+bug/438402 but marked incomplete. However there is a working patch by Jonathan (Comment #17) yet.
Because I had no time to wait on upstream inclusion and because wicd-1.6.2 is not longer in the tree, I wrote an ebuild which includes Jonathan's patch and thus fixes this issue. 

Reproducible: Always

Steps to Reproduce:
1. Create a custom wired connection in wicd-gtk
2. Add scripts for execution on disconnection/connection
3. Try to connect to that connection

Actual Results:  
Wicd stalls and thus is not usable.

Expected Results:  
Successful connection.

Workaround: Use Wicd-curses
Comment 1 Phillip Merensky 2010-06-21 08:13:09 UTC
Created attachment 236129 [details]
Wicd 1.7.0-r1.ebuild which fixes bug

Only use this ebuild with the attached patch copied to the files directory.
Comment 2 Phillip Merensky 2010-06-21 08:14:08 UTC
Created attachment 236131 [details]
Jonathan's patch for fixing the issue

Usage in correspondence with the ebuild. Copy this patch to the files directory of the ebuild.
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-20 23:50:52 UTC
assigning to new maintainer.
Comment 4 Thomas Kahle (RETIRED) gentoo-dev 2011-09-13 19:12:54 UTC
This patch was applied long time ago.  It is included in the 1.7.1 beta series that already has a stable version.