Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 324615 - dev-perl/IPC-Run-0.89 fails tests
Summary: dev-perl/IPC-Run-0.89 fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2010-06-18 17:25 UTC by Paweł Hajdan, Jr. (RETIRED)
Modified: 2014-03-15 05:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (dev-perl:IPC-Run-0.89:20100618-114330.log,8.23 KB, text/plain)
2010-06-18 17:26 UTC, Paweł Hajdan, Jr. (RETIRED)
Details
build.log (dev-perl:IPC-Run-0.89:20100729-232855.log,8.08 KB, text/plain)
2010-07-29 23:30 UTC, Paweł Hajdan, Jr. (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-06-18 17:25:34 UTC
t/pty.t ...................... 1/32 
#   Failed test at t/pty.t line 170.
#          got: 'hello'
#     expected: '(?-xism:^hello\r?\n(?!\n)$)'

#   Failed test at t/pty.t line 198.
#          got: 'hello
# HELLO
# hello'
#     expected: '(?i-xsm:^(?:hello\r?\n){3}(?!\n)$)'

#   Failed test at t/pty.t line 204.
#          got: 'hello
# HELLO
# helloworld
# 
# WORLD
# world
# '
#     expected: '(?i-xsm:^(?:hello\r?\n){3}(?:world\r?\n){3}(?!\n)$)'
# Looks like you failed 3 tests of 32.
^M                                      ^Mt/pty.t ...................... Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/32 subtests 
t/pump.t ..................... ^Mt/pump.t ..................... 1/27 ^M                                      ^Mt/pump.t ..................... ok
t/run.t ...................... ^Mt/run.t ...................... 1/266 ^Mt/run.t ...................... 144/266 ^M                                        
^Mt/run.t ...................... ok
t/signal.t ................... ^Mt/signal.t ................... 1/3 ^M                                    ^Mt/signal.t ................... ok
t/timeout.t .................. ^Mt/timeout.t .................. 1/25 ^Mt/timeout.t .................. 9/25 ^Mt/timeout.t .................. 19/25 ^Mt/timeout.t .................. 24/25 ^M                                      ^Mt/timeout.t .................. ok
t/timer.t .................... ^Mt/timer.t .................... 1/72 ^Mt/timer.t .................... 72/72 ^M                                      ^Mt/timer.t .................... ok
t/win32_compile.t ............ ^Mt/win32_compile.t ............ 1/1 ^M                                    ^Mt/win32_compile.t ............ ok
t/windows_search_path.t ...... ^Mt/windows_search_path.t ...... 1/11 ^M                                      ^Mt/windows_search_path.t ...... ok

Test Summary Report

-------------------
t/pty.t                    (Wstat: 768 Tests: 32 Failed: 3)
  Failed tests:  17, 26, 28
  Non-zero exit status: 3
Files=20, Tests=685, 15 wallclock secs ( 0.08 usr  0.09 sys +  0.72 cusr  1.54 csys =  2.43 CPU)
Result: FAIL
Failed 1/20 test programs. 3/685 subtests failed.
make: *** [test_dynamic] Error 255
 * ERROR: dev-perl/IPC-Run-0.89 failed:
 *   test failed
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_test
 *   environment, line 2649:  Called perl-module_src_test
 *   environment, line 2385:  Called die
 * The specific snippet of code:
 *                   emake test TEST_VERBOSE=${TEST_VERBOSE:-0} || die "test failed";
 * 


Portage 2.1.8.3 (default/linux/x86/10.0/developer, gcc-4.4.3, glibc-2.11.1-r0, 2.6.30-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-i686-Intel-R-_Core-TM-2_Duo_CPU_P8700_@_2.53GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 18 Jun 2010 10:30:21 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.6.3-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA spin-educational"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/fax /usr/share/X11/xkb /usr/share/config /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests collision-protect cvs distlocks fixpackages multilib-strict news parallel-fetch protect-owned sandbox sfperms splitdebug strict test test-fail-continue unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emacs emboss encode exif fam firefox flac fortran gdbm gif gtk hal iconv jpeg lcms libnotify mad mbox mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nss ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support readline reflection sdl session snmp spell spl sqlite ssl startup-notification subversion svg sysfs tcb tcpd tiff toolkit-scroll-bars truetype unicode usb vorbis x264 x86 xcb xft xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vmware vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-06-18 17:26:42 UTC
Created attachment 235875 [details]
build.log
Comment 2 David Abbott gentoo-dev 2010-06-18 18:42:02 UTC
Passed here;
make -j5 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.12.1 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/97_meta.t .................. skipped: Author tests not required for installation
t/98_pod.t ................... skipped: Author tests not required for installation
t/98_pod_coverage.t .......... skipped: Author tests not required for installation
t/99_perl_minimum_version.t .. skipped: Author tests not required for installation
t/adopt.t .................... skipped: adopt not implemented yet
t/binmode.t .................. ok     
t/bogus.t .................... ok   
t/filter.t ................... ok     
t/harness.t .................. ok       
t/io.t ....................... ok     
t/kill_kill.t ................ ok   
t/parallel.t ................. ok   
t/pty.t ...................... # IO::Tty 1.08, IO::Pty 1.08
t/pty.t ...................... ok     
t/pump.t ..................... ok     
t/run.t ...................... ok       
t/signal.t ................... ok   
t/timeout.t .................. ok     
t/timer.t .................... ok     
t/win32_compile.t ............ ok   
t/windows_search_path.t ...... ok     
All tests successful.
Files=20, Tests=685, 12 wallclock secs ( 0.15 usr  0.02 sys +  1.22 cusr  0.35 csys =  1.74 CPU)
Result: PASS

Did dev-perl/IO-Tty-1.08 Pass ? Its an rdep.

Comment 3 David Abbott gentoo-dev 2010-06-18 19:00:08 UTC
Passes on 5.10.1 also may be your using 5.8.8 ?

make -j3 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.10.1 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/97_meta.t .................. skipped: Author tests not required for installation
t/98_pod.t ................... skipped: Author tests not required for installation
t/98_pod_coverage.t .......... skipped: Author tests not required for installation
t/99_perl_minimum_version.t .. skipped: Author tests not required for installation
t/adopt.t .................... skipped: adopt not implemented yet
t/binmode.t .................. ok     
t/bogus.t .................... ok   
t/filter.t ................... ok     
t/harness.t .................. ok       
t/io.t ....................... ok     
t/kill_kill.t ................ ok   
t/parallel.t ................. ok   
t/pty.t ...................... # IO::Tty 1.08, IO::Pty 1.08
t/pty.t ...................... ok     
t/pump.t ..................... ok     
t/run.t ...................... ok       
t/signal.t ................... ok   
t/timeout.t .................. ok     
t/timer.t .................... ok     
t/win32_compile.t ............ ok   
t/windows_search_path.t ...... ok     
All tests successful.
Files=20, Tests=685, 12 wallclock secs ( 0.21 usr  0.03 sys +  1.40 cusr  0.42 csys =  2.06 CPU)
Result: PASS
Comment 4 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-07-29 23:30:45 UTC
Created attachment 240645 [details]
build.log

I reproduced this with perl-5.10.1 after running perl-cleaner --all. Down to 2 subtests failed from 3 before, but still failure.
Comment 5 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-07-29 23:31:26 UTC
(In reply to comment #2)
> Did dev-perl/IO-Tty-1.08 Pass ? Its an rdep.

Yes, it did. I think it has no tests by the way.
Comment 6 David Abbott gentoo-dev 2010-07-30 00:54:57 UTC
Passed here on 5.8.8 also

All tests successful.
Files=20, Tests=685, 12 wallclock secs ( 0.18 usr  0.05 sys +  1.58 cusr  0.37 csys =  2.18 CPU)
Result: PASS

>>> Install IPC-Run-0.89 into /var/tmp/portage/dev-perl/IPC-Run-0.89/image/ category dev-perl
make -j3 pure_install 
Installing /var/tmp/portage/dev-perl/IPC-Run-0.89/image/usr/lib/perl5/vendor_perl/5.8.8/IPC/Run.pm

I see yours fails here;

#   Failed test at t/pty.t line 198.
#          got: 'hello
# HELLO
# hello'
#     expected: '(?i-xsm:^(?:hello\r?\n){3}(?!\n)$)'

#   Failed test at t/pty.t line 204.
#          got: 'hello
# HELLO
# helloworld
# 
# WORLD
# world
# '
#     expected: '(?i-xsm:^(?:hello\r?\n){3}(?:world\r?\n){3}(?!\n)$)'
# Looks like you failed 2 tests of 32.

Comment 7 Torsten Veller (RETIRED) gentoo-dev 2010-07-30 05:12:23 UTC
Upstream has a number of bugs for pty.t <https://rt.cpan.org/Public/Dist/Display.html?Name=IPC-Run>;
for example https://rt.cpan.org/Public/Bug/Display.html?id=20105
Or another where it fails with a non-C locale.

Don't know what to do. Maybe we just disable the pty.t test?
Comment 8 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2011-10-03 03:04:30 UTC
(In reply to comment #7)
> Upstream has a number of bugs for pty.t
> <https://rt.cpan.org/Public/Dist/Display.html?Name=IPC-Run>;
> for example https://rt.cpan.org/Public/Bug/Display.html?id=20105
> Or another where it fails with a non-C locale.
> 
> Don't know what to do. Maybe we just disable the pty.t test?

This is still happening, over a year from last activity on this bug. Maybe go ahead and disable?
Comment 9 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-03-15 05:45:59 UTC
Should be fine in 0.910.0