Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 32400 - Kernel Doesnt Compile during install, make: *** [vmlinux] Error 1
Summary: Kernel Doesnt Compile during install, make: *** [vmlinux] Error 1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: Sparc Linux
: High blocker (vote)
Assignee: Sparc Porters
Depends on:
Reported: 2003-10-31 09:52 UTC by Tim Smith
Modified: 2006-02-04 06:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tim Smith 2003-10-31 09:52:51 UTC
drivers/input/inputdrv.o in function emulate_raw
undefined reference to handle_scancode
drivers/input/inputdrv.o more undefined references to handle_scancode
drivers/input/inputdrv.o in function keybdev_init
undefined reference to kbd_ledfunc

make: *** [vmlinux] Error 1

fresh install from stage3 bypassing broken bootstrap libperl

compiling on sun ultra1 with rather liberal kernel options. also tried with 
very restrictive kernel options, same result. right before it spat that out, it 
was doing something with /usr/src/linXXX/arch/sparc64/prom/promlib.a (sorry im 
not more specific, im no good at interperting GCC output and I cant copy/paste 
off this system.... ).

Reproducible: Always
Steps to Reproduce:
1. make dep && make clean vmlinux modules modules_install

Actual Results:  
normal kernel compilation GCC stuff, until it spat the error out

Expected Results:  
should have finished compiling the kernel

system 2.4.21-rc6-up sparc64 sun4u
features sandbox ccache
Comment 1 Keith M Wesolowski (RETIRED) gentoo-dev 2003-11-01 08:48:03 UTC
Can you please paste a .config that triggers the problem?
Comment 2 Sven Blumenstein (RETIRED) gentoo-dev 2003-11-17 04:33:08 UTC

is this problem still valid or does it work for you now?
Please attach the .config if it still b0rks for you.
Comment 3 Sven Blumenstein (RETIRED) gentoo-dev 2003-11-30 06:52:24 UTC
Reopen if the problem still exists.