Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323787 - sys-kernel/gentoo-sources-2.6.34: system freeze (intel videocard, i915 driver, DRM)
Summary: sys-kernel/gentoo-sources-2.6.34: system freeze (intel videocard, i915 driver...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical with 1 vote (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2010-06-13 15:23 UTC by Igor Poboiko
Modified: 2010-07-30 12:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

kern.log with call trace (kern.log,113.83 KB, text/plain)
2010-06-13 15:24 UTC, Igor Poboiko
Kernel config for video section (kernlog,3.56 KB, text/plain)
2010-06-13 15:32 UTC, Igor Poboiko

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Poboiko 2010-06-13 15:23:30 UTC
I worked in X, and suddenly system hangs. It happens accidentally. Kern.log with call trace attached.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Just start X session
2. Work in it some time (from some minutes to some days, absolutely randomly)

Actual Results:  
System freezes, and only hard reset helps.

Expected Results:  
It works

# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
/var/log/Xorg.0.log says:

(II) intel(0): Integrated Graphics Chipset: Intel(R) GM45                                                                            (--) intel(0): Chipset: "GM45"
# emerge --info x11-base/xorg-server
Portage 2.2_rc67 (default/linux/x86/10.0/desktop/kde, gcc-4.4.4, glibc-2.11.2-r0, 2.6.34-gentooli3710 i686)
                        System Settings
System uname: Linux-2.6.34-gentooli3710-i686-Intel-R-_Celeron-R-_CPU_900_@_2.20GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 12 Jun 2010 20:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_LICENSE="* -@EULA LOKI-EULA Q3AEULA sun-bcla-java-vm dlj-1.1 PUEL skype-eula googleearth"
CFLAGS="-O2 -march=i686 -pipe -ggdb"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe -ggdb"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="ru en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/db/paludis/repositories/java-overlay /var/db/paludis/repositories/roslin /var/db/paludis/repositories/kde /var/db/paludis/repositories/mine"
USE="X a52 aac acl acpi alsa bash-completion berkdb branding bzip2 cairo cdda cdr chm cli consolekit cracklib crypt ctype cups curl cxx dbus dcc_video djvu dri dri2 dts dvd dvdr emboss encode exif fam fbcon fbcondecor ffmpeg filter firefox flac fortran gdbm geoip gif glib gpm gstreamer hal handbook iconv icq imagemagick ipv6 jabber jpeg jpeg2k kde kipi kontact lame laptop lcms ldap libnotify mad mikmod mjpeg mng modules mp3 mp4 mpeg mudflap musepack ncurses networkmanager nls nptl nptlonly ntfs ogg opengl openmp openssl oscar pam pango pcre pdf perl phonon pm-utils png policykit ppds pppd python qt-webkit qt3support qt4 readline reflection resolvconf samba sdl semantic-desktop session skype spell spl ssl startup-notification subversion svg sysfs taglib tcpd theora threads tiff truetype udev unicode usb utf8 v4l v4l2 vcd vim-syntax visibility vnc vorbis wav wavpack webkit wifi win32codecs wma x264 x86 xcb xcomposite xml xmp xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

                        Package Settings

x11-base/xorg-server-1.8.1-r1 was built with the following:
USE="hal ipv6 nptl udev xorg -dmx -doc -kdrive -minimal -static-libs -tslib" 
LDFLAGS="-Wl,-O1 -Wl,-z,lazy"
Comment 1 Igor Poboiko 2010-06-13 15:24:30 UTC
Created attachment 235193 [details]
kern.log with call trace
Comment 2 Igor Poboiko 2010-06-13 15:32:57 UTC
Created attachment 235195 [details]
Kernel config for video section
Comment 3 Igor Poboiko 2010-06-13 18:06:52 UTC
And after downgrading to xorg-server 1.7.7 looks like this bug dissapeared.
Comment 4 Michael Weber (RETIRED) gentoo-dev 2010-06-15 13:10:21 UTC
This looks like an x11 problem to me, please reassign to kernel@g.o if i'm wrong.
Comment 5 Rémi Cardona (RETIRED) gentoo-dev 2010-06-23 10:41:28 UTC
(In reply to comment #3)
> And after downgrading to xorg-server 1.7.7 looks like this bug dissapeared.

Then, which server were you using before?

Could you give one of the 2.6.35_rc kernels a try?

Comment 6 Igor Poboiko 2010-06-23 18:32:29 UTC
I tried xorg-server 1.8.1(-r1) and
Comment 7 Igor Poboiko 2010-06-30 13:01:45 UTC
I installed sys-kernel/vanilla-sources-2.6.35_rc3, x11-base/xorg-server- and looks like it helped! Now X/kernel doesn't crash and all works fine. Thanks!
Comment 8 Frank 2010-07-08 06:46:08 UTC
Could you track it down to either the kernel or xorg? 

I suppose, needing a working system, I would need to wait until the new kernel will be released?

Another thought: For me it seems, like x11-drivers/xf86-video-intel-2.11.0 stabilizes the system more than x11-drivers/xf86-video-intel-2.12.0. Right now I am running x11-base/xorg-server- and sys-kernel/gentoo-sources-2.6.34-r1 which dont seem to crash my system as often with the 2.11 driver. Is this something, you experienced too?

Sorry, I dont have the time right now to investigate it further, so I am just guessing...
Comment 9 Lukas Schneiderbauer 2010-07-30 12:24:55 UTC
Im using

The bug came up with gentoo-sources-2.6.34 for me, but didnt disappear with vanilla-kernel 2.6.35_rc5.