Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323425 - net-libs/libpcap-1.1.1: unusable with bonding devices activated
Summary: net-libs/libpcap-1.1.1: unusable with bonding devices activated
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL: http://sourceforge.net/tracker/index....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-10 14:25 UTC by Oliver Schmidt
Modified: 2010-06-11 18:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for correct bonding device handling (libpcap-1.1.1-bond.patch,422 bytes, patch)
2010-06-10 14:26 UTC, Oliver Schmidt
Details | Diff
Enhanced ebuild to implement the patch (libpcap-1.1.1-r1.ebuild,1.68 KB, text/plain)
2010-06-10 14:27 UTC, Oliver Schmidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Schmidt 2010-06-10 14:25:08 UTC
If you have the new stable libpcap 1.1.1 and kernel support for Bonding devices, libpcap will refuse to work as described in the upstream bug report (see URL).

Since this will be included in 1.1.2 first, I changed the ebuild for v1.1.1 a little bit to include the patch. Please find attached the modified ebuild + patch.

Reproducible: Always

Steps to Reproduce:
1. Install libpcap + tcpdump or jnettop
2. Active kernel support for Bonding (CONFIG_BONDING=y or M)
3. Try to execute jnettop or tcpdump 

Actual Results:  
Program crashes with "pcap_findalldevs: SIOCGIFFLAGS: bonding_masters: No such device"
Comment 1 Oliver Schmidt 2010-06-10 14:26:01 UTC
Created attachment 234855 [details, diff]
Patch for correct bonding device handling

Copied from http://sourceforge.net/tracker/index.php?func=detail&aid=2993250&group_id=53067&atid=469579
Comment 2 Oliver Schmidt 2010-06-10 14:27:35 UTC
Created attachment 234857 [details]
Enhanced ebuild to implement the patch

Modified the v1.1.1 ebuild in main portage tree
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2010-06-11 18:25:27 UTC
Thank you for report. This patch was added in libpcap-1.1.1-r1.