Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323157 - kernel 2.6.32-r8 oops with btrfs / loop
Summary: kernel 2.6.32-r8 oops with btrfs / loop
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Hardened (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: The Gentoo Linux Hardened Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-08 10:36 UTC by barthek
Modified: 2010-06-28 16:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
for completness, kernel config (kernconfig.txt,38.33 KB, text/plain)
2010-06-08 15:07 UTC, barthek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description barthek 2010-06-08 10:36:22 UTC
Hi,
I'm experiencing this strange behaviour with btrfs over loop on 2.6.32-r8 hardened kernel.
I use this setup to keep portage tree and kernel sources.

I saw this kernel error message, which I believe is related to the issue (even though 'last sysfs' suggests something else...):

Jun  4 02:12:18 felix.ibt.com.pl felix kernel: kernel BUG at mm/slub.c:1170!
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: invalid opcode: 0000 [#1]
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: last sysfs file: /sys/devices/virtual/net/lo/statistics/tx_dropped
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: Modules linked in: sch_sfq cls_u32 sch_htb ipt_REJECT xt_tcpudp nf_nat_ftp nf_conntrack_ftp xt_state xt_limit ipt_LOG iptable_mangle iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter xt_conntrack nf_conntrack ip_tables x_tables lm78 hwmon_vid hwmon loop i2c_piix4
Jun  4 02:12:18 felix.ibt.com.pl felix kernel:
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: Pid: 13474, comm: loop1 Not tainted (2.6.32-hardened-r8 #1)
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: EIP: 0060:[<000541fe>] EFLAGS: 00010202 CPU: 0
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: EAX: 00000010 EBX: c1e61aa0 ECX: 0002011a EDX: d38a3500
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: ESI: 00000000 EDI: d38a3480 EBP: d38a3480 ESP: c8fb79dc
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: DS: 0068 ES: 0068 FS: 0000 GS: 0000 SS: 0068
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: Process loop1 (pid: 13474, ti=c8fb6000 task=c06c2780 task.ti=c8fb6000)
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: Stack:
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: ffffffff 0002011a 00000010 00000286 0002011a 00000202 0002011a d38a3480
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: <0> 00000050 000546bd 000f794e d38a3500 1ff7c000 00000000 1ff7cfff 00000000
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: <0> 000f794e 1ff7c000 000f944d 00000010 c8d7a01c c535b320 00000000 1ff7dfff
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: Call Trace:
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl last message repeated 2 times
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000546bd>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000f794e>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000f794e>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000f944d>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000f99bd>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000ddb50>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<00037516>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0003f62b>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0003e6d5>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0003fcf7>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<000f4240>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<00011c1b>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<00040756>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<00011d1a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:18 felix.ibt.com.pl felix kernel: [<0003e64e>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0003c08b>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0002011a>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00005645>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0003d29c>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0003ffff>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0003d382>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0003d67f>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00005645>] ?
Jun  4 02:12:19 felix.ibt.com.pl last message repeated 2 times
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<000705f2>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00005645>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0000564f>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00005650>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0012378b>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00123bb1>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00166211>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00166243>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<0016c5bb>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: [<00121f01>] ?
Jun  4 02:12:19 felix.ibt.com.pl felix kernel: Code: 24 04 80 e5 7f 83 e0 10 89 4c 24 10 89 44 24 08 75 0e eb 0d 8b 4c 24 2c 89 51 04 e9 4f ff ff ff fb f7 44 24 10 06 00 c0 ff 74 04 <0f> 0b eb fe 8b 5c 24 10 b9 d8 f7 81 c1 8b 7d 10 81 e3 f0 1e 07


the system didn't die nor reboot but I can no longer access the btrfs/loop mount and processes using it are hung.e.g. updatedb, emerge sync etc. Just stay there doing nothing. Can't be killed.
Comment 1 Anthony Basile gentoo-dev 2010-06-08 14:44:49 UTC
Can you post your emerge --info, I'm going to try to reproduce this.
Comment 2 barthek 2010-06-08 15:04:00 UTC
sorry forgot to include that info
bear in mind its been running fine for about a week before this happened... good luck ;)

Portage 2.1.8.3 (hardened/linux/x86/10.0, gcc-4.3.4, glibc-2.11.1-r0, 2.6.32-hardened-r8 i686)
=================================================================
System uname: Linux-2.6.32-hardened-r8-i686-Pentium_II_-Deschutes-with-gentoo-2.0.1
Timestamp of tree: Tue, 08 Jun 2010 11:15:02 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.7.9-r1, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       3.4.6-r2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.8
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium2 -O2 -pipe -fstack-protector"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=pentium2 -O2 -pipe -fstack-protector"
DISTDIR="/home/distfiles"
FEATURES="assume-digests collision-protect distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-L/mysql/lib/mysql"
PKGDIR="/mnt/sparse/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portagetmp"
PORTDIR="/mnt/sparse/portage"
SYNC="rsync://rsync7.pl.gentoo.org/gentoo-portage"

USE="bashlogger bzip2 caps chroot clamdtop clearpasswd cli cracklib crypt cxx dri elf ftp glibc-omitfp hardened ithreads jpeg mbox minimal modules ncurses nptl nptlonly old-hd-rules openmp pam pam_chroot pam_timestamp pcre perl pic png pppd pwdb python readline reflection sasl sendfile session sftplogging spl ssl symlink sysfs tcpd threads tools urandom userlocales x86 xinetd xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1     emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m        maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 intel  mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage  siliconmotion sis sisusb tdfx tga trident tseng v4l vesa via vmware      voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 barthek 2010-06-08 15:07:33 UTC
Created attachment 234539 [details]
for completness, kernel config
Comment 4 barthek 2010-06-11 10:25:12 UTC
it happened again... this time triggered by updatedb running through kernel source tree:


kernel BUG at mm/slub.c:1170!
invalid opcode: 0000 [#1]
last sysfs file: /sys/devices/virtual/block/loop0/removable
Modules linked in: sch_sfq cls_u32 sch_htb ipt_REJECT xt_tcpudp nf_nat_ftp nf_conntrack_ftp xt_state xt_limit ipt_LOG iptable_mangle iptable_nat
 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter xt_conntrack nf_conntrack ip_tables x_tables lm78 hwmon_vid hwmon loop i2c_piix4

Pid: 6980, comm: loop0 Not tainted (2.6.32-hardened-r8 #1)
EIP: 0060:[<000541fe>] EFLAGS: 00010202 CPU: 0
EAX: 00000010 EBX: c1d87840 ECX: 0002011a EDX: d38a3500
ESI: 00000000 EDI: d38a3480 EBP: d38a3480 ESP: d3a659dc
 DS: 0068 ES: 0068 FS: 0000 GS: 0000 SS: 0068
Process loop0 (pid: 6980, ti=d3a64000 task=d22472c0 task.ti=d3a64000)
Stack:
 ffffffff 0002011a 00000010 c676b470 0002011a 00000202 0002011a d38a3480
<0> 00000050 000546bd 000f794e d38a3500 207a1000 00000000 207a1fff 00000000
<0> 000f794e 207a1000 000f944d 00000010 ce84a01c c676b460 00000000 207b1fff
Call Trace:
 [<0002011a>] ?
 [<0002011a>] ?
 [<0002011a>] ?
 [<000546bd>] ?
 [<000f794e>] ?
 [<000f794e>] ?
 [<000f944d>] ?
 [<0002011a>] ?
 [<000f99bd>] ?
 [<0002011a>] ?
 [<000ddb50>] ?
 [<0002011a>] ?
 [<0002011a>] ?
 [<00037516>] ?
 [<0003f62b>] ?
 [<0003e6d5>] ?
 [<0003fcf7>] ?
 [<00139a4d>] ?

 [<00040756>] ?
 [<0002011a>] ?
 [<00011dc1>] ?
 [<0002011a>] ?
 [<0003e64e>] ?
 [<0002011a>] ?
 [<0003c08b>] ?
 [<0002011a>] ?
 [<0000a14a>] ?
 [<0003d29c>] ?
 [<0003ffff>] ?
 [<0003d382>] ?
 [<0003d67f>] ?
 [<0000a14a>] ?
 [<0000a14a>] ?
 [<0000a14a>] ?
 [<000705f2>] ?
 [<0000a14a>] ?
 [<0000a17a>] ?
 [<0000a17b>] ?
 [<0000c927>] ?
 [<004c4b40>] ?
 [<000118f9>] ?
 [<00002d91>] ?
 [<00015eb9>] ?
 [<00015eb8>] ?
 [<00011c97>] ?
 [<00015eb9>] ?
 [<0001428f>] ?
 [<000269d7>] ?
 [<0001196b>] ?
 [<0000c927>] ?
 [<0000a389>] ?
 [<00012816>] ?
 [<001dc6ad>] ?
 [<001dc784>] ?

 [<00285660>] ?
 [<0006f70c>] ?
 [<00070939>] ?
 [<000708d3>] ?
 [<0006eeb6>] ?
 [<0006f7dd>] ?
 [<00285c6b>] ?
 [<00285c06>] ?
 [<002856fb>] ?
 [<0028584b>] ?
 [<000252fd>] ?
 [<0002529d>] ?
 [<00004267>] ?
Code: 24 04 80 e5 7f 83 e0 10 89 4c 24 10 89 44 24 08 75 0e eb 0d 8b 4c 24 2c 89 51 04 e9 4f ff ff ff fb f7 44 24 10 06 00 c0 ff 74 04 <0f> 0b e
b fe 8b 5c 24 10 b9 d8 f7 81 c1 8b 7d 10 81 e3 f0 1e 07
EIP: [<000541fe>]  SS:ESP 0068:d3a659dc
---[ end trace 96b30f68b4b6dc35 ]---



felix ~ # lsof -n | grep '/mnt/compressed'
updatedb  25791    root  cwd       DIR       0,16     2492      66707 /mnt/compressed/src/linux-2.6.32-hardened-r8/arch/arm/include/asm
updatedb  25791    root    7r      DIR       0,16     2492      66707 /mnt/compressed/src/linux-2.6.32-hardened-r8/arch/arm/include/asm
Comment 5 Tony Vroon gentoo-dev 2010-06-11 21:43:28 UTC
BTRFS is an *experimental* filesystem for which the disk format isn't finalised. Even in 2.6.35, 3 versions ahead of what you are running, it carries this dire warning:
          Btrfs is highly experimental, and THE DISK FORMAT IS NOT YET
          FINALIZED.  You should say N here unless you are interested in
          testing Btrfs with non-critical data.
Comment 6 barthek 2010-06-12 10:22:09 UTC
i dont know why you keep repeating yourself about disk format ?
the reason i submitted the bug is that i believe it is somehow related to hardened branch - I've been using btrfs on a couple of other systems (ubuntu) with 2.6.32 kernel without any issues whatsoever.
Comment 7 barthek 2010-06-28 16:06:34 UTC
for future reference - I've upgraded to -r9 and have been running fine for over a week now.
hope this helps someone else