Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323149 - app-emulation/virtualbox-bin doesn't use the Qt system libraries
Summary: app-emulation/virtualbox-bin doesn't use the Qt system libraries
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
: 319271 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-08 09:25 UTC by Benedikt Reinartz
Modified: 2010-07-03 07:13 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for the ebuild (virtualbox-bin-3.2.4.ebuild.patch,1.51 KB, patch)
2010-06-08 09:26 UTC, Benedikt Reinartz
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benedikt Reinartz 2010-06-08 09:25:45 UTC
As said, VirtualBox doesn't use the system libraries and so looks quite aweful (at least in a Gnome environment). This patch for the ebuild creates symlinks during the install phase to the system libs.

Reproducible: Always

Steps to Reproduce:
Comment 1 Benedikt Reinartz 2010-06-08 09:26:19 UTC
Created attachment 234511 [details, diff]
Patch for the ebuild
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2010-06-08 10:57:12 UTC
Sorry to disappoint you but we cannot make a binary package use system qt libs. It may work now but may fail as soon as we for example get qt-4.7 into portage.
If you really find virtualbox-bin looking so ugly you may switch to virtualbox-ose which links against sytem qt.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2010-06-08 10:58:09 UTC
*** Bug 319271 has been marked as a duplicate of this bug. ***
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2010-07-03 07:13:10 UTC
*** Bug 326711 has been marked as a duplicate of this bug. ***