Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 322609 - libpng version conflict with 1.2.42-r2/-r3
Summary: libpng version conflict with 1.2.42-r2/-r3
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 322707 325265 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-03 14:05 UTC by Robert Bradbury
Modified: 2010-06-23 21:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Bradbury 2010-06-03 14:05:27 UTC
There appear to be problems integrating upgrades to libpng in determining which version is OK (1.2.43-r2 or 1.2.43-r3).

If I upgrade to r3 it wants to downgrade to r2; if I downgrade to r2 it wants to upgrade to r3.

I've looked through some of the ebuilds and it appears as if the problem might be associated with specific pages making specific requests for specific libpng versions in their ebuilds.  But given my poor understanding of ebuilds and version numbering I cannot be sure.

Some of "emerge --pretend --update --verbose --deep --newuse world" output is:

[ebuild  NS   ] media-libs/libpng-1.2.43-r3 [1.2.43-r2] 0 kB

[blocks B     ] media-libs/libpng:1.2 ("media-libs/libpng:1.2" is blocking media-libs/libpng-1.2.43-r2)
[blocks B     ] <media-libs/libpng-1.2.43-r3 ("<media-libs/libpng-1.2.43-r3" is blocking media-libs/libpng-1.2.43-r3)

Total: 5 packages (2 upgrades, 1 in new slot, 2 reinstalls), Size of downloads: 0 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'media-libs/libpng-1.2.43-r2', 'nomerge') pulled in by
    >=media-libs/libpng-1.2.43-r2:0 required by ('installed', '/', 'app-text/texlive-core-2008-r7', 'nomerge')
    >=media-libs/libpng-1.2.43-r2:0 required by ('installed', '/', 'x11-libs/cairo-1.8.8-r1', 'nomerge')
    media-libs/libpng:0 required by world
    (and 4 more)

  ('ebuild', '/', 'media-libs/libpng-1.2.43-r3', 'merge') pulled in by
    media-libs/libpng required by ('installed', '/', 'media-video/subtitleripper-0.3.4-r3', 'nomerge')
    media-libs/libpng required by ('installed', '/', 'app-office/openoffice-3.2.0', 'nomerge')
    media-libs/libpng required by ('installed', '/', 'media-video/w3cam-0.7.2', 'nomerge')
    (and 115 more)

Reproducible: Always

Steps to Reproduce:
1. Enable media-libs/libpng in /etc/portage/package.keywords
2. emerge -v libpng
3. emerge -pv world

Actual Results:  
Emerging libpng works fine.  Attempts to emerge world afterwards are problematic.

Expected Results:  
Latest version of libpng should be installed and used,

Seems to be a problem that cuts across multiple package ebuilds (given the large number of packages which seem to want v2 or v3).  Presumably there should be only a single "most up-to-date" version of libpng.
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2010-06-03 14:15:17 UTC
(In reply to comment #0)
> 1. Enable media-libs/libpng in /etc/portage/package.keywords

Then you need to also keyword libpng-1.4, because -r3 is designed to be co-installed with it.
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2010-06-03 14:16:02 UTC
and closing as invalid
Comment 3 Robert Bradbury 2010-06-03 14:32:11 UTC
I don't understand the suggested fix.

Old /etc/portage/package.keywords had:
media-libs/libpng ~x86
Tried adding:
media-libs-libpng-1.4 ~x86
  that failed with a syntax error.
Tried changing to
media-libs/libpng
  that still generates the error:
[blocks B     ] media-libs/libpng:1.2 ("media-libs/libpng:1.2" is blocking media-libs/libpng-1.2.43-r2)
[blocks B     ] <media-libs/libpng-1.2.43-r3 ("<media-libs/libpng-1.2.43-r3" is blocking media-libs/libpng-1.2.43-r3)

Is there some document I should have read/be reading?  My last emerge of libpng (May 9 2010) had no instructions at the end of the emerge listing.  It looks like libpng may be in the process of being "slotted".  Is there documentation on this anywhere?

Thanks.
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-06-04 03:59:22 UTC
*** Bug 322707 has been marked as a duplicate of this bug. ***
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2010-06-04 11:26:52 UTC
- 1.2.43-r3 is a special version designed to be co-installed with libpng-1.4.2
- both 1.2.43-r3 and 1.4.2 are in ~arch
- 1.2.43-r2 is stable
- as such, there won't be any hardblockers unless you have done something wrong in /etc/portage yourself, instead portage will autoresolve this for you with softblockers.
- ... or your /var/lib/portage/world might be broken, shouldn't have libpng there.

so this bug and the bug marked duplicate here is really invalids, there really isn't any problem.
Comment 6 Jeff Shanab 2010-06-04 14:28:34 UTC
(In reply to comment #5)
> - 1.2.43-r3 is a special version designed to be co-installed with libpng-1.4.2
> - both 1.2.43-r3 and 1.4.2 are in ~arch
> - 1.2.43-r2 is stable
> - as such, there won't be any hardblockers unless you have done something wrong
> in /etc/portage yourself, instead portage will autoresolve this for you with
> softblockers.
> - ... or your /var/lib/portage/world might be broken, shouldn't have libpng
> there.
> 
> so this bug and the bug marked duplicate here is really invalids, there really
> isn't any problem.
> 

Then the problem is one of documentation or lack of disseminating the information. Only the creator knows this detail. Days on the IRC channel and no one knows this. The description you gave for the package would be great. Instead it just reads "Portable Network Graphics Library" 

Search the forum and blogs and you will find many people bitten by and just masking 1.4 out to get buy. 

Maybe this is a "Documentation Bug".
Mostly I find people say the libpng situation is a mess.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2010-06-23 21:43:31 UTC
*** Bug 325265 has been marked as a duplicate of this bug. ***