Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 322479 - sys-app/portage : regenworld isn't properly prefixed
Summary: sys-app/portage : regenworld isn't properly prefixed
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-02 15:23 UTC by Florian CROUZAT (SuperFlo)
Modified: 2011-04-24 12:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
$EPREFIX/usr/sbin/regenworld patch (regenworld.patch,677 bytes, patch)
2010-06-02 15:24 UTC, Florian CROUZAT (SuperFlo)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian CROUZAT (SuperFlo) 2010-06-02 15:23:46 UTC
regenworld fails to locate the world file.

Do regenworld --help to perform a dry-run and see the displayed wrong path to the world file. I have attached a working patch, but it's (highly) probable that it is not the correct way to fix this.

As I understand it, the problem is that regenworld tries to concatenate portage.const.EPREFIX and portage.WORLD_FILE to build the path to the world file, but the later already contains the full prefixed path, except for the leading slash.

As sys-app/portage is kinda heavy, I only provide a patch for the $EPREFIX/usr/sbin/regenworld file, not the ebuild, you do it ;)
Comment 1 Florian CROUZAT (SuperFlo) 2010-06-02 15:24:40 UTC
Created attachment 233855 [details, diff]
$EPREFIX/usr/sbin/regenworld patch

Works fine on my prefix, but probably not the right way to do it. Yet, it still highlight the lines creating the issue.
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-06-03 20:25:24 UTC
%% regenworld --help
This script regenerates the portage world file by checking the portage
logfile for all actions that you've done in the past. It ignores any
arguments except --help. It is recommended that you make a backup of
your existing world file (/home/jolexa/portage/linux-64/home/jolexa/portage/linux-64/var/lib/portage/world) before using this tool.


What am I looking at?
Comment 3 Florian CROUZAT (SuperFlo) 2010-06-03 20:34:32 UTC
I'm not sure I understand your question correctly, it's pretty obvious that your world file isn't located at /home/jolexa/portage/linux-64/home/jolexa/portage/linux-64/var/lib/portage/world (see the two /home/jolexa/portage/... ? One come from portage.const.EPREFIX and the other from portage.WORLD_FILE. Regenworld concatenate them, see my "patch").
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-06-03 20:58:58 UTC
ah, yes.
Comment 5 Fabian Groffen gentoo-dev 2011-04-24 12:09:03 UTC
this bug seems to have been fixed already.