Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 322475 - app-emulation/virtualbox-bin-3.2.0 flooding system logs with systraces
Summary: app-emulation/virtualbox-bin-3.2.0 flooding system logs with systraces
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-02 14:25 UTC by Bogdan Lipski
Modified: 2010-06-23 23:33 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bogdan Lipski 2010-06-02 14:25:36 UTC
I am getting a lot of these messages below after upgrading to virtualbox 3.2.0 (3.1.6 and was ok, then i upgraded to 3.2.0 and started getting lots of messages as below, now i downgraded to 3.1.8 and it's also running without a problem)

problem observed under: gentoo 10 x64, all updates, kernel 2.6.33-vanilla and 2.6.34-gentoo
virtualbox 3.2.0
guests: windows 2003 x86, windows 2008 x64


problem seems to happen when network operations involved (not all though) - noticed with:
- clicking links in internet explorer/firefox (in guest)
- connecting by rdp

but does not seem to happen when using some other services like ftp.

host os and guests seem to run fine, so flooding seems to be the only symptom so far. very annoying though. there might be other one - guest having problems with shutting down completely.

i was googling for it, also in here and bug reports and found nothing so far.

here the example of messages i am getting, i have been getting tons of them every few minutes:
Jun 2 08:51:56 gizmo kernel: ------------[ cut here ]------------
Jun 2 08:51:56 gizmo kernel: WARNING: at net/core/dev.c:1737 skb_gso_segment+0xf9/0x239()
Jun 2 08:51:56 gizmo kernel: Hardware name: OEM
Jun 2 08:51:56 gizmo kernel: asix: caps=(0x0, 0x0) len=11434 data_len=0 ip_summed=1
Jun 2 08:51:56 gizmo kernel: Modules linked in: vboxnetadp vboxnetflt vboxdrv f71882fg coretemp hwmon cryptd aes_x86_64 aes_generic 8021q ipt_LOG xt_state iptable_filter xt_tcpudp iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 iptable_mangle ipt_addrtype xt_dscp xt_string xt_owner xt_multiport xt_mark xt_iprange xt_hashlimit xt_conntrack xt_connmark xt_DSCP xt_NFQUEUE xt_MARK xt_CONNMARK nf_conntrack ip_tables x_tables dahdi_echocan_mg2 wctdm dahdi crc_ccitt ipv6 reiserfs arc4 sr_mod cdrom ath9k ath9k_common mac80211 ath9k_hw ath cfg80211 snd_hda_codec_intelhdmi rtc_cmos iTCO_wdt asix rtc_core i2c_i801 usbnet led_class r8169 snd_hda_codec_realtek i2c_core pcspkr iTCO_vendor_support rtc_lib sg pata_jmicron snd_hda_intel snd_hda_codec snd_hwdep fan processor snd_pcm snd_timer snd soundcore psmouse snd_page_alloc thermal button ehci_hcd uhci_hcd thermal_sys usbcore
Jun 2 08:51:56 gizmo kernel: Pid: 7020, comm: VBoxHeadless Tainted: G W 2.6.34-gentoo-01 #1
Jun 2 08:51:56 gizmo kernel: Call Trace:
Jun 2 08:51:56 gizmo kernel: <IRQ> [<ffffffff8121bd01>] ? skb_gso_segment+0xf9/0x239
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121bd01>] ? skb_gso_segment+0xf9/0x239
Jun 2 08:51:56 gizmo kernel: [<ffffffff8102bc08>] ? warn_slowpath_common+0x77/0xa3
Jun 2 08:51:56 gizmo kernel: [<ffffffff8102bc90>] ? warn_slowpath_fmt+0x51/0x59
Jun 2 08:51:56 gizmo kernel: [<ffffffffa02c478a>] ? ipt_do_table+0x59f/0x5da [ip_tables]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa01331d7>] ? usbnet_get_drvinfo+0x50/0x7f [usbnet]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0148688>] ? asix_get_drvinfo+0x3c/0x51 [asix]
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121bd01>] ? skb_gso_segment+0xf9/0x239
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121bffb>] ? dev_hard_start_xmit+0x1ba/0x301
Jun 2 08:51:56 gizmo kernel: [<ffffffff8122c64e>] ? sch_direct_xmit+0x5a/0x15b
Jun 2 08:51:56 gizmo kernel: [<ffffffff8124109d>] ? ip_finish_output+0x0/0x28b
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121c4fe>] ? dev_queue_xmit+0x2bb/0x417
Jun 2 08:51:56 gizmo kernel: [<ffffffff8123c671>] ? ip_rcv_finish+0x321/0x33b
Jun 2 08:51:56 gizmo kernel: [<ffffffff8123c8f2>] ? ip_rcv+0x267/0x2a3
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121b5cd>] ? process_backlog+0x73/0xa1
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121b751>] ? net_rx_action+0x69/0x11d
Jun 2 08:51:56 gizmo kernel: [<ffffffff810304f1>] ? __do_softirq+0x8b/0x106
Jun 2 08:51:56 gizmo kernel: [<ffffffff81002ccc>] ? call_softirq+0x1c/0x28
Jun 2 08:51:56 gizmo kernel: <EOI> [<ffffffff810046d5>] ? do_softirq+0x31/0x63
Jun 2 08:51:56 gizmo kernel: [<ffffffff8121bbd3>] ? netif_rx_ni+0x19/0x1d
Jun 2 08:51:56 gizmo kernel: [<ffffffffa056a02f>] ? vboxNetFltPortOsXmit+0x7a/0x97 [vboxnetflt]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa056a9e9>] ? vboxNetFltRelease+0x297/0x386 [vboxnetflt]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa040752e>] ? g_abExecMemory+0x375ce/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0413efe>] ? g_abExecMemory+0x43f9e/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03edc74>] ? g_abExecMemory+0x1dd14/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03d8ca1>] ? g_abExecMemory+0x8d41/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03d8ca1>] ? g_abExecMemory+0x8d41/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03c61c2>] ? RTSpinlockAcquireNoInts+0xd/0x12 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0412aad>] ? g_abExecMemory+0x42b4d/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0414c37>] ? g_abExecMemory+0x44cd7/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0412652>] ? g_abExecMemory+0x426f2/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa041576a>] ? g_abExecMemory+0x4580a/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0444478>] ? g_abExecMemory+0x74518/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0444f2f>] ? g_abExecMemory+0x74fcf/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0445f92>] ? g_abExecMemory+0x76032/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa044642b>] ? g_abExecMemory+0x764cb/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa04464cd>] ? g_abExecMemory+0x7656d/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03e952d>] ? g_abExecMemory+0x195cd/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03ea6e7>] ? g_abExecMemory+0x1a787/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03d8ca1>] ? g_abExecMemory+0x8d41/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03edc74>] ? g_abExecMemory+0x1dd14/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03eb930>] ? g_abExecMemory+0x1b9d0/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03ff089>] ? g_abExecMemory+0x2f129/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03fd210>] ? g_abExecMemory+0x2d2b0/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03dfa4d>] ? g_abExecMemory+0xfaed/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffff81034e56>] ? process_timeout+0x0/0x5
Jun 2 08:51:56 gizmo kernel: [<ffffffff8103dc76>] ? prepare_to_wait+0x19/0x73
Jun 2 08:51:56 gizmo kernel: [<ffffffff8103dac0>] ? autoremove_wake_function+0x0/0x2e
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03d6a8a>] ? g_abExecMemory+0x6b2a/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03e3470>] ? g_abExecMemory+0x13510/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03ddc1b>] ? g_abExecMemory+0xdcbb/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03d8c42>] ? g_abExecMemory+0x8ce2/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa0412217>] ? g_abExecMemory+0x422b7/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03e2d1e>] ? g_abExecMemory+0x12dbe/0x180000 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03bc441>] ? supdrvIOCtlFast+0x41/0x53 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffffa03bc220>] ? SUPR0Printf+0xdd/0x232 [vboxdrv]
Jun 2 08:51:56 gizmo kernel: [<ffffffff810995d2>] ? vfs_ioctl+0x21/0x92
Jun 2 08:51:56 gizmo kernel: [<ffffffff81099acd>] ? do_vfs_ioctl+0x414/0x44c
Jun 2 08:51:56 gizmo kernel: [<ffffffff8104b58a>] ? sys_futex+0x113/0x131
Jun 2 08:51:56 gizmo kernel: [<ffffffff81099b42>] ? sys_ioctl+0x3d/0x5c
Jun 2 08:51:56 gizmo kernel: [<ffffffff81001eab>] ? system_call_fastpath+0x16/0x1b
Jun 2 08:51:56 gizmo kernel: ---[ end trace 8f28366478322075 ]---


Reproducible: Always

Steps to Reproduce:
possibly:
1. install gentoo amd64 version with kernels 2.6.33/34, emerge --sync,emerge --update --deep world
2. install virtualbox 3.2.0
3. install windows 2003 or 2008 guest with 3.2.0 guest additions
4. run firefox or IE and click on some links, or even connect to it via rdp and watch the messages log on host system
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2010-06-02 15:08:49 UTC
Is this with virtualbox-ose or virtualbox-bin?
Comment 2 Bogdan Lipski 2010-06-02 15:44:35 UTC
(In reply to comment #1)
> Is this with virtualbox-ose or virtualbox-bin?
> 

virtualbox-bin and virtualbox-modules, all compiled from portage
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2010-06-02 15:53:53 UTC
Since this only happens with a .0 release I'd say this is most likely a bug which upstream should be made aware of.
Please report this bug to the virtualbox bug tracker at http://www.virtualbox.org/wiki/Bugtracker