Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 322413 - app-admin/paxtest 0.9.9 available - version bump
Summary: app-admin/paxtest 0.9.9 available - version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Hardened (show other bugs)
Hardware: AMD64 Linux
: High enhancement (vote)
Assignee: The Gentoo Linux Hardened Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-01 21:36 UTC by Radoslaw Madej (radegand)
Modified: 2010-08-09 12:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild (paxtest-0.9.9.ebuild,2.13 KB, text/plain)
2010-07-11 02:31 UTC, Anthony Basile
Details
Replace -O2 with imported CFLAGS (paxtest-0.9.9-honor-CFLAGS.patch,522 bytes, patch)
2010-07-11 02:32 UTC, Anthony Basile
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Radoslaw Madej (radegand) 2010-06-01 21:36:34 UTC
Hi,
A new version of paxtest is available (0.9.9), the latest ebuild in the tree is for 0.9.7_pre5 and it would be nice to have the new one available via portage :). Source code for the new version is available here: http://grsecurity.net/~spender/paxtest-0.9.9.tgz

I tried to create a new ebuild locally and I've used the previous one as a starting point which worked fine apart from QA message below (tested on amd64 only):

* QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/lib64/paxtest/anonmap
 * /usr/lib64/paxtest/execbss
 * /usr/lib64/paxtest/execdata
 * /usr/lib64/paxtest/execheap
 * /usr/lib64/paxtest/execstack
 * /usr/lib64/paxtest/getamap
 * /usr/lib64/paxtest/getheap1
 * /usr/lib64/paxtest/getheap2
 * /usr/lib64/paxtest/getmain1
 * /usr/lib64/paxtest/getmain2
 * /usr/lib64/paxtest/getshlib
 * /usr/lib64/paxtest/getstack1
 * /usr/lib64/paxtest/getstack2
 * /usr/lib64/paxtest/mprotanon
 * /usr/lib64/paxtest/mprotbss
 * /usr/lib64/paxtest/mprotdata
 * /usr/lib64/paxtest/mprotheap
 * /usr/lib64/paxtest/mprotshbss
 * /usr/lib64/paxtest/mprotshdata
 * /usr/lib64/paxtest/mprotstack
 * /usr/lib64/paxtest/randamap
 * /usr/lib64/paxtest/randheap1
 * /usr/lib64/paxtest/randheap2
 * /usr/lib64/paxtest/randmain1
 * /usr/lib64/paxtest/randmain2
 * /usr/lib64/paxtest/randshlib
 * /usr/lib64/paxtest/randstack1
 * /usr/lib64/paxtest/randstack2
 * /usr/lib64/paxtest/rettofunc1
 * /usr/lib64/paxtest/rettofunc1x
 * /usr/lib64/paxtest/rettofunc2
 * /usr/lib64/paxtest/rettofunc2x
 * /usr/lib64/paxtest/shlibbss
 * /usr/lib64/paxtest/shlibdata
 * /usr/lib64/paxtest/shlibtest.so
 * /usr/lib64/paxtest/shlibtest2.so
 * /usr/lib64/paxtest/writetext

which seems to be due to my LDFLAGS including '--hash-style=gnu' (LDFLAGS="-Wl,-O1 -Wl,--sort-common,--warn-once,--hash-style=gnu").

When compiled without '--hash-style' option, no QA messages are reported. Unfortunately I don't know how this should be fixed properly...


Reproducible: Always

Steps to Reproduce:
1. download http://grsecurity.net/~spender/paxtest-0.9.9.tgz
2. unpack, compile, run and enjoy! ;)




Expected Results:  
paxtest-0.9.9.ebuild in the tree :)
Comment 1 Anthony Basile gentoo-dev 2010-07-11 02:31:35 UTC
Created attachment 238255 [details]
Ebuild

@solar: I wrote an ebuild for this and tested.  Should I put it up on the tree?
Comment 2 Anthony Basile gentoo-dev 2010-07-11 02:32:14 UTC
Created attachment 238257 [details, diff]
Replace -O2 with imported CFLAGS
Comment 3 cilly 2010-08-05 14:40:39 UTC
adding to tree?
 
Comment 4 Anthony Basile gentoo-dev 2010-08-05 14:50:17 UTC
(In reply to comment #3)
> adding to tree?
> 
> 

Solar is the maintainer, I did the leg work, but I will not add to the tree without his blessing.
Comment 5 solar (RETIRED) gentoo-dev 2010-08-07 14:17:44 UTC
(In reply to comment #4)
> Solar is the maintainer, I did the leg work, but I will not add to the tree
> without his blessing.

Blessing granted.
When you bump the pkg. Please set the maintainer to hardened@ or blueness@ 

Thanks in advance.
Comment 6 Anthony Basile gentoo-dev 2010-08-09 12:48:37 UTC
In the tree.  See also bug #331599.