Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321919 - net-misc/nx-3.4.0 failed to emerge
Summary: net-misc/nx-3.4.0 failed to emerge
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-28 22:59 UTC by David Badia
Modified: 2010-09-24 15:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emege output && emerge --info (bug.log,21.69 KB, text/plain)
2010-05-28 23:00 UTC, David Badia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Badia 2010-05-28 22:59:32 UTC
See attached

Reproducible: Always

Steps to Reproduce:
1.emerge  =net-misc/nx-3.4.0
Actual Results:  
x86_64-pc-linux-gnu-gcc -c -march=athlon64 -O2 -pipe -I../nx-X11/exports/include -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith -fPIC   Vars.c
In file included from ClientChannel.h:22,
                 from ClientReadBuffer.cpp:20:
Channel.h: In member function âint Channel::canCleanStore(MessageStore*)â:
Channel.h:505: warning: suggest parentheses around && within ||
In file included from ServerChannel.h:22,
                 from ServerReadBuffer.cpp:19:
Channel.h: In member function âint Channel::canCleanStore(MessageStore*)â:
Channel.h:505: warning: suggest parentheses around && within ||
In file included from Proxy.h:31,
                 from Agent.h:29,
                 from ClientProxy.cpp:19:
Channel.h: In member function âint Channel::canCleanStore(MessageStore*)â:
Channel.h:505: warning: suggest parentheses around && within ||
x86_64-pc-linux-gnu-g++ -o libXcomp.so.3.4.0 -Wl,-O1 -Wl,-soname,libXcomp.so.3 Loop.o Children.o Control.o Misc.o Socket.o Fork.o Pipe.o List.o Keeper.o Timestamp.o Transport.o Statistics.o Auth.o Agent.o Proxy.o Channel.o Message.o Split.o ClientProxy.o ServerProxy.o OpcodeStore.o ClientStore.o ServerStore.o ChannelCache.o ClientCache.o ServerCache.o ClientChannel.o ServerChannel.o GenericChannel.o ReadBuffer.o ProxyReadBuffer.o ClientReadBuffer.o ServerReadBuffer.o GenericReadBuffer.o EncodeBuffer.o DecodeBuffer.o WriteBuffer.o SequenceQueue.o IntCache.o CharCache.o XidCache.o ActionCache.o BlockCache.o BlockCacheSet.o StaticCompressor.o TextCompressor.o Unpack.o Alpha.o Colormap.o Jpeg.o Pgn.o Bitmap.o Rgb.o Rle.o Z.o ChangeProperty.o SendEvent.o ChangeGC.o CreateGC.o CreatePixmap.o SetClipRectangles.o CopyArea.o PolyLine.o PolySegment.o PolyFillRectangle.o PutImage.o TranslateCoords.o GetImage.o ClearArea.o ConfigureWindow.o PolyText8.o PolyText16.o ImageText8.o ImageText16.o PolyPoint.o PolyFillArc.o PolyArc.o FillPoly.o InternAtom.o GetProperty.o SetUnpackGeometry.o SetUnpackColormap.o SetUnpackAlpha.o PutPackedImage.o ShapeExtension.o RenderExtension.o GenericRequest.o QueryFontReply.o ListFontsReply.o GetImageReply.o GetPropertyReply.o GenericReply.o RenderGenericRequest.o RenderCreatePicture.o RenderChangePicture.o RenderFreePicture.o RenderPictureClip.o RenderPictureTransform.o RenderPictureFilter.o RenderCreateGlyphSet.o RenderFreeGlyphSet.o RenderAddGlyphs.o RenderComposite.o RenderCompositeGlyphs.o RenderFillRectangles.o RenderTrapezoids.o RenderTriangles.o PositionCacheCompat.o ChangeGCCompat.o CreatePixmapCompat.o SetUnpackColormapCompat.o SetUnpackAlphaCompat.o RenderCreatePictureCompat.o RenderFreePictureCompat.o RenderPictureClipCompat.o RenderCreateGlyphSetCompat.o RenderCompositeCompat.o RenderCompositeGlyphsCompat.o MD5.o Pack.o Vars.o -L../nx-X11/exports/lib  -shared  -lpng -ljpeg -lz
rm -f  libXcomp.a
ar clq libXcomp.a Loop.o Children.o Control.o Misc.o Socket.o Fork.o Pipe.o List.o Keeper.o Timestamp.o Transport.o Statistics.o Auth.o Agent.o Proxy.o Channel.o Message.o Split.o ClientProxy.o ServerProxy.o OpcodeStore.o ClientStore.o ServerStore.o ChannelCache.o ClientCache.o ServerCache.o ClientChannel.o ServerChannel.o GenericChannel.o ReadBuffer.o ProxyReadBuffer.o ClientReadBuffer.o ServerReadBuffer.o GenericReadBuffer.o EncodeBuffer.o DecodeBuffer.o WriteBuffer.o SequenceQueue.o IntCache.o CharCache.o XidCache.o ActionCache.o BlockCache.o BlockCacheSet.o StaticCompressor.o TextCompressor.o Unpack.o Alpha.o Colormap.o Jpeg.o Pgn.o Bitmap.o Rgb.o Rle.o Z.o ChangeProperty.o SendEvent.o ChangeGC.o CreateGC.o CreatePixmap.o SetClipRectangles.o CopyArea.o PolyLine.o PolySegment.o PolyFillRectangle.o PutImage.o TranslateCoords.o GetImage.o ClearArea.o ConfigureWindow.o PolyText8.o PolyText16.o ImageText8.o ImageText16.o PolyPoint.o PolyFillArc.o PolyArc.o FillPoly.o InternAtom.o GetProperty.o SetUnpackGeometry.o SetUnpackColormap.o SetUnpackAlpha.o PutPackedImage.o ShapeExtension.o RenderExtension.o GenericRequest.o QueryFontReply.o ListFontsReply.o GetImageReply.o GetPropertyReply.o GenericReply.o RenderGenericRequest.o RenderCreatePicture.o RenderChangePicture.o RenderFreePicture.o RenderPictureClip.o RenderPictureTransform.o RenderPictureFilter.o RenderCreateGlyphSet.o RenderFreeGlyphSet.o RenderAddGlyphs.o RenderComposite.o RenderCompositeGlyphs.o RenderFillRectangles.o RenderTrapezoids.o RenderTriangles.o PositionCacheCompat.o ChangeGCCompat.o CreatePixmapCompat.o SetUnpackColormapCompat.o SetUnpackAlphaCompat.o RenderCreatePictureCompat.o RenderFreePictureCompat.o RenderPictureClipCompat.o RenderCreateGlyphSetCompat.o RenderCompositeCompat.o RenderCompositeGlyphsCompat.o MD5.o Pack.o Vars.o
ranlib libXcomp.a
rm -f libXcomp.so.3
rm -f libXcomp.so
ln -s libXcomp.so.3.4.0 libXcomp.so.3
ln -s libXcomp.so.3.4.0 libXcomp.so
make -j10
if [ -x makedepend ] ; then \
                        makedepend   \
                        -I/usr/include/g++ -I/usr/include/g++-3 -f Makefile Main.c  Core.cpp Input.cpp Logger.cpp Shadow.cpp X11.cpp Win.cpp Updater.cpp Manager.cpp 2>/dev/null; \
                fi
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Core.cpp
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Input.cpp
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Logger.cpp
touch depend.status
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Shadow.cpp
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   X11.cpp
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++

x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Win.cpp
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Updater.cpp
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
x86_64-pc-linux-gnu-g++ -c -march=athlon64 -O2 -pipe -Wmissing-declarations -Wnested-externs -fPIC -DIN_ADDR_T=in_addr_t -DVERSION=\"3.4.0\"  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith   Manager.cpp
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
X11.cpp:27:34: error: X11/extensions/XTest.h: No such file or directory
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
X11.cpp:27:34: error: X11/extensions/XTest.h: No such file or directory
In file included from Core.h:24,
                 from X11.h:26,
                 from Poller.h:27,
                 from X11.cpp:33:
Regions.h:33: warning: âtypedefâ was ignored in this declaration
X11.cpp: In member function âvoid Poller::sendFakeModifierEvents(int, int)â:
X11.cpp:614: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:633: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:646: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:653: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:673: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:684: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:693: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:700: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:707: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:722: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:729: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:739: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:746: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:753: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp: In member function âvoid Poller::cancelFakeModifierEvents()â:
X11.cpp:772: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:784: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:796: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:808: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:820: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:832: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:844: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp:856: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp: In member function âvirtual void Poller::handleKeyboardEvent(Display*, XEvent*)â:
X11.cpp:1107: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp: In member function âvirtual void Poller::handleWebKeyboardEvent(KeySym, int)â:
X11.cpp:1209: error: âXTestFakeKeyEventâ was not declared in this scope
X11.cpp: In member function âvirtual void Poller::handleMouseEvent(Display*, XEvent*)â:
X11.cpp:1228: error: âXTestFakeMotionEventâ was not declared in this scope
X11.cpp:1232: error: âXTestFakeButtonEventâ was not declared in this scope
X11.cpp:1236: error: âXTestFakeButtonEventâ was not declared in this scope
X11.cpp: In member function âvoid Poller::xtestInit()â:
X11.cpp:1278: error: âXTestQueryExtensionâ was not declared in this scope
X11.cpp:1299: error: âXTestGrabControlâ was not declared in this scope
make: *** [X11.o] Error 1
make: *** Waiting for unfinished jobs....
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
In file included from Core.h:25,
                 from X11.h:27,
                 from Poller.h:28,
                 from Shadow.cpp:29:
Regions.h:33: warning: 'typedef' was ignored in this declaration
Shadow.cpp: In function 'void NXShadowResetOptions()':
Shadow.cpp:192: warning: no previous declaration for 'void NXShadowResetOptions()'
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
In file included from Core.h:25,
                 from Core.cpp:27:
Regions.h:33: warning: 'typedef' was ignored in this declaration
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
In file included from Updater.h:23,
                 from Manager.h:23,
                 from Manager.cpp:28:
Regions.h:33: warning: âtypedefâ was ignored in this declaration
cc1plus: warning: command line option "-Wnested-externs" is valid for C/ObjC but not for C++
In file included from Updater.h:24,
                 from Updater.cpp:31:
Regions.h:33: warning: 'typedef' was ignored in this declaration
 * ERROR: net-misc/nx-3.4.0 failed:
 *   nxcompshad emake failed
 *
 * Call stack:
 *     ebuild.sh, line  54:  Called src_compile
 *   environment, line 6276:  Called die
 * The specific snippet of code:
 *       emake || die "nxcompshad emake failed";
 *
 * If you need support, post the output of 'emerge --info =net-misc/nx-3.4.0',
 * the complete build log and the output of 'emerge -pqv =net-misc/nx-3.4.0'.
 * The complete build log is located at '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/temp/build.log'.
 * The ebuild environment file is located at '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/temp/environment'.
 * S: '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/work/nx-X11'

>>> Failed to emerge net-misc/nx-3.4.0, Log file:

>>>  '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/temp/build.log'

 * Messages for package net-misc/nx-3.4.0:

 * ERROR: net-misc/nx-3.4.0 failed:
 *   nxcompshad emake failed
 *
 * Call stack:
 *     ebuild.sh, line  54:  Called src_compile
 *   environment, line 6276:  Called die
 * The specific snippet of code:
 *       emake || die "nxcompshad emake failed";
 *
 * If you need support, post the output of 'emerge --info =net-misc/nx-3.4.0',
 * the complete build log and the output of 'emerge -pqv =net-misc/nx-3.4.0'.
 * The complete build log is located at '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/temp/build.log'.
 * The ebuild environment file is located at '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/temp/environment'.
 * S: '/mnt/tmplog/vartmp/portage/net-misc/nx-3.4.0/work/nx-X11'

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.







See attached
Comment 1 David Badia 2010-05-28 23:00:17 UTC
Created attachment 233341 [details]
emege output && emerge --info
Comment 2 Bernard Cafarelli gentoo-dev 2010-06-02 14:59:27 UTC
> X11.cpp:27:34: error: X11/extensions/XTest.h: No such file or directory

Hmm, this should be /usr/include/X11/extensions/XTest.h, provided by x11-libs/libXtst (which is in nx DEPEND)

What is the output of `qlist x11-libs/libXtst` on your system? (qlist from portage-utils). It may help to remerge it
Comment 3 Bernard Cafarelli gentoo-dev 2010-09-24 15:21:55 UTC
Looks like this was a temporary problem on a big update (from the number of unread news)

So I hope it's solved, if you still have the problem, don't hesitate to reopen with the output of comment #2