Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321799 - x11-drivers/xf86-video-nouveau: cursor sometimes disappears after blanking the screen
Summary: x11-drivers/xf86-video-nouveau: cursor sometimes disappears after blanking th...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 2 votes (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-28 10:14 UTC by Vladimir
Modified: 2018-11-27 22:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/etc/X11/xorg.conf (xorg-server-1.8.xorg.conf,5.02 KB, text/plain)
2010-07-02 12:35 UTC, Vladimir
Details
Xorg.0.log-1 (xorg-server-1.8.Xorg.0.log,27.92 KB, text/plain)
2010-07-02 12:35 UTC, Vladimir
Details
Xorg.0.log-1 (xorg-server-1.8.Xorg.0.log,27.92 KB, text/plain)
2010-07-02 12:36 UTC, Vladimir
Details
Xorg.0.log-2 (xorg-server-1.8.Xorg.0.log-2,28.33 KB, text/plain)
2010-07-02 12:36 UTC, Vladimir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2010-05-28 10:14:47 UTC
Hello!
I have encountered a following problem.
I adjusted my power management system to turn the screen off after some minutes of inactivity. Everything had been fine for years until last weeks. With new xorg-server (in my case - xorg-server-1.8.1-r1) mouse pointer tends to disappear from time to time after the screen is being turned off and on. 
  I still can use the pointer, but I just cannot see it.

  And to be honest, I'm not sure whether this is a xorg-server who causes this issue or not; but as far as I know, this is a xorg-server who is responsible for showing a mouse pointer on the screen.

Reproducible: Sometimes

Steps to Reproduce:
1. Upgrade to the x11-base/xorg-server-1.8.1-r1.
2. Setup your power management system to turn off the screen after some minutes of inactivity.
3. Wait until the screen is turned off.
4. Wait some more minutes.
5. Move your mouse and try to find the mouse pointer on the screen.
  If you do, then you are luckier than me. :)
Actual Results:  
Mouse pointer disappears.

Expected Results:  
Mouse pointer should be there.

Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.1-r0, 2.6.34-gentoo x86_64)
=================================================================
System uname: Linux-2.6.34-gentoo-x86_64-Mobile_AMD_Sempron-tm-_Processor_3800+-with-gentoo-2.0.1
Timestamp of tree: Thu, 27 May 2010 23:30:01 +0000
distcc[2110] (dcc_set_trace_from_env) ERROR: failed to open logfile /var/log/distccd.log: Permission denied [disabled]
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-python/pycrypto: 2.1.0
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.7b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA PUEL skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/mnt/data/Install/GNU-LinuxSoft/distfiles/"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="/mnt/lan/data/Install/GNU-LinuxSoft/distfiles/                 http://gentoo.kiev.ua/ftp/ ftp://gentoo.kiev.ua/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j3"
PKGDIR="/mnt/data/Install/GNU-LinuxSoft/binpkg/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/sage-on-gentoo /usr/local/overlays"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit 7zip X a52 aac aalib acpi alsa amd64 amrnb amrwb apm arts ass atm audiofile avahi bash-completion bcmath berkdb bzip2 cairo calendar cdb cddb cdparanoia cdr cgi clamav cli cracklib crypt ctype curl curlwrappers cxx dbm dbus dbx dga djvu dri dssi dts dvd dvdr dvdread encode esd evo exif expat faac faad fastcgi fbcon fbcondecor festival ffmpeg fftw firefox flac flatfile freetds ftp fuse gd gdbm geoip gif gimp ginac git glut gmp gnuplot gnustep gnutls gsl hal hddtemp htmlhandbook icc iconv icq idn imlib inifile innodb irc jabber jack javascript jbig jikes jpeg jpeg2k kerberos krb4 lame laptop lash latex ldap leim libcaca libnotify libsamplerate libwww lm_sensors lua lzo mad maildir matroska matrox mcal mhash mikmod milter mime mmap mmx mmxext mng modplug modules motiff mozilla mp3 mpeg mpi mplayer msn mudflap mule multilib musepack musicbrainz mysql mysqli nas ncurses nforce2 nls nptl nptlonly nsplugin nvidia ogg openal opencore-amr opengl openmp osc pam pcntl pdf plotutils pmu png posix pppd prelude profile python qt3support qt4 quicktime radius readline recode reflection rss rtc ruby samba sasl sdl session sharedmem shorten simplexml skins slang slp sndfile snmp soap sockets socks5 sox speex spell sqlite sqlite3 sse sse2 ssl ssse3 startup-notification svg symlink sysfs syslog systray sysvipc szip taglib tcl tcpd tetex theora threads tidy tiff timidity truetype unicode usb vcd vhosts vorbis wavpack wddx webkit x264 xattr xcb xcomposite xface xine xinerama xml xml-rpc xorg xosd xpm xsl xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Weber (RETIRED) gentoo-dev 2010-06-07 02:22:06 UTC
Hello Valdimir,

can you please attach your /etc/X11/xorg.conf* (if any) and your /var/log/Xorg.0.log of a `failed` X Server run? You can also ask in #gentoo-desktop on irc.freenode.net to get answers from other users, if it's a common problem.

Thanks, Michael
Comment 2 Rémi Cardona gentoo-dev 2010-06-23 11:41:08 UTC
Please get back to us with the requested information in comment #1.

Thanks
Comment 3 Vladimir 2010-07-02 12:35:16 UTC
Created attachment 237245 [details]
/etc/X11/xorg.conf
Comment 4 Vladimir 2010-07-02 12:35:45 UTC
Created attachment 237247 [details]
Xorg.0.log-1
Comment 5 Vladimir 2010-07-02 12:36:16 UTC
Created attachment 237249 [details]
Xorg.0.log-1
Comment 6 Vladimir 2010-07-02 12:36:46 UTC
Created attachment 237251 [details]
Xorg.0.log-2
Comment 7 Vladimir 2010-07-02 12:42:22 UTC
  Hello!
  It happened again. Let me describe my actions just before that.

- I was working on my laptop and everything was fine;
- I decided to update some applications, so I started to emerge them;
- I left my laptop compiling for several minutes;
- The screen turned off after 10 minutes of no activity;
- After some more time passed, I came back, moved a cursor to turn the screen on again and found that there is no mouse pointer on the screen. I still had an ability to push some buttons on the screen, but I just could not see the actual pointer location.
- I made a copy of xorg.conf (see "/etc/X11/xorg.conf" attachment) and /var/log/Xorg.0.log (see "Xorg.0.log-1" attachment);
- After that I left my X-session (logged off, then typed "/etc/init.d/xdm stop" from the console and then killed X-server process "kill -QUIT <X-server pid>").
- After starting X again (/etc/init.d/xdm start) there still was no mouse pointer on the screen.
- I made a new copy of /var/log/Xorg.0.log (see "Xorg.0.log-2" attachment).
  Only reboot of the machine returned the pointer back onto my screen.

  That is all story so far.
Comment 8 Vladimir 2010-07-08 13:00:11 UTC
  Well... It happened again.
  And this time both conditions were present again. Namely: I started 'emerge <something>' and left the laptop without activity from my side for several minutes. When I came up to it and touched the thouchpad to turn the screen on, there had been no mouse cursor on a screen.
  Since, this problem happens again and again, I reopen the bug if you don't mind.
Comment 9 Rémi Cardona gentoo-dev 2010-09-22 06:59:28 UTC
@Chi-Thanh, have you seen this before?

Cheers
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-09-22 09:51:11 UTC
There are a few known issues with disappearing or corrupted hardware cursors.

https://bugs.freedesktop.org/show_bug.cgi?id=24886
https://bugs.freedesktop.org/show_bug.cgi?id=28891
http://lists.freedesktop.org/archives/nouveau/2010-March/005318.html

See if you get any dmesg output when the cursor disappears. The usual workaround is to disable hardware cursor in xorg.conf (see "man nouveau" for details). You could also check if xorg-server-1.9.0 and/or xf86-video-nouveau-9999 from the x11 overlay makes a difference.
Comment 11 Vladimir 2012-06-15 19:28:36 UTC
It is getting worse and worse. Now the cursors disappears almost each time the screen is turned off and left alone for some time. What I noticed is that it usually does not disappear after the first screen blanking. It usually disappears after the screen has been turned off for a couple of times.

I tried turning off the 'hardware cursor' in the past, and it seem to work fine. Now I cannot do it any more because when I set 

    	Option		"HWCursor"	"off"

in /etc/X11/xorg.conf, I cannot even start Xfce (the X-server itself seems to work  though).

And one more thing. I have NVidia GeForce 7300 GT video card on another machine running Gentoo with KDE and I haven't noticed such cursor disappearances there.
I experience this problem only on my laptop with NVidia GeForce Go 6100 video card. Maybe it is related to certain video chip somehow.
Comment 12 Ronald 2012-06-19 07:48:31 UTC
This bug is known for a while, I'm experiencing it too.

https://bugs.freedesktop.org/show_bug.cgi?id=15758

What makes the problem worse, is how the xf86-video-nv maintainers fixed it (ugly hack):

http://cgit.freedesktop.org/xorg/driver/xf86-video-nv/commit/?id=7f281be7e53ac274016a6af6b2b5dc6f8bddb810

Which resulted from the original bug reported in the original (nv) driver:

https://bugs.freedesktop.org/show_bug.cgi?id=7309

Vladimir, could you please post a 'me too' on the first (15758) bug so it gets some more exposure?

On a sidenote, using the hwcursor option also breaks VT switching here (6150 go). So it's not weird you are experiencing issue's as well.
Comment 13 sphakka 2013-10-04 12:49:56 UTC
For me this now happens always, it's just a matter of (random?) time: usually it takes a bit (couple hours) to occur without doing anything special, apart from coming back to a blanked screen.

It's worth noting that this *also* happens with xf86-video-nv, thus the bug might well reside in xorg-server.
Comment 14 Matt Turner gentoo-dev 2018-11-27 22:50:11 UTC
Upstream driver bugs like this are really outside the capabilities of a distro
to fix.