Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321759 - sys-devel/libtool-2.2.8 fails with access violation on /dev/dri/card0 via `print` when /usr/Amaya/wx/bin/print exists
Summary: sys-devel/libtool-2.2.8 fails with access violation on /dev/dri/card0 via `pr...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-28 03:53 UTC by keenblade
Modified: 2010-06-10 07:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
full build log (sys-devel:libtool-2.2.7b:20100529-084636.log,29.43 KB, text/plain)
2010-05-29 08:50 UTC, keenblade
Details
full build log (sys-devel:libtool-2.2.8:20100607-173639.log,29.39 KB, text/plain)
2010-06-07 17:46 UTC, keenblade
Details
emerge --info --verbose (emergeinfo.txt,12.16 KB, text/plain)
2010-06-07 17:53 UTC, keenblade
Details
output of "strace -f -s 4096 -o log ebuild libtool-2.2.8.ebuild compile" (str.log,57.84 KB, text/plain)
2010-06-09 02:41 UTC, keenblade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description keenblade 2010-05-28 03:53:21 UTC
sys-devel/libtool-2.2.7b fails with access violation with this output:

>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-26461.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /dev/dri/card0
A: /dev/dri/card0
R: /dev/dri/card0
C: print -r -- -n

Reproducible: Always




emerge --info
Portage 2.2_rc67 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11.1-r0, 2.6.33-zen3 x86_64)
=================================================================
System uname: Linux-2.6.33-zen3-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 28 May 2010 00:30:12 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.5.4-r2, 2.6.5-r2, 3.1.2-r3
dev-python/pycrypto: 2.1.0
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.4_p6-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/media/xs-2/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests ccache collision-protect distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ "
LANG="tr_TR.UTF-8"
LC_ALL="tr_TR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="tr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/crossdev /usr/local/overlays/symix /usr/local/overlays/keenblade /var/lib/layman/pcsx2 /var/lib/layman/pok3d /var/lib/layman/pd-overlay /var/lib/layman/mpd /var/lib/layman/desktop-effects /var/lib/layman/emacs /var/lib/layman/java-overlay /var/lib/layman/sunrise /var/lib/layman/webapps-experimental /var/lib/layman/rox /var/lib/layman/enlightenment /var/lib/layman/mozilla /var/lib/layman/ladi /var/lib/layman/pro-audio /var/lib/layman/gechi /var/lib/layman/gnome"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif glitz gnome gpm gstreamer gtk iconv ipv6 jack java jpeg kde ladspa lash lcms ldap libnotify lm_sensors mad midi mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib mysql mysqli ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline reflection sdl session spell spl sqlite3 sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb vorbis x264 xcb xcomposite xinerama xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel mpu401 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="tr" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2010-05-28 12:22:20 UTC
Fabulous, now, how about attaching full build log ?
Comment 2 keenblade 2010-05-29 08:50:11 UTC
Created attachment 233377 [details]
full build log

Ok. Here the full fail build log is.
Comment 3 SpanKY gentoo-dev 2010-06-07 09:37:09 UTC
2.2.7b is going away, so double check 2.2.8 ... not that this error really makes sense in the first place ...

post `emerge --info --verbose` as an attachment
Comment 4 keenblade 2010-06-07 17:44:11 UTC
(In reply to comment #3)
> 2.2.7b is going away, so double check 2.2.8 ... not that this error really
> makes sense in the first place ...
> 
> post `emerge --info --verbose` as an attachment
> 

I checked 2.2.8 and it fails to build, too. The error is the same. I am attaching new build log and "emerge --info --verbose".
Comment 5 keenblade 2010-06-07 17:46:05 UTC
Created attachment 234447 [details]
full build log

full build log for libtool-2.2.8
Comment 6 keenblade 2010-06-07 17:53:46 UTC
Created attachment 234449 [details]
emerge --info --verbose
Comment 7 Samuli Suominen gentoo-dev 2010-06-07 18:01:25 UTC
Bug 192548, Bug 192872, Bug 192540... Running ati-drivers or some other "special" drivers?
Comment 8 keenblade 2010-06-07 18:10:34 UTC
(In reply to comment #7)
> Bug 192548, Bug 192872, Bug 192540... Running ati-drivers or some other
> "special" drivers?
> 

I use xf86-video-nouveau-0.0.16_pre20100510 which is in portage for my nvidia card.
Comment 9 keenblade 2010-06-07 18:17:58 UTC
Also x11-drivers/nvidia-drivers-195.36.24 is installed which is in portage. But I use nouveau at the moment.
Comment 10 SpanKY gentoo-dev 2010-06-07 22:43:35 UTC
if you run each step manually via `ebuild`, does it still fail ?

might be useful to get to the compile step and run that through strace:
strace -f -s 4096 -o log ebuild libtool-2.2.8.ebuild compile
Comment 11 keenblade 2010-06-09 02:41:01 UTC
Created attachment 234615 [details]
output of "strace -f -s 4096 -o log ebuild libtool-2.2.8.ebuild compile"

(In reply to comment #10)
> if you run each step manually via `ebuild`, does it still fail ?
> 
> might be useful to get to the compile step and run that through strace:
> strace -f -s 4096 -o log ebuild libtool-2.2.8.ebuild compile
> 
Running each step manually via ebuild, it does not fail. Although compile phase gives the same sandbox error, install and qmerge phases goes fine. The log file for strace output is 640mb sized. But I attached the console output of the strace you wanted sized 57kb.
Comment 12 SpanKY gentoo-dev 2010-06-09 04:08:30 UTC
whatever is installing this is broken:
/usr/Amaya/wx/bin/print

nothing should be installing a binary named `print`
Comment 13 Jeroen Roovers (RETIRED) gentoo-dev 2010-06-10 02:34:02 UTC
Amaya would be bug #165280.

The workaround for this "bug" is to remove the Amaya bin directory from your PATH variable.

For Gentoo there is nothing here to fix.
Comment 14 keenblade 2010-06-10 07:58:24 UTC
SpanKY and Jeroen Roovers, thank you both. You were right. Amaya was the problem. The bug is solved for me now. Many thanks again.