Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321163 - [gnome-overlay] dev-libs/gjs-0.6: compile failure gcc4.4/4.5
Summary: [gnome-overlay] dev-libs/gjs-0.6: compile failure gcc4.4/4.5
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InOverlay
: 329095 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-23 11:41 UTC by fkhp
Modified: 2011-04-09 06:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,139.21 KB, text/plain)
2010-05-23 11:47 UTC, fkhp
Details
emerge --info gjs (info,4.41 KB, text/plain)
2010-05-23 11:48 UTC, fkhp
Details
emerge --info (info,4.56 KB, text/plain)
2010-05-31 04:34 UTC, fkhp
Details
build log (build.log,140.34 KB, text/plain)
2010-05-31 04:35 UTC, fkhp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fkhp 2010-05-23 11:41:34 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/gjs-console: hidden symbol `atexit' in /usr/lib64/libc_nonshared.a(atexit.oS) is referenced by DSO
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make[1]: *** [gjs-console] 错误 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/gjs-0.6/work/gjs-0.6'
make: *** [all] 错误 2
 * ERROR: dev-libs/gjs-0.6 failed:
 *   compile failure
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 1569:  Called gnome2_src_compile
 *   environment, line 1305:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 * 
 * If you need support, post the output of 'emerge --info =dev-libs/gjs-0.6',
 * the complete build log and the output of 'emerge -pqv =dev-libs/gjs-0.6'.
 * This ebuild is from an overlay named 'gnome': '/var/lib/layman/gnome/'
 * The complete build log is located at '/var/tmp/portage/dev-libs/gjs-0.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/gjs-0.6/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/gjs-0.6/work/gjs-0.6'

>>> Failed to emerge dev-libs/gjs-0.6, Log file:

>>>  '/var/tmp/portage/dev-libs/gjs-0.6/temp/build.log'


Reproducible: Always

Steps to Reproduce:
1.emerge -av gjs
2.
3.

Actual Results:  
compile failure

Expected Results:  
compile OK
Comment 1 fkhp 2010-05-23 11:47:18 UTC
Created attachment 232559 [details]
build log
Comment 2 fkhp 2010-05-23 11:48:03 UTC
Created attachment 232561 [details]
emerge --info gjs
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2010-05-25 08:54:03 UTC
dev-libs/gjs?

I can't see this package on portage :/
Comment 4 fkhp 2010-05-25 13:03:32 UTC
(In reply to comment #3)
> dev-libs/gjs?
> 
> I can't see this package on portage :/
> 

sorry, it is from gnome overly. 
Comment 5 Michael Weber (RETIRED) gentoo-dev 2010-05-31 02:36:32 UTC
Can you please rename this ebuild to gjs-0.7.ebuild, run `repoman fix` and check if the problem still exists?
Comment 6 fkhp 2010-05-31 04:34:14 UTC
Created attachment 233601 [details]
emerge --info
Comment 7 fkhp 2010-05-31 04:35:49 UTC
Created attachment 233603 [details]
build log
Comment 8 fkhp 2010-05-31 04:36:35 UTC
(In reply to comment #5)
> Can you please rename this ebuild to gjs-0.7.ebuild, run `repoman fix` and
> check if the problem still exists?
> 

still fails.
Comment 9 fkhp 2010-05-31 04:39:50 UTC
(In reply to comment #5)
> Can you please rename this ebuild to gjs-0.7.ebuild, run `repoman fix` and
> check if the problem still exists?
> 

gcc-4.4.3/4.5.0 both fails.
Comment 10 Gilles Dartiguelongue gentoo-dev 2010-08-25 08:17:15 UTC
*** Bug 329095 has been marked as a duplicate of this bug. ***
Comment 11 Gilles Dartiguelongue gentoo-dev 2010-10-22 22:55:00 UTC
0.7 is in overlay and works fine with gcc4.4 afaict. Thanks for reporting.
Comment 12 Guillaume ZITTA 2011-02-13 22:42:19 UTC
I've the same problem, but compiles with USE=-coverage
Comment 13 Gilles Dartiguelongue gentoo-dev 2011-02-14 09:52:32 UTC
guys, gjs 0.6 is gone, please open a new bug if you are having the problem with 0.7.10.