Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 321055 - dev-ruby/minitest-1.6.0 fails tests with JRuby
Summary: dev-ruby/minitest-1.6.0 fails tests with JRuby
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Ruby Team
URL: http://rubyforge.org/tracker/index.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-22 15:31 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2014-02-06 06:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (minitest-1.6.0:20100522-134457.log,12.13 KB, text/plain)
2010-05-22 15:31 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-05-22 15:31:35 UTC
Bug to help track the issue with upstream as well…

Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.5.0-asneeded, glibc-2.11.1-r0, 2.6.34 i686)
=================================================================
System uname: Linux-2.6.34-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.1
Timestamp of tree: Thu, 20 May 2010 20:05:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-python/pycrypto: 2.1.0
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.4_p6-r1, 1.5-r1, 1.6.3-r1, 1.7.9-r2, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.5.0
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb /var/qmail/alias /var/qmail/control /var/spool/torque /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree-tinderbox"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap ncurses nls nostatic nptl nptlonly openmp pam pcre perl pppd python qt3support readline reflection ruby session spl ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18 jruby ruby19" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-05-22 15:31:45 UTC
Created attachment 232471 [details]
Build log
Comment 2 Christian Faulhammer (RETIRED) gentoo-dev 2010-07-18 08:56:55 UTC
This holding up stabilisation of some Ruby packages.  Any comments here?
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2010-07-18 15:50:29 UTC
(In reply to comment #2)
> This holding up stabilisation of some Ruby packages.  Any comments here?
> 

There's 1.7.0 out. Could try bumping and see if it helps.
Comment 4 Hans de Graaff gentoo-dev 2010-07-19 08:44:22 UTC
(In reply to comment #3)

> There's 1.7.0 out. Could try bumping and see if it helps.

I've tried locally and it still has failures. I think some of these might be caused by the way we install jruby, but I have not had time to start tracking it down yet.

Comment 5 Alistair Bush (RETIRED) gentoo-dev 2010-07-19 09:30:11 UTC
(In reply to comment #4)
> (In reply to comment #3)
> 
> > There's 1.7.0 out. Could try bumping and see if it helps.
> 
> I've tried locally and it still has failures. I think some of these might be
> caused by the way we install jruby, but I have not had time to start tracking
> it down yet.
> 

I agree.  We should "mask" or filter tests for jruby in the meantime with a ewarn explaining it.

Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2010-07-20 07:39:14 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > 
> > > There's 1.7.0 out. Could try bumping and see if it helps.
> > 
> > I've tried locally and it still has failures. I think some of these might be
> > caused by the way we install jruby, but I have not had time to start tracking
> > it down yet.
> > 
> 
> I agree.  We should "mask" or filter tests for jruby in the meantime with a
> ewarn explaining it.

 Please do that.
Comment 7 Hans de Graaff gentoo-dev 2010-07-21 07:35:59 UTC
(In reply to comment #6)

>  Please do that.

Done for minitest-1.6.0 and minitest-1.7.0. I'll leave this bug open because the underlying issue obviously is not fixed.

Comment 8 Hans de Graaff gentoo-dev 2012-04-30 06:59:06 UTC
Still a problem with minitest 2.12.0 and jruby 1.6.7.
Comment 9 Hans de Graaff gentoo-dev 2014-02-06 06:32:55 UTC
Closing this bug since upstream closed it as WONTFIX and current minitest ebuilds avoid the failing tests on jruby.