Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 320549 - sys-apps/usb_modeswitch-1.1.2 doesnt work with zte mf637
Summary: sys-apps/usb_modeswitch-1.1.2 doesnt work with zte mf637
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 320587 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-19 12:03 UTC by niv
Modified: 2010-06-26 10:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description niv 2010-05-19 12:03:51 UTC
when using usb_modeswitch-1.1.1 with the zte mf637 cellular modem , it worked fine.
After upgrading to 1.1.2 the pc no longer finds the modem

Reproducible: Always

Steps to Reproduce:
1.1.1 /var/log/messges 
May 19 13:41:59 zahi kernel: usb 3-1: new full speed USB device using uhci_hcd and address 5
May 19 13:41:59 zahi kernel: usb 3-1: not running at top speed; connect to a high speed hub
May 19 13:41:59 zahi kernel: usb 3-1: New USB device found, idVendor=19d2, idProduct=0031
May 19 13:41:59 zahi kernel: usb 3-1: New USB device strings: Mfr=3, Product=2, SerialNumber=4
May 19 13:41:59 zahi kernel: usb 3-1: Product: ZTE CDMA Technologies MSM
May 19 13:41:59 zahi kernel: usb 3-1: Manufacturer: ZTE,Incorporated
May 19 13:41:59 zahi kernel: usb 3-1: SerialNumber: 1234567890ABCDEF
May 19 13:41:59 zahi kernel: usb-storage: USB Mass Storage device detected
May 19 13:41:59 zahi kernel: usb-storage: -- associate_dev
May 19 13:41:59 zahi kernel: usb-storage: Vendor: 0x19d2, Product: 0x0031, Revision: 0x0000
May 19 13:41:59 zahi kernel: usb-storage: Interface Subclass: 0x06, Protocol: 0x50
May 19 13:41:59 zahi kernel: usb-storage: Transport: Bulk
May 19 13:41:59 zahi kernel: usb-storage: Protocol: Transparent SCSI
May 19 13:41:59 zahi kernel: scsi3 : usb-storage 3-1:1.2
May 19 13:41:59 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:41:59 zahi kernel: usb-storage 3-1:1.2: device found
May 19 13:41:59 zahi kernel: usb-storage 3-1:1.2: waiting for device to settle before scanning
May 19 13:42:00 zahi kernel: usbcore: registered new interface driver usbserial
May 19 13:42:00 zahi kernel: usbserial: USB Serial Driver core
May 19 13:42:00 zahi kernel: USB Serial support registered for GSM modem (1-port)
May 19 13:42:00 zahi kernel: option 3-1:1.0: GSM modem (1-port) converter detected
May 19 13:42:00 zahi kernel: usb 3-1: GSM modem (1-port) converter now attached to ttyUSB0
May 19 13:42:00 zahi kernel: option 3-1:1.1: GSM modem (1-port) converter detected
May 19 13:42:00 zahi kernel: usb 3-1: GSM modem (1-port) converter now attached to ttyUSB1
May 19 13:42:00 zahi kernel: option 3-1:1.3: GSM modem (1-port) converter detected
May 19 13:42:00 zahi kernel: usb 3-1: GSM modem (1-port) converter now attached to ttyUSB2
May 19 13:42:00 zahi kernel: usbcore: registered new interface driver option
May 19 13:42:00 zahi kernel: option: v0.7.2:USB Driver for GSM modems
May 19 13:42:00 zahi usb_modeswitch: switched to 19d2:0031 (ZTE,Incorporated: ZTE CDMA Technologies MSM)
May 19 13:42:01 zahi logger: usb_modeswitch: adding device ID 19d2:0031 to driver "option"
May 19 13:42:04 zahi kernel: usb-storage: usb_stor_control_msg: rq=fe rqtype=a1 value=0000 index=02 len=1
May 19 13:42:04 zahi kernel: usb-storage: GetMaxLUN command result is 1, data is 0
May 19 13:42:04 zahi kernel: usb-storage: queuecommand called
May 19 13:42:04 zahi kernel: usb-storage: *** thread awakened.
May 19 13:42:04 zahi kernel: usb-storage: Command INQUIRY (6 bytes)
May 19 13:42:04 zahi kernel: usb-storage:  12 00 00 00 24 00
May 19 13:42:04 zahi kernel: usb-storage: Bulk Command S 0x43425355 T 0x1 L 36 F 128 Trg 0 LUN 0 CL 6
May 19 13:42:04 zahi kernel: usb-storage: usb_stor_bulk_transfer_buf: xfer 31 bytes
May 19 13:42:04 zahi kernel: usb-storage: Status code 0; transferred 31/31
May 19 13:42:04 zahi kernel: usb-storage: -- transfer complete
May 19 13:42:04 zahi kernel: usb-storage: Bulk command transfer result=0
May 19 13:42:04 zahi kernel: usb-storage: usb_stor_bulk_transfer_sglist: xfer 36 bytes, 1 entries
May 19 13:42:04 zahi kernel: usb-storage: Status code 0; transferred 36/36
May 19 13:42:04 zahi kernel: usb-storage: -- transfer complete
May 19 13:42:04 zahi kernel: usb-storage: Bulk data transfer result 0x0
May 19 13:42:04 zahi kernel: usb-storage: Attempting to get CSW...
May 19 13:42:04 zahi kernel: usb-storage: usb_stor_bulk_transfer_buf: xfer 13 bytes
May 19 13:42:04 zahi kernel: usb-storage: Status code 0; transferred 13/13
May 19 13:42:04 zahi kernel: usb-storage: -- transfer complete
May 19 13:42:04 zahi kernel: usb-storage: Bulk status result = 0
May 19 13:42:04 zahi kernel: usb-storage: Bulk Status S 0x53425355 T 0x1 R 0 Stat 0x0
May 19 13:42:04 zahi kernel: usb-storage: scsi cmd done, result=0x0
May 19 13:42:04 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:42:04 zahi kernel: scsi 3:0:0:0: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
Actual Results:  
1.1.2 :
May 19 13:35:38 zahi kernel: usb 3-1: new full speed USB device using uhci_hcd and address 3
May 19 13:35:38 zahi kernel: usb 3-1: not running at top speed; connect to a high speed hub
May 19 13:35:38 zahi kernel: usb 3-1: New USB device found, idVendor=19d2, idProduct=2000
May 19 13:35:38 zahi kernel: usb 3-1: New USB device strings: Mfr=3, Product=2, SerialNumber=4
May 19 13:35:38 zahi kernel: usb 3-1: Product: ZTE CDMA Technologies MSM
May 19 13:35:38 zahi kernel: usb 3-1: Manufacturer: ZTE,Incorporated
May 19 13:35:38 zahi kernel: usb 3-1: SerialNumber: P673A3CDROMMS+MS
May 19 13:35:38 zahi kernel: usb-storage: USB Mass Storage device detected
May 19 13:35:38 zahi kernel: usb-storage: -- associate_dev
May 19 13:35:38 zahi kernel: usb-storage: Vendor: 0x19d2, Product: 0x2000, Revision: 0x0000
May 19 13:35:38 zahi kernel: usb-storage: Interface Subclass: 0x06, Protocol: 0x50
May 19 13:35:38 zahi kernel: usb-storage: Transport: Bulk
May 19 13:35:38 zahi kernel: usb-storage: Protocol: Transparent SCSI
May 19 13:35:38 zahi kernel: scsi1 : usb-storage 3-1:1.0
May 19 13:35:38 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:38 zahi kernel: usb-storage 3-1:1.0: device found
May 19 13:35:38 zahi kernel: usb-storage 3-1:1.0: waiting for device to settle before scanning
May 19 13:35:43 zahi kernel: usb-storage: usb_stor_control_msg: rq=fe rqtype=a1 value=0000 index=00 len=1
May 19 13:35:43 zahi kernel: usb-storage: GetMaxLUN command result is 1, data is 0
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Command INQUIRY (6 bytes)
May 19 13:35:43 zahi kernel: usb-storage:  12 00 00 00 24 00
May 19 13:35:43 zahi kernel: usb-storage: Bulk Command S 0x43425355 T 0x1 L 36 F 128 Trg 0 LUN 0 CL 6
May 19 13:35:43 zahi kernel: usb-storage: usb_stor_bulk_transfer_buf: xfer 31 bytes
May 19 13:35:43 zahi kernel: usb-storage: Status code 0; transferred 31/31
May 19 13:35:43 zahi kernel: usb-storage: -- transfer complete
May 19 13:35:43 zahi kernel: usb-storage: Bulk command transfer result=0
May 19 13:35:43 zahi kernel: usb-storage: usb_stor_bulk_transfer_sglist: xfer 36 bytes, 1 entries
May 19 13:35:43 zahi kernel: usb-storage: Status code 0; transferred 36/36
May 19 13:35:43 zahi kernel: usb-storage: -- transfer complete
May 19 13:35:43 zahi kernel: usb-storage: Bulk data transfer result 0x0
May 19 13:35:43 zahi kernel: usb-storage: Attempting to get CSW...
May 19 13:35:43 zahi kernel: usb-storage: usb_stor_bulk_transfer_buf: xfer 13 bytes
May 19 13:35:43 zahi kernel: usb-storage: Status code 0; transferred 13/13
May 19 13:35:43 zahi kernel: usb-storage: -- transfer complete
May 19 13:35:43 zahi kernel: usb-storage: Bulk status result = 0
May 19 13:35:43 zahi kernel: usb-storage: Bulk Status S 0x53425355 T 0x1 R 0 Stat 0x0
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x0
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: scsi 1:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad LUN (0:1)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (1:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (2:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (3:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (4:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (5:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (6:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage: queuecommand called
May 19 13:35:43 zahi kernel: usb-storage: *** thread awakened.
May 19 13:35:43 zahi kernel: usb-storage: Bad target number (7:0)
May 19 13:35:43 zahi kernel: usb-storage: scsi cmd done, result=0x40000
May 19 13:35:43 zahi kernel: usb-storage: *** thread sleeping.
May 19 13:35:43 zahi kernel: usb-storage 3-1:1.0: scan complete
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2010-05-20 14:22:00 UTC
*** Bug 320587 has been marked as a duplicate of this bug. ***
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2010-05-21 19:13:44 UTC
Could you maybe post the syslog output when you plug in the modem with usb_modeswitch-1.1.1?

For the sake of completeness please also post the output of

  emerge --info usb_modeswitch

and the output of 

  lsusb

when the modem is plugged into your computer.
Comment 3 niv 2010-05-23 14:41:52 UTC
Even when using the 1.1.2 bin with the 1.1.1 conf files , my cellular doesnt work. so the issue is in the bin itself.

I would suggest masking it


# lsusb
Bus 002 Device 004: ID 19d2:0031 ONDA Communication S.p.A.

$ emerge --info usb_modeswitch
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.33-gentoo-r1 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.33-gentoo-r1-i686-Intel-R-_Pentium-R-_4_CPU_1.80GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 19 May 2010 08:45:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.4-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.5, 1.7.9-r2, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/X11/xkb /usr/share/config /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirror.pw.edu.pl/ http://mirrors.ludost.net/gentoo/ http://gentoo.supp.name/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="he"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/tante /usr/local/portage_overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa apache2 avahi berkdb bidi bonjour bzip2 cairo cdparanoia cli cracklib crypt cups cxx dbus dri dts exif flac fortran gdbm gif gpm gtk hal iconv jack jpeg json laptop ldap mmx modules mp3 mp4 mudflap mysql ncurses nls nptl nptlonly opengl openmp oss pam pcre perl png posix pppd python readline reflection samba scanner session speex spell spl sse sse2 ssl sysfs tcpd tiff truetype unicode usb v4l v4l2 vorbis win32codecs x264 x86 xcomposite xinerama xorg xvid zeroconf zlib" ALSA_CARDS="snd-ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="tda1004x" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="he" LIRC_DEVICES="hauppauge hauppauge_dvb" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-apps/usb_modeswitch-1.1.1 was built with the following:
USE="" 

Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-06-26 10:58:32 UTC
Try 1.1.3, reopen if it doesn't work