Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 319455 - kde4 some of applications start behind the plasma or desktop
Summary: kde4 some of applications start behind the plasma or desktop
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2010-05-12 19:12 UTC by Michal Augustyniak
Modified: 2010-05-28 04:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Michal Augustyniak 2010-05-12 19:12:21 UTC
I have noticed bizare behavior of some application which starts but are invisible. Dragon and digikam are that apps. Not sure what the reason is and where should I post a bug or issue. Could not find anything like that in internet.

So basically how i know that apps actually starts: 
 - the process exists.

How I know that apps lives behind the plasma or desktop: 
 - when I close the system and the system is shutting down the screen goes black like normally , then on a second the screen is black that invisible apps are actully there previously opened. Weired ha !?

It is very bizare and cannot figure it out.

When I start dragon I see on few seconds tab on kde bottom panel, then disappearing.
When I start digikam it actually open the window with initializing Main View message, this sits till I click on it, then disappearing too.

Please help
Thought I will post some info about the system, let me know if you need more info:

# emerge --info
Portage (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r10 i686)
System uname: Linux-2.6.31-gentoo-r10-i686-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-gentoo-1.12.13
Timestamp of tree: Sat, 08 May 2010 03:00:01 +0000                                                       
app-shells/bash:     4.0_p37                                                                             
dev-java/java-config: 2.1.10                                                                             
dev-lang/python:     2.6.4-r1                                                                            
dev-util/cmake:      2.6.4-r3                                                                            
sys-apps/baselayout: 1.12.13                                                                             
sys-apps/sandbox:    1.6-r2                                                                              
sys-devel/autoconf:  2.13, 2.65                                                                          
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1                                                  
sys-devel/binutils:  2.18-r3                                                                             
sys-devel/gcc:       4.3.4                                                                               
sys-devel/gcc-config: 1.4.1                                                                              
sys-devel/libtool:   2.2.6b                                                                              
virtual/os-headers:  2.6.30-r1                                                                           
CFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"                                                      
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"                               
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"                                                                                                                          
CXXFLAGS="-march=i686 -O2 -pipe -fomit-frame-pointer"                                                                                                                                                                                        
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X accessibility acpi alsa amd apache2 apm arts bash-completion berkdb bluetooth bzip2 cairo cdr clamav cli consolekit crypt curl dbus dvd dvdr expat fam ffmpeg ftp gd gdbm gif gstreamer hal iconv imap java jpeg kde keyboard libwww mmx mng mouse mozilla mp3 mp4 mplayer mysql ncurses nls nptl odbc ogg opengl pam pcf pcre pdflib perl perlsuid plasma png posix python qt qt3support qt4 readline samba session snmp spell sql sse sse2 ssl svg svga tcpd threads tiff truetype usb v4l v4l2 video webkit wifi x86 xcb xinerama xml xmlrpc xpm zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="*" APACHE2_MODULES="alias auth_basic authz_host dir log_config mime mime_magic rewrite vhost_alias actions asis auth_digest authn_alias authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_owner authz_user autoindex cache cern_meta charset_lite dav dav_fs dav_lock dbd deflate disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_forensic logio mem_cache negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http setenvif speling status unique_id userdir usertrack version" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" NETBEANS_MODULES="*" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Reproducible: Always
Comment 1 Michal Augustyniak 2010-05-12 20:10:03 UTC
I ment Dragon Player.

Same issue for amarok as digikam, the main pre window shows up, then I click on it disappeared, process still exists.

What I am missing, lib ??
I have tried rebuild that apps

Please help
Comment 2 Michal Augustyniak 2010-05-13 03:43:53 UTC
I have rebuild that packages, did not help at all.

soprano plasma-runtime kdebase-runtime-meta


emerge -uDNp world

misiek # emerge -uDNp world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-lang/swig-1.3.36  USE="java*"
[ebuild  N    ] media-libs/raptor-1.4.20  USE="curl xml -debug -unicode"
[ebuild   R   ] dev-libs/soprano-2.3.1-r1  USE="raptor*"
[ebuild  N    ] media-libs/gd-2.0.35-r1  USE="jpeg png truetype xpm -fontconfig"
[ebuild  N    ] app-crypt/mit-krb5-1.6.3-r6  USE="-doc -krb4"
[ebuild  N    ] media-gfx/graphviz-2.26.0  USE="cairo java nls perl python -doc -examples -gtk -lasi -ruby -tcl"
[ebuild  N    ] app-doc/doxygen-1.5.8-r1  USE="qt4 -debug -doc -latex -nodot"
[ebuild   R   ] kde-base/kdelibs-4.3.5  USE="3dnow* acl* debug* doc* handbook* jpeg2k* kerberos* lzma* openexr* semantic-desktop*"
[ebuild  N    ] kde-base/nepomuk-4.3.5  USE="(-aqua) -debug -handbook (-kdeenablefinal) (-kdeprefix)"
[ebuild   R   ] media-sound/amarok-2.2.2-r1  USE="semantic-desktop*"
[ebuild   R   ] media-gfx/digikam-1.1.0  USE="semantic-desktop*"
Comment 3 Michal Augustyniak 2010-05-13 22:09:42 UTC
really no thoughts ???
Comment 4 Michal Augustyniak 2010-05-13 22:09:56 UTC
really no thoughts ???
Comment 5 Michal Augustyniak 2010-05-27 17:25:38 UTC
Fixed it was phonon problem.

PluginLoader::KPluginLoader: Could not find plugin/library for "phononbackends/xine.desktop" library name: "phonon_xine"

I have reemerge qt-core and qt-qui with glib flag, after that again phonon and phonon-kde

This error is till there but at least my apps are working 

dragon, digikam, amarok finally showing up
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2010-05-27 22:55:17 UTC
Ok resolving then.
Comment 7 Michal Augustyniak 2010-05-28 04:08:01 UTC
(In reply to comment #6)
> Ok resolving then.

was so exicted forgot to close