Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 319163 - kde-base/kopete-4.4.3: USE winpopup needs net-fs/samba[server,smbclient] as RDEPEND
Summary: kde-base/kopete-4.4.3: USE winpopup needs net-fs/samba[server,smbclient] as R...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2010-05-10 16:46 UTC by Nikoli
Modified: 2010-06-07 02:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikoli 2010-05-10 16:46:00 UTC
Try to create winpopup account - you need to set path to smbclient.

Reproducible: Always
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-06-06 23:37:37 UTC
kopete has no build or run-time dependency on samba. I suspect it just uses a samba binary when trying to send messages through  winpopup.
In that case, we'll add a pkg_postinst warning, but it doesn't justify a dep.
Comment 2 Nikoli 2010-06-07 01:20:43 UTC
You are wrong, unpack kdenetwork-4.4.4.tar.bz2 and do 'grep -Ri -e samba -e smb kopete/protocols/winpopup/'. Without samba kopete does not work with winpopup protocol. Not only one feature of protocol, but all. Why you think is not enough for RDEPEND, what is enough then?

pkg_postinst should tell that winpopup needs running samba server.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-06-07 02:38:45 UTC
You can use the following to check run-time dependencies of an installed package. Running that on kopete built with winpopup doesn't list samba.

qlist -vo ${1} | xargs scanelf -L -n -q -F '%n #F' | tr , ' ' | xargs qfile -C | sort -u

So as there's no linking to samba, the only other option is for kopete to call a binary directly - a bit like krdc and rdesktop. You can confirm this by grepping the sources for smb.
In any case, I've now added the samba run-time dependency for the winpopup use flag - but the reason it wasn't added or identified before is that the CMakeLists.txt have no mention of samba.