Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 31864 - "emerge rsync" will attempt to do an "emerge sync" instead of emerging the rsync package
Summary: "emerge rsync" will attempt to do an "emerge sync" instead of emerging the r...
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-23 17:30 UTC by Sumit Khanna
Modified: 2011-10-30 22:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Khanna 2003-10-23 17:30:42 UTC
example, if I do an "emerge -Up rsync" it will tell me that -p (pretend) can't
be using when doing an "emerge sync". Doing "emerge rsync" will begin to do an
"emerge sync" instead. The problem lies in the way emerge handles command line
arguments. This could becomne a problem with other packages that contian the
word "sync"

Reproducible: Always
Steps to Reproduce:
1. "emerge -Up rsync" OR
2. "emerge rsync"
3.

Actual Results:  
it fails to emerge rsync and instead thinks I want to sync the portage tree.

Expected Results:  
emerge the rsync tool
Comment 1 SpanKY gentoo-dev 2003-10-23 22:02:33 UTC

*** This bug has been marked as a duplicate of 2365 ***