Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 317999 - media-tv/xbmc-9999 compiles but fails to install
Summary: media-tv/xbmc-9999 compiles but fails to install
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Xbox herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-01 12:10 UTC by hal
Modified: 2010-05-23 18:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hal 2010-05-01 12:10:45 UTC
latest development revisions of xbmc-9999 fail to install. it gets compiled successfully but the last step, the installation itself, fails.

error message:
>>> Source compiled.
>>> Test phase [not enabled]: media-tv/xbmc-9999

>>> Install xbmc-9999 into /var/tmp/portage/media-tv/xbmc-9999/image/ category media-tv
Copying XBMC binary to /var/tmp/portage/media-tv/xbmc-9999/image/usr/share/xbmc/xbmc.bin
You can run XBMC with the command 'xbmc'
find: `screensavers': No such file or directory                                
find: `visualisations': No such file or directory
make: *** [install-arch] Error 1
 * ERROR: media-tv/xbmc-9999 failed:
 *   einstall failed
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_install
 *   environment, line 2990:  Called einstall
 *     ebuild.sh, line  588:  Called die
 * The specific snippet of code:
 *   		${MAKE:-make} prefix="${D}usr" \
 *   			datadir="${D}usr/share" \
 *   			infodir="${D}usr/share/info" \
 *   			localstatedir="${D}var/lib" \
 *   			mandir="${D}usr/share/man" \
 *   			sysconfdir="${D}etc" \
 *   			${LOCAL_EXTRA_EINSTALL} \
 *   			${MAKEOPTS} ${EXTRA_EMAKE} -j1 \
 *   			"$@" install || die "einstall failed"
 * 
 * If you need support, post the output of 'emerge --info =media-tv/xbmc-9999',
 * the complete build log and the output of 'emerge -pqv =media-tv/xbmc-9999'.
 * This ebuild is from an overlay named 'local xbmc overlay': '/usr/local/portage/xbmc-overlay/'
 * The complete build log is located at '/var/log/portage/media-tv:xbmc-9999:20100501-131035.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/xbmc-9999/temp/environment'.
 * S: '/var/tmp/portage/media-tv/xbmc-9999/work/xbmc-9999'

>>> Failed to emerge media-tv/xbmc-9999, Log file:

>>>  '/var/log/portage/media-tv:xbmc-9999:20100501-131035.log'

---------------------------------------------------

emerge --info =media-tv/xbmc-9999
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.33-gentoo-r1 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.33-gentoo-r1-i686-Intel-R-_Atom-TM-_CPU_330_@_1.60GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 01 May 2010 09:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.4-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests candy ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="bzip2"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/xbmc-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi bash-completion berkdb bluetooth bzip2 cairo cddb cdr cli consolekit cpudetection cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif fam fbcondecor fbsplash ffmpeg firefox flac fortran gdbm gif gpm hal iconv jpeg jpeg2k laptop lcms libnotify libsamplerate lirc lm_sensors mad mikmod minimal mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support readline reflection sdl session spell spl sse sse2 ssl startup-notification svg symlink sysfs syslog tcpd theora threads tiff truetype unicode usb v4l2 vdpau vorbis x264 x86 xcb xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" LIRC_DEVICES="devinput" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-tv/xbmc-9999 was built with the following:
USE="aac alsa avahi css debug joystick sse sse2 vdpau xrandr (-altivec) -midi -profile -pulseaudio" 
CFLAGS="-march=prescott -O2 -pipe -ggdb"
CXXFLAGS="-march=prescott -O2 -pipe -ggdb"

---------------------------------------------------

emerge -pqv =media-tv/xbmc-9999
[ebuild   R   ] media-tv/xbmc-9999  USE="aac alsa avahi css debug joystick sse sse2 vdpau xrandr (-altivec) -midi -profile -pulseaudio" 

---------------------------------------------------





Reproducible: Always

Steps to Reproduce:
1. emerge xbmc-9999
2. xbmc is getting compiled


Actual Results:  
xbmc fails to install

Expected Results:  
xbmc should get installed
Comment 1 hal 2010-05-02 11:24:28 UTC
seems to be a issue upstream: http://forum.xbmc.org/showthread.php?t=73059
Comment 2 hal 2010-05-03 02:01:27 UTC
fixed.

see: http://forum.xbmc.org/showpost.php?p=530933&postcount=8
Comment 3 SpanKY gentoo-dev 2010-05-23 18:44:25 UTC
not a Gentoo bug