Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 315989 - dev-perl/Crypt-SSLeay-0.57: network tests fail
Summary: dev-perl/Crypt-SSLeay-0.57: network tests fail
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2010-04-18 16:32 UTC by Kirikaza
Modified: 2014-02-04 12:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log (Crypt-SSLeay-0.57.log,5.36 KB, text/plain)
2010-04-21 20:13 UTC, Kirikaza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kirikaza 2010-04-18 16:32:52 UTC
If I set $http_proxy to use my local proxy server (Squid) it fails as follows:
================================================================
make -j3 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.10.1 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic.t .... ok     
t/01-connect.t .. 1/8 
#   Failed test 'Net::SSL->new'
#   at t/01-connect.t line 25.
# proxy connect failed: Bad arg length for Socket::pack_sockaddr_in, length is 9, should be 4 at /usr/lib/perl5/5.10.1/i686-linux/IO/Socket/INET.pm line 257.
# ;  at t/01-connect.t line 11
# Looks like you failed 1 test of 8.
t/01-connect.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/8 subtests 
        (less 7 skipped subtests: 0 okay)
t/02-live.t ..... 1/4 # config on linux
# ssl OpenSSL 0.9.8 in /usr
# lib -L/usr/lib -lssl -lcrypto -lgcc
# inc -I/usr/include/openssl
# cc /usr/bin/gcc
t/02-live.t ..... ok   

Test Summary Report
-------------------
t/01-connect.t (Wstat: 256 Tests: 8 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=3, Tests=24,  0 wallclock secs ( 0.06 usr  0.02 sys +  0.34 cusr  0.06 csys =  0.48 CPU)
Result: FAIL
Failed 1/3 test programs. 1/24 subtests failed.
================================================================
If I unset the $http_proxy it fails again but with another error:
================================================================
make -j3 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.10.1 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic.t .... ok     
t/01-connect.t .. 1/8 
#   Failed test 'Net::SSL->new'
#   at t/01-connect.t line 25.
# proxy connect failed: Bad arg length for Socket::pack_sockaddr_in, length is 9, should be 4 at /usr/lib/perl5/5.10.1/i686-linux/IO/Socket/INET.pm line 257.
# ;  at t/01-connect.t line 11
# Looks like you failed 1 test of 8.
t/01-connect.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/8 subtests 
        (less 7 skipped subtests: 0 okay)
t/02-live.t ..... 1/4 # config on linux
# ssl OpenSSL 0.9.8 in /usr
# lib -L/usr/lib -lssl -lcrypto -lgcc
# inc -I/usr/include/openssl
# cc /usr/bin/gcc
t/02-live.t ..... ok   

Test Summary Report
-------------------
t/01-connect.t (Wstat: 256 Tests: 8 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=3, Tests=24,  1 wallclock secs ( 0.07 usr  0.01 sys +  0.40 cusr  0.06 csys =  0.54 CPU)
Result: FAIL
Failed 1/3 test programs. 1/24 subtests failed.
================================================================
Comment 1 Kirikaza 2010-04-18 16:44:12 UTC
(In reply to comment #0)
Oops, I'm sorry, errors are the same... Yes, they are.
Comment 2 Torsten Veller (RETIRED) gentoo-dev 2010-04-21 10:07:53 UTC
I can't reproduce it. What's your http_proxy config?
Comment 3 Kirikaza 2010-04-21 20:13:55 UTC
Created attachment 228661 [details]
emerge log

Full emerge log *without* http(s)_proxy variables. They are not related to the failure.
Comment 4 David Abbott gentoo-dev 2010-08-26 00:54:58 UTC
I can't reproduce it here;
make -j3 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.12.1 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic.t .... ok     
t/01-connect.t .. ok   
t/02-live.t ..... 1/4 # config on linux
# ssl OpenSSL 0.9.8 in /usr
# lib -L/usr/lib -lssl -lcrypto -lgcc
# inc -I/usr/include/openssl
# cc i686-pc-linux-gnu-gcc
t/02-live.t ..... ok   
All tests successful.
Files=3, Tests=24,  1 wallclock secs ( 0.04 usr  0.00 sys +  0.40 cusr  0.04 csys =  0.48 CPU)
Result: PASS
Comment 5 Nikoli 2010-08-26 01:13:52 UTC
David, it builds fine for me with LANG=C, but LANG="ru_RU.UTF-8" emerge -1vb dev-perl/Crypt-SSLeay fails, please try building with LANG="ru_RU.UTF-8".

>>> Source compiled.
make -j2 test TEST_VERBOSE=0 
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.8 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-basic......ok                                                           
        4/12 skipped: various reasons
t/01-connect....
#   Failed test 'Net::SSL->new'
#   in t/01-connect.t at line 25.
# Connect failed: connect: В соединении отказано; В соединении отказано at t/01-connect.t line 11
t/01-connect....ok 2/8# Looks like you failed 1 test of 8.                   
t/01-connect....dubious                                                      
        Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 1
        Failed 1/8 tests, 87.50% okay (less 7 skipped tests: 0 okay, 0.00%)
t/02-live.......ok 1/4# config on linux                                      
# ssl OpenSSL 0.9.8 in /usr
# lib -L/usr/lib -lssl -lcrypto -lgcc
# inc -I/usr/include/openssl
# cc x86_64-pc-linux-gnu-gcc
t/02-live.......ok                                                           
        1/4 skipped: Network tests disabled
Failed Test    Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/01-connect.t    1   256     8    1  12.50%  1
12 subtests skipped.
Failed 1/3 test scripts, 66.67% okay. 1/24 subtests failed, 95.83% okay.
make: *** [test_dynamic] Ошибка 255
 * ERROR: dev-perl/Crypt-SSLeay-0.57 failed:
 *   test failed


----
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11.2-r0, 2.6.33-gentoo-r2 x86_64)
=================================================================
Timestamp of tree: Wed, 25 Aug 2010 13:15:01 +0000
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.5-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict test unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/nikoli"
USE="7zip X a52 aac acl acpi akonadi alsa amd64 amr amrnb amrwb ares atm audiofile bash-completion bluetooth bzip2 cairo cdda cddb cdio cdparanoia cdr chroot cli consolekit cracklib crypt css cups cxx dbus divx djvu dri dts dv dvd dvdr dvdread emboss encode exif ffmpeg firefox flac fluidsynth fontconfig fortran gd geoip gif gimp glitz gmp gnutls gphoto2 gpm graphviz gstreamer gtk hal handbook iconv id3tag idn ieee1394 imagemagick imap imlib ipv6 jbig jpeg jpeg2k kde kipi kontact ladspa lame laptop lcms libproxy libsamplerate libwww lm_sensors lzma lzo mad matroska md5sum mikmod mmx mmxext mng modplug modules mp3 mp4 mpeg mtp mudflap multilib musepack musicbrainz ncurses nls nptl nptlonly ntfs nvidia obex ogg openal opencore-amr openexr opengl openmp pam pango pcre pdf perl pg-intdatetime phonon plasma pm-utils png ppds pppd qt3support qt4 quicktime rar raw readline reflection reiserfs sasl scanner schroedinger semantic-desktop session smp sndfile socks5 speex spell spl sqlite sse sse2 sse3 ssl ssse3 startup-notification svg symlink sysfs taglib theora threads thumbnail tiff truetype tta udev unicode upnp usb userlocales v4l v4l2 vaapi vcd vdpau vorbis vpx wavpack webkit wifi wma wmf wps x264 xcb xcomposite xface xml xmp xorg xpm xscreensaver xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" NGINX_MODULES_HTTP="access auth_basic autoindex fastcgi gzip rewrite" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Kirikaza 2010-08-26 05:09:41 UTC
(In reply to comment #5)
> David, it builds fine for me with LANG=C, but LANG="ru_RU.UTF-8" emerge -1vb
> dev-perl/Crypt-SSLeay fails, please try building with LANG="ru_RU.UTF-8".

What about LANG="en_GB.UTF-8"? (I can't try to emerge Crypt-SSLeay myself.) I guess the problem is "UTF-8" not "ru_RU". And "en_GB" is more readable for non-Russians =)
Comment 7 Nikoli 2010-08-26 06:07:57 UTC
No, it builds fine with LANG="en_GB.UTF-8". Now google tranlsate exist.
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-02-04 12:13:38 UTC
Can't reproduce on last stable (0.640.0). Looks like OBSOLETE.