Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 315497 - kde-base/kdelibs-4.4.2 fails to emerge (kde 3 installed)
Summary: kde-base/kdelibs-4.4.2 fails to emerge (kde 3 installed)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
Depends on:
Blocks: 313999
  Show dependency tree
Reported: 2010-04-15 18:09 UTC by B.Rathmann
Modified: 2010-06-22 16:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Build log (build.log,145.60 KB, text/plain)
2010-04-15 18:13 UTC, B.Rathmann

Note You need to log in before you can comment on or make changes to this bug.
Description B.Rathmann 2010-04-15 18:09:36 UTC
When trying to "emerge kdelibs-meta:4.4" the emerge starts and fails at about 21%.
Please note that I have KDE 3.5 (via KDE-Sunset) installed and don't want to kill it off just yet as I am not sure whether I'll like kde4 or not. So I am using USE=kdeprefix

Reproducible: Always

Steps to Reproduce:
1. emerge kdelibs-meta:4.4

Actual Results:  
[ 19%] Building C object kdecore/CMakeFiles/kdecore.dir/fakes.o
Linking CXX shared library ../lib/
[ 19%] Built target kdecore
make: *** [all] Error 2
 * ERROR: kde-base/kdelibs-4.4.2 failed:
 *   Make failed!
 * Call stack:
 *, line   54:  Called src_compile
 *   environment, line 4023:  Called kde4-base_src_compile
 *   environment, line 3109:  Called cmake-utils_src_compile
 *   environment, line 1271:  Called _execute_optionaly 'src_compile'
 *   environment, line  678:  Called enable_cmake-utils_src_compile
 *   environment, line 1636:  Called cmake-utils_src_make
 *   environment, line 1290:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";

Expected Results:  
Well finish compile, install kdelibs and carry on :)

Portage (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 i686)
System uname: Linux-2.6.31-gentoo-r6-i686-Intel-R-_Core-TM-_i5_CPU_660_@_3.33GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 15 Apr 2010 15:45:01 +0000
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.4
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
CFLAGS="-O3 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -march=i686 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="en de"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl alsa berkdb bzip2 cdr cli cracklib crypt cups cxx dbus dlloader dri dvd dvdr dvdread encode ffmpeg fortran gdbm gimpprint gpm hal iconv ipv6 jpeg kde mmx modules mp3 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin odbc ogg opengl openmp pam pcre perl png policykit pppd python qt qt3 qt3support readline reflection scanner seamonkey session spl sql sqlite sse sse2 ssl stream svg sysfs tcpd theora unicode usb vorbis webkit win32codecs x86 xcomposite xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Comment 1 B.Rathmann 2010-04-15 18:13:10 UTC
Created attachment 227945 [details]
Build log
Comment 2 B.Rathmann 2010-04-15 18:15:30 UTC
 emerge -pqv =kde-base/kdelibs-4.4.2
[ebuild  NS   ] kde-base/kdelibs-4.4.2 [3.5.10-r7] USE="acl alsa bzip2 handbook mmx nls opengl policykit sse sse2 ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -fam -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -openexr -semantic-desktop -spell -test -zeroconf"
Comment 3 B.Rathmann 2010-04-15 18:17:43 UTC
Please note that there is a pending email change, the address is no longer valid!
Comment 4 B.Rathmann 2010-04-15 20:02:26 UTC
I just noticed that kdeprefix was not set in this  emerge -pqv =kde-base/kdelibs-4.4.2  (although it is set in make.conf). Tried it again with USE="kdeprefix" emerge kdebase-meta:4.4 with the same result.
Comment 5 Andreas K. Hüttel archtester gentoo-dev 2010-04-15 20:06:41 UTC
You do not need kdeprefix for installing kde-3 and kde-4 at the same time. 

kdeprefix is just for kde-4.x and kde-4.y, and also deprecated. Please do not use it...

Comment 6 B.Rathmann 2010-04-17 06:25:25 UTC
Ok, no problem. Thought is was for seperating KDE 3 and 4.
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2010-06-12 15:34:05 UTC
[0m/var/tmp/portage/kde-base/kdelibs-4.4.2/work/kdelibs-4.4.2_build/bin/icemaker: /usr/lib/ version `GLIBCXX_3.4.9' not found (required by /var/tmp/portage/kde-base/kdelibs-4.4.2/work/kdelibs-4.4.2_build/bin/icemaker)
make[2]: *** [kjs/opcodes.h] Error 1
make[1]: *** [kjs/CMakeFiles/kjs.dir/all] Error 2

This looks like something with your libc went badly wrong. Did you recently install / change libc or gcc?

Is the problem reproducible?

How about kde 4.4.4?
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2010-06-22 16:24:33 UTC
(In reply to comment #7)
> [0m/var/tmp/portage/kde-base/kdelibs-4.4.2/work/kdelibs-4.4.2_build/bin/icemaker:
> /usr/lib/ version `GLIBCXX_3.4.9' not found (required by
> /var/tmp/portage/kde-base/kdelibs-4.4.2/work/kdelibs-4.4.2_build/bin/icemaker)

Not a KDE problem, rather broken system by unfinished gcc upgrade.