Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 314613 - kde-base/gwenview-4.4.4 can not save rotated jpeg image (compiled with jpeg-8a)
Summary: kde-base/gwenview-4.4.4 can not save rotated jpeg image (compiled with jpeg-8a)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: [kde testing]
Keywords: InOverlay, InVCS
: 318523 (view as bug list)
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2010-04-11 05:48 UTC by Nikoli
Modified: 2014-08-31 17:05 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikoli 2010-04-11 05:48:29 UTC
It rotates and saves *png fine, but can not save *jpg. It shows image as rotated, but after pressing "Save" button log says:

gwenview(8297) Gwenview::JPEGErrorManager::errorExitCallBack: Invalid crop request 
gwenview(8297): libjpeg error in src

After restating gwenview image is not rotated.



Reproducible: Always
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2010-04-12 21:35:53 UTC
Just for completeness, please attach the output of emerge --info
Comment 2 Nikoli 2010-04-13 02:43:50 UTC
Portage 2.1.7.17 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r10 x86_64)
=================================================================
Timestamp of tree: Mon, 12 Apr 2010 11:45:03 +0000
app-shells/bash:     4.0_p37
dev-lang/python:     2.6.4-r1
dev-python/pycrypto: 2.1.0_beta1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en"
MAKEOPTS="-j4"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/nikoli"
USE="7zip X a52 aac acl acpi akonadi alsa amd64 amr amrnb amrwb ares atm audiofile bash-completion bluetooth bzip2 cairo cdda cddb cdio cdparanoia cdr chroot cli consolekit cracklib crypt css cups cxx dbus divx djvu dri dts dv dvd dvdr dvdread emboss encode exif ffmpeg firefox flac fluidsynth fontconfig fortran gd geoip gif gimp glitz gmp gnutls gphoto2 gpm graphviz gstreamer gtk hal handbook iconv id3tag idn ieee1394 imagemagick imap imlib ipv6 jbig jpeg jpeg2k kde kipi kontact ladspa lame laptop lcms libsamplerate libwww lm_sensors lzma lzo mad matroska md5sum mikmod mmx mmxext mng modplug modules mp3 mp4 mpeg mplayer mtp mudflap multilib musepack musicbrainz ncurses nls nptl nptlonly ntfs nvidia obex ogg openal opencore-amr openexr opengl openmp pam pango pcre pdf perl pg-intdatetime phonon plasma pm-utils png ppds pppd qt3support qt4 quicktime rar raw readline reflection reiserfs sasl scanner schroedinger semantic-desktop session smp sndfile socks5 speex spell spl sqlite sse sse2 sse3 ssl ssse3 startup-notification svg symlink sysfs taglib tcpd theora threads thumbnail tiff truetype tta unicode upnp usb userlocales v4l v4l2 vcd vdpau vorbis wavpack webkit wifi wma wmf wps x264 xcb xcomposite xface xml xmp xorg xpm xscreensaver xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-04-13 15:05:16 UTC
Please post the output of emerge -pv kdelibs
Comment 4 Nikoli 2010-04-13 15:10:20 UTC
[ebuild   R   ] kde-base/kdelibs-4.4.2  USE="acl alsa bzip2 handbook jpeg2k lzma mmx nls openexr opengl semantic-desktop spell sse sse2 ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -fam (-kdeenablefinal) (-kdeprefix) -kerberos -policykit -test -zeroconf"
Comment 5 Eugene Shalygin 2010-05-02 00:38:29 UTC
http://websvn.kde.org/?view=revision&revision=1098734 - it helps me, but I had a little bit different problem: only first image from sequence of rotated images was saved. But because the fix is initialization of uninitialized variables, maybe it could help here to.
Anyway, it would be good to have this patch in portage because it seems to be not ported to 4.4 branch
Comment 6 simon 2010-06-03 20:01:33 UTC
Same here with current stable kde:

emerge -pv imagemagick kdelibs gwenview

...

[ebuild   R   ] kde-base/kdelibs-4.3.5  USE="3dnow alsa bzip2 fam lzma mmx nls openexr opengl semantic-desktop spell sse sse2 ssl -acl (-altivec) (-aqua) -bindist -debug -doc -handbook -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -test -zeroconf" 0 kB
[ebuild   R   ] media-gfx/imagemagick-6.6.1.2  USE="X bzip2 cxx fontconfig jpeg lcms lqr openexr openmp perl png raw svg tiff truetype xml zlib -autotrace -djvu -fftw -fpx -graphviz -gs -hdri -jbig -jpeg2k -q32 -q8 -static-libs -wmf" 0 kB
[ebuild   R   ] kde-base/gwenview-4.3.5  USE="kipi (-aqua) -debug -handbook (-kdeenablefinal) (-kdeprefix) -semantic-desktop" 0 kB

output of "emerge --info":

Portage 2.2_rc67 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.10.1-r1, 2.6.34-gentoo x86_64)                                 
=================================================================                                                             
System uname: Linux-2.6.34-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3800+-with-gentoo-2.1.6                     
Timestamp of tree: Mon, 31 May 2010 11:30:01 +0000             
app-shells/bash:     4.0_p28                                   
dev-java/java-config: 2.1.10                                   
dev-lang/python:     2.6.5-r2                                  
dev-util/cmake:      2.6.4-r3                                  
sys-apps/baselayout: 2.1.6                                     
sys-apps/openrc:     0.6.0                                     
sys-apps/sandbox:    2.2                                       
sys-devel/autoconf:  2.13, 2.65                                
sys-devel/automake:  1.10.3, 1.11.1                            
sys-devel/binutils:  2.20.1                                    
sys-devel/gcc:       4.3.3-r2, 4.4.3                           
sys-devel/gcc-config: 1.4.1                                    
sys-devel/libtool:   2.2.6b                                    
virtual/os-headers:  2.6.32                                    
ACCEPT_KEYWORDS="amd64"                                        
ACCEPT_LICENSE=""                           
CBUILD="x86_64-pc-linux-gnu"                                   
CFLAGS="-O2 -march=k8-sse3 -pipe"                              
CHOST="x86_64-pc-linux-gnu"                                    
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"     
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8-sse3 -pipe"                            
DISTDIR="/var/Gentoo/distfiles"                                
FEATURES="assume-digests distlocks fixpackages news preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch usersync"                                      
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ "          
LANG="de_AT.UTF-8"                                             
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"            
LINGUAS="de"                                                   
MAKEOPTS="-j5"                                                 
PKGDIR="/var/Gentoo/packages"                                  
PORTAGE_CONFIGROOT="/"                                         
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"                                                         
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                              
PORTAGE_TMPDIR="/var/tmp"                                      
PORTDIR="/usr/portage"                                         
PORTDIR_OVERLAY="/usr/local/portage"                           
SYNC="rsync://rsync.gentoo.org/gentoo-portage"                 
USE="3dnow 3dnowext X a52 aac acpi alac alsa amd64 apache2 bash-completion bzip2 cairo cdda cdr cli cracklib cups cxx dbus dri dv dvd dvdr dvdread encode exif fam ffmpeg flac fontconfig fortran gdbm gif gimp gpm hal iconv ieee1394 imagemagick jack jpeg kde ladspa lame lcms libsamplerate lm_sensors lzma mad mmx mmxext modules mp3 mpeg mudflap multilib mysql ncurses nls nptl nptlonly ogg openexr opengl openmp pam pcre perl png pppd pvr python qt3support qt4 quicktime raw readline reflection sdl session sox spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff truetype unicode usb v4l v4l2 vhosts vorbis x264 xcomposite xml xorg xulrunner xv zip zlib" ALSA_CARDS="intel8x0 ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="radeon v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


I would be happy to find a patch in portagen soon :)
Comment 7 simon 2010-06-04 21:17:26 UTC
By the way, solution from Comment #05 didn't help in my case.
Comment 8 Malte E. 2010-06-09 11:01:10 UTC
This is still an issue in 4.4.4
Comment 9 Andreas K. Hüttel archtester gentoo-dev 2010-06-10 16:03:18 UTC
I had the same issue, and the commit from the upstream bug fixes it fully for me. 

Patch added in the overlay, please test.
Comment 10 Andreas K. Hüttel archtester gentoo-dev 2010-06-10 18:02:14 UTC
*** Bug 318523 has been marked as a duplicate of this bug. ***
Comment 11 Maciej Mrozowski gentoo-dev 2010-06-11 02:55:29 UTC
(In reply to comment #5)
> http://websvn.kde.org/?view=revision&revision=1098734 - it helps me, but I had
> a little bit different problem: only first image from sequence of rotated
> images was saved. But because the fix is initialization of uninitialized
> variables, maybe it could help here to.

It works now, rotation operation now doesn't fail, images are marked as modified and need to be saved (or changes ignored).

> Anyway, it would be good to have this patch in portage

Done in 4.4.4-r1

> because it seems to be not ported to 4.4 branch

and done.

Thanks for all involved in investigating.